3D / Overscan Compensation

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Bochi Offline
Junior Member
Posts: 10
Joined: Jan 2010
Reputation: 0
Location: Nuremberg, Germany
Question  3D / Overscan Compensation
Post: #1
Hi everyone,

first off thanks for XBMC 11 - sweet piece of software :-)

So I recently decided to buy a new fancy 3D TV. I am using the latest XBMCbuntu on an Acer Aspire Revo with NVidia ION graphics. My problem is that in its default configuration, XBMC's screen is too large for my TV, so I set the Skin Zoom to -2 which fits perfectly. Later I noticed that for some videos the picture is still too large for the screen, so I used the "Calibrate" function while playing the video to adjust the screen size. This works great for regular videos, but now I can't watch 3D movies (left-right) anymore. Before I adjusted the video size it worked great, and it appears that now the shift between the 2 pictures that are required for 3D is too large (when looking at it without the shutter glasses one can see that pretty well).

My next step was to remove my user settings and redo them, but this time I gave nvidia-settings a try and set overscan compensation there (which basically has the same effect as what skin zoom/calibrate does) - same problem :-(

Also, I notice that when playing music and using the visualizations the picture is incorrect - it looks like it moves the whole picture a bit to bottom left, and even when playing a video after listening to music there will be a black stripe at the top and the left side.

Did anyone ever see similar issues and maybe even found a way to solve these? I looked in my TV's settings but there is no option to adjust the screen size, so it needs to be done on OS level obviously.

PS. The issue doesn't seem to be XBMCbuntu specific, before it was released I was running XBMC Live but with upgraded XBMC (Beta + RCs), and I had the same issues there. And yes, I know I should have reported this a long time ago during the Beta/RC phase but I didn't get to it, I am sorry.

Thanks in advance for any hints
Bochi
(This post was last modified: 2012-04-06 15:13 by Bochi.)
find quote
matt77303 Offline
Fan
Posts: 358
Joined: Dec 2011
Reputation: 6
Post: #2
Have you got any over scan options on the tv?

On my Panasonic its called 16:9 over-scan and ive got it turned OFF. i was always changing the over-scan options in xbmc until i found that option on my TV

Matt

CPU - AMD Athlon™ II X2 Dual-Core 3.4Ghz
MB - ASUS M5A78L-M/USB3, Nvidia 610 2GB
RAM - 4GB DDR3 Dual-Channel
OS - XBMC Frodo
TV - Panasonic TX-P50S21B
Home Cinema - Pioneer VSX-S300 5.1
Remote - Harmony one
find quote
Bochi Offline
Junior Member
Posts: 10
Joined: Jan 2010
Reputation: 0
Location: Nuremberg, Germany
Post: #3
Well, after spending a few more hours googling for all kinds of different search terms it turns out my TV actually has an option to set the display size to "Native", which fixed my issues. The option isn't reachable via the config menu though, it has an extra key with a weird symbol on the remote, so much for usability... BTW its a Toshiba TV.
find quote