Mac Mini audio lost after switching TV off

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
mysiar Offline
Junior Member
Posts: 1
Joined: Jan 2012
Reputation: 0
Post: #1
Hi

I just purchased Mac Mini for my media center.
My configuration:

Mac Mini -> HDMI -> DENON AVR 4810 -> HDMI -> SAMSUNG TV

When I run XBMC and play music and switch TV off the audio output is redirected to the Mac Mini speaker and I can not force it to go through HDMI.
There is no problem with iTunes.
I can switch TV off and on and audio output is still through HDMI to my Denon.

Does anybody got any idea how to force XBMC to use HDMI audio output no mater of TV on or off ?

Regards
Piotr
find quote
plot Offline
Junior Member
Posts: 27
Joined: Dec 2010
Reputation: 0
Post: #2
Getting a seperate audio cable from the Mac Mini to the receiver fixed the problem for me. Not sure if we were having the same problem though, my audio wouldnt work at all through the entire computer (not just XBMC) because the TV was no longer detected when it was off, the Mac would stop sending anything through HDMI. You make it sound as if the problem only exists with XBMC, am I right?
find quote
htpcero Offline
Member
Posts: 88
Joined: May 2009
Reputation: 0
Post: #3
I run into a very similar problem with different XBMC hardware, also with a denon receiver:

AMD Fusion-based HTPC (on ubuntu 12.04/ XBMC Eden) > HDMI > Denon AVR 3312CI > HDMI > Sharp TV.

Audio over hdmi from xbmc works fine up until I switch the video source in the receiver to e.g. my apple TV. When I return to the "xbmc source", the audio is gone, and the only way to fix it is to restart xbmc (not the htpc, just the app > hence the problem seems to be in xbmc).

I found the same solution as Plot did, I added a digital audio using the SPDIF output of my HTPC to the receiver. Works fine, the only issue with the SPDIF are some slighly anoying "click" sounds that xbmc generates when opening and closing the audio channel (for some reason, this doesn't happen when using hdmi audio)

it would be great to get HDMI audio to work properly in this setup!
find quote
beemarp Offline
Member
Posts: 66
Joined: Mar 2012
Reputation: 0
Location: Oklahoma
Post: #4
I'm on a 2011 Mac Mini (Mountain Lion) and having quite a few issues with HDMI audio.

Especially when running PseudoTV with multiple files containing different audio sources (DD 5.1, DTS, Stereo). The problem seems to occur when switching from surround sound to stereo.

My setup is Mac Mini HDMI > Pioneer Elite VSX30 > Sony LCD.

Best solution I have found is to change the Mac Mini audio output to 2ch 16bit (via the AudioMIDI utility) and XBMC audio settings to ANALOG 5.1 output, "Default Audio Output" as the output device.

Not sure if there's a better solution, but this is the only thing that works for me to prevent audio dropouts. I've tried several nightly builds as well as the stable release, and all the same result.

Also not sure that if by selecting "Analog" vs. "HDMI" in XBMC affects the audio quality or not...I haven't noticed much of a difference, but that's not to say there is one, possibly undetected by my untrained ears.
(This post was last modified: 2012-09-07 18:23 by beemarp.)
find quote