Mythtv backend setup issue

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
maizey Offline
Junior Member
Posts: 6
Joined: Aug 2011
Reputation: 0
Post: #1
Hi guys

First off thanks for all the work your doing with the PVR development. Been following it for a while and think its about ready to have a go. Till now ive been running xbmc on ubunto 10.04 with mythtv seperate for tv recording.

Ive just finished installing xbmcbuntu 11.0 and all is working fine there. I then procedded to install Mythtv for the backend of the recording but having issues with it.

I am using a winfast dtv2000ds tuner card which appears to be installed and running correctly.

output of dmesg | grep dvb is

Quote:[ 7.311501] dvb-usb: found a 'Leadtek WinFast DTV2000DS' in cold state, will try to load a firmware
[ 7.456279] dvb-usb: downloading firmware from file 'dvb-usb-af9015.fw'
[ 7.524538] dvb-usb: found a 'Leadtek WinFast DTV2000DS' in warm state.
[ 7.524636] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 8.416913] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 9.435930] dvb-usb: schedule remote query interval to 500 msecs.
[ 9.435934]
dvb-usb: Leadtek WinFast DTV2000DS successfully initialized and connected.
[ 9.446904] usbcore: registered new interface driver dvb_usb_af9015

and output of lsusb -v is


Quote:Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x0413 Leadtek Research, Inc.
idProduct 0x6a04
bcdDevice 2.00
iManufacturer 1
iProduct 2
iSerial 0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 46
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 4
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 0
bInterfaceProtocol 0
iInterface 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x02 EP 2 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x84 EP 4 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x85 EP 5 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0

/dev/dvb has two folders for the adaptors

The problem is when selecting the cards in mythtv backend setup the Frontend ID has Error_open instead of the card name and cant tune in any channels. When i try to scan I get a message "unable top open channels"

Anyone have any idea what ive done wrong?
(This post was last modified: 2012-04-07 08:05 by maizey.)
find quote