Need help installing XBMCbuntu on Acer Revo R3700 please

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Finchy Offline
Senior Member
Posts: 168
Joined: Dec 2010
Reputation: 0
Post: #31
Ah, ok, so mine says;

matthew@Revo:~$ dmesg | grep eth0
[ 1.431511] r8169 0000:03:00.0: eth0: RTL8168e/8111e at 0xf8012000, d0:27:88:1b:48:c9, XID 0c200000 IRQ 43
[ 20.759529] r8169 0000:03:00.0: eth0: link down
[ 20.759548] r8169 0000:03:00.0: eth0: link down
[ 20.760032] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 22.805280] r8169 0000:03:00.0: eth0: link up
[ 22.805669] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 33.672013] eth0: no IPv6 routers present

lsmod gives me;

matthew@Revo:~$ lsmod | grep r816*
r8169 43104 0

It is connecting (I'm SSH'd in at the moment to get this) but it keeps losing it. Strange.
find quote
jawilljr Offline
Senior Member
Posts: 185
Joined: Jan 2010
Reputation: 5
Post: #32
Finchy, please see this thread. Especially post #10. Sometimes you have to blacklist r8169 and use r8168 instead.

Hope this helps.

Jerry
find quote
Finchy Offline
Senior Member
Posts: 168
Joined: Dec 2010
Reputation: 0
Post: #33
Crap! I did;

echo "blacklist r8169" | sudo tee -a /etc/modprobe.d/blacklist.conf
sudo modprobe -rf r8169
sudo modprobe -v r8168
sudo depmod -a
sudo update-initramfs -u

but it's disabled r8169 but says Module r8168 not found! Now there is no connection at all! How do I unblacklist r8169 and down the drivers for r8168?!
(This post was last modified: 2012-04-10 20:08 by Finchy.)
find quote
Finchy Offline
Senior Member
Posts: 168
Joined: Dec 2010
Reputation: 0
Post: #34
Ah, looking at this blog - http://murzal-arsya.blogspot.co.uk/2012/...l8168.html

it appears that Ubuntu thinks it has an R8169 in but it's an R8168. This tells me how to do it, but I'm limited with Linux and don't know how to get it off the USB stick at /dev/sdc1!
Can anyone tell me the commands missing from this blog to change directory to the USB stick, extract the files and install those drivers?

Thanks!
find quote
pumkinut Offline
Posting Freak
Posts: 972
Joined: May 2006
Reputation: 9
Post: #35
It's not that Ubuntu thinks it's an 8169, it's that the default driver r8169 should work for both the 8169 and 8168 phy chipsets. The r8169 is broken and doesn't work with the 8168 chipsets well at all. The r8168 isn't included by default so this is why you need to download and compile the driver from Realtek, then blacklist r8169 and insert r8168. You need to compile it on the machine that you're going to use it on, as it's kernel and architecture specific.

If you have the source files saved on a USB thumbdrive, first make sure you determine which /dev device is your USB drive with:
Code:
sudo fdisk -l
This will list all block devices and show their paritions and sizes. Find with /dev/sd<x> is your device (easiest by matching up the size) e.g. 8GB USB thumbdrive will register as 8GB under fdisk. Once you have the device number, you can see if it automatically mounted or not with:
Code:
mount
This output will show you all the mounted devices and where there mount points are. If you thumbdrive is mounted it will most likely be under /media/<long UUID number>. You'll be able to correlate the mount point with the /dev number you got from fdisk. If the thumbdrive isn't mounted you can mount it manually with:
Code:
sudo mkdir /media/usb
sudo mount -t <filesystem> /dev/sd<x> /media/usb
mount (verify that the drive mounted correctly)
cd /media/usb
cp -r /media/usb/<Realtek source files> /home/xbmc

The mkdir command makes a new directory (use a name that's easy to remember) for a new mount point. The mount mount -t command mounts the drive. You may not need to give it a filetype, if it's fat32 or ext formatted you shouldn't need to. You may need to install ntfs-3g if it's ntfs formatted. The mount command all by itself just shows what's mounted and where the mount points are. You just copy the directory (recursive copy command cp -r) to the xbmc home directory and then follow your previously linked page to compile the kernel module and insert it. The autorun.sh script should do that all of that, looks like you'll need to do a
Code:
sudo autorun.sh
As the script needs elevated privileges to work.

If the script, for whatever reason doesn't work, post back. I have instructions for manually compiling the r8168 driver, inserting it, and making sure it comes up with every reboot. I've had to go through the procedure a couple of times with my HTPC.

Actually, this is why I can't use Openelec. They have the r8169 kernel module statically compiled in and my NIC is completely unstable with it. Because Openelec is built as an appliance, you can't compile your own drivers and make them work.
(This post was last modified: 2012-04-10 22:41 by pumkinut.)
find quote
Finchy Offline
Senior Member
Posts: 168
Joined: Dec 2010
Reputation: 0
Post: #36
The USB drive is fat32 and there's nothing else on it but the driver from. It's sdc but I can't work out what to put. is
the /media/usb needed in the
Code:
sudo mkdir /media/usb
part if it's not laid out like that?

And for
Code:
sudo mount -t <filesystem> /dev/sd<x> /media/usb
would that be
Code:
sudo mount -t fat32 /dev/sdc /media/usb
find quote
pumkinut Offline
Posting Freak
Posts: 972
Joined: May 2006
Reputation: 9
Post: #37
If you know the drive is fat32, then you would do the following:

1) Make a directory to mount the drive to:
Code:
sudo mkdir /media/usb

2) Mount the drive (since it's fat32 you may not need to specify the filesystem:
Code:
sudo mount /dev/sdc /media/usb

2a) If that doesn't work, for whatever reason, specify the filesystem. In this case vfat is the fat32 filesystem driver.
Code:
sudo mount -t vfat /dev/sdc /media/usb

The last command should complete with no feedback. If it does, check to see that /dev/sdc is mounted where you want it by just issue mount (no switches or sudo needed). That will enumerate all mounted devices and their respective mount points.

After that, move the files over and start with compilation.

Edit:
You may want to check to see whether or not your thumbdrive is auto mounted or not when you insert it. Just issue the mount command (again, no switches or sudo) and see if /dev/sdc is mounted anywhere. If it is, just copy the files over without all the extra directory and mount commands.
(This post was last modified: 2012-04-11 02:06 by pumkinut.)
find quote
Finchy Offline
Senior Member
Posts: 168
Joined: Dec 2010
Reputation: 0
Post: #38
Nope. Says 'autorun.sh' command not found.

I couldn't work out how to change the directory to the USB drive (sdc1) so I went into XBMCbuntu and copied the files over to /tmp but I still couldn't get it working.

To be honest, I'm kind of working off your instructions plus the earlier bits from that blog and am really getting confused! I still have the old drivers installed as
Code:
rmmod r8169
said it couldn't find them and I'm getting quite lost! I need to disable the wireless drivers as well (as the wireless is crap on it so not worth using), but I don't know what to add to the blacklist-modem.conf file to do that!

My only experience of Linux is copying in commands from guides and don't really know what's going on with most of it so you really will need to give me an idiots guide if I'm going to get there! Nod
(This post was last modified: 2012-04-11 20:11 by Finchy.)
find quote
pumkinut Offline
Posting Freak
Posts: 972
Joined: May 2006
Reputation: 9
Post: #39
For the autorun script you need to do the following:
Make sure you're in the same directory as the autorun script. You should be able to perform an "ls" and see the script.
Code:
sudo chmod +x ./autorun.sh

This changes the script so that it's executable (+x) and the ./ indicates that the script is in the current directory. If that command completes you should be able to run it with the following:
Code:
sudo ./autorun.sh

Again, the ./ tells the command interpreter to look in the directory you're currently in.

If that still doesn't work, post back. I can post the instructions I used for manually compiling the driver and getting everything up and running, but I can't do that until tonight.
find quote
Finchy Offline
Senior Member
Posts: 168
Joined: Dec 2010
Reputation: 0
Post: #40
Thanks. When I do that it says "check the old driver and unload it, but then looks like it's gone on to build the module and install the new one for R8168. It says it's backed up and renamed R8169. Presumably I still need to add R8169 to the blacklist?
find quote
pumkinut Offline
Posting Freak
Posts: 972
Joined: May 2006
Reputation: 9
Post: #41
You might, you could check to see if it's blacklisted or not with the following:
Code:
cat /etc/modprobe.d/blacklist.conf | grep r8169

This command concatenates the file /etc/modprobe.d/blacklist.conf (where kernel modules are blacklisted from loading), and then pipes that through grep (grep searches for patterns) which looks for r8169.

If the driver isn't on the blacklist, you can easily just do the following:
Code:
sudo echo blacklist r8169 >> /etc/modprobe.d/blacklist.conf
Which will insert the blacklist statement at the bottom of blacklist.conf.
find quote
pumkinut Offline
Posting Freak
Posts: 972
Joined: May 2006
Reputation: 9
Post: #42
One last thing. After the script runs, you'll need to reboot for everything to take effect. After the reboot, you can check to see if the correct driver is loaded by performing:
Code:
lsmod | grep r8168

If the command returns some output, then the driver is loaded and everything should be good.
find quote
Finchy Offline
Senior Member
Posts: 168
Joined: Dec 2010
Reputation: 0
Post: #43
It did work fine last night, but then when I swithed it on this morning it didn't have LAN connection again.

I've just booted it back up and done the commands you mention above and get the following results;

Code:
cat /etc/modprobe.d/blacklist.conf | grep r8169
gets
Code:
blacklist r8169
blacklist r8169
blacklist r8169
blacklist r8169

Code:
sudo echo blacklist r8169 >> /etc/modprobe.d/blacklist.conf
gets
-
Code:
bash: /etc/modprobe.d/blacklist.conf: Permission denied

and
Code:
lsmod | grep r8168
gets
Code:
r8168                 202040  0

I also keep getting 'cannot connect to remote server' when it scans and tries to pick up art. Should I be putting in a proxy or webgateway address in somewhere so it knows how to get to the web servers to scrape?

And how do I blacklist the wireless network adapter, as I don't use that;
Code:
matthew@Revo:~$ lspci
00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GT218 [ION] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
02:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
(This post was last modified: 2012-04-12 20:00 by Finchy.)
find quote
pumkinut Offline
Posting Freak
Posts: 972
Joined: May 2006
Reputation: 9
Post: #44
Well, it looks like the r8168 driver is loading from the lsmod output, and your r8169 driver has been blacklisted (multiple times by the look of it).

The 8168 PHY is there and the driver is loaded, so the next step is to see if the interface is actually up or not. You can see this by issuing:
Code:
ifconfig
You should see an entry for eth0 along with address and statistics information. If it's not there then try:
Code:
sudo ifup eth0

This should enable eth0 if it's not active for some reason. If that fails there may be something else going on. You can see if the interface is failing during init by looking through dmesg for information regarding the NIC:
Code:
dmesg | grep eth0
find quote
Finchy Offline
Senior Member
Posts: 168
Joined: Dec 2010
Reputation: 0
Post: #45
Ah, yes, I think it is correct then! Thanks!

Two last issues.... I still keep getting the failed to connect to remote server error, and I noticed that it looks like it's looking locally for the remote server. Should I set the proxy address to the gateway (ie the router's 192.168.1.1)? Or is it just a problem with Eden itself?

And where do I turn off the sounds effects?! The clicking and whooshing is driving my GF mad! Big Grin
(This post was last modified: 2012-04-15 18:40 by Finchy.)
find quote