SMB Authentication string in sources.xml == unsupported?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
doihave2 Offline
Junior Member
Posts: 3
Joined: Oct 2005
Reputation: 0
Post: #1
Hi,

I'm running XBMC v11 Eden on Windows 7 and I noticed that when using the GUI to add a source, the UserName and Password fields are not present in the new-source setup screen. Thus, upon adding a new, msft-SMB source, located on a remote share which requires authentication, the connection failed.

So, I launched my XML editor, opened up sources.xml, and added the connection info as per the usual format, as I've been doing for years with XBMC.

However, upon starting up XBMC and navigating to the desired source, the remote connection fails. I'm getting 'Could not connect to remote share' from the GUI. And, on the remote share server, I see that the wrong UserName was used to initiate the connection to the remote share.

I determined that the setting I added to sources.xml for (e.g. smb://username:password@server/) were not affecting the connection XBMC was making to the remote share by enabling advanced auditing of file shares. Thus in the Security Event Log I see that, instead of asserting the username:password credentials I provided in the sources.xml file, the SMB connection (to the remote share) is attempting to leverage my currently logged on UserName on the Win7 machine XBMC is running on. And since the particular share I'm trying to configure is only enabled for service-accounts, the connection is failing.

Unfortunately this screws up my media-sharing scheme, in which I have created/exposed media-specific remote shares throughout my network and granted share-level access to a generic service-account known as 'Media' which exists for the purpose of accessing my NAS and server-attached remote storage. Then, at the file-system ACL level, I'm able to shape what content is visible to this basic service-account.

I've had this scheme set up for years now because it allows me to tailor what specific content and file-shares are visible to anyone sitting in front of our HTPC/Televisions without requiring the person running the media player to log-in or authenticate to anything. Remote authentication information is a property of the specific remote-connection's config. In past experience this all worked very well and I'm able to backup my sources.xml settings and even transfer them between XBMC platforms. (where XBMC for the xbox was the original source)

Unfortunately there are examples of the type of notation used for SMB authentication interspersed within many pages of the Wiki. Example]

So, can someone please verify whether the previous functionality/support for the configuration of a (SMB) network resource's authentication credentials was removed or is unsupported in the Windows build of XBMC?

If so, I'm going to need to come up with a Plan B.

Thanks.

-mr.bill
find quote
tetzuoshima Offline
Member
Posts: 85
Joined: Feb 2011
Reputation: 0
Location: Sweden
Post: #2
Hi!
Look in below thread it worked for me when adding a password.xml in my userdata folder.
http://forum.xbmc.org/showthread.php?tid...pid1061002

[Image: watched-fanart.jpg]
Hardware. Asrock VisionX, Onkyo TX-SR508, LG 47", ReadyNAS Ultra 6 TB | Software. XBMC Frodo, Aeon Nox 4.0, Sickbeard, Couchpotato, SABnzbd, Newznab server
[Newznab]
[trakt.tv]
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 25,671
Joined: Oct 2003
Reputation: 169
Post: #3
It should work fine - make sure you urlencode both username and password.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote