Mac OS X - Sound problem

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
maxspiderx Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #1
Using Macbook OSX Lion, XBMC Eden.

9 out of 10 times when I play a video in XBMC, the sound would come out distorted with hissing noise. Please see the following logs and help me decipher the problem. Thanks!

Your debug xbmc.log: http://xbmclogs.com/show.php?id=1281
Your XBMC crashlog: http://xbmclogs.com/show.php?id=1282
(This post was last modified: 2012-04-08 04:26 by maxspiderx.)
find quote
Ned Scott Offline
Team-XBMC Wiki Guy
Posts: 18,195
Joined: Jan 2011
Reputation: 217
Location: Arizona, USA
Post: #2
Is this coming directly from the macbook, or is it hooked up to a TV and/or receiver?

You can make easy links to the XBMC wiki using double brackets around words: [[debug log]] = debug log, [[Add-on:YouTube]] = Add-on:YouTube, [[Adding videos to the library]] = Adding videos to the library, [[userdata]] = userdata, etc
find quote
maxspiderx Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #3
Both.
find quote
maxspiderx Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #4
Bump.
find quote
maxspiderx Offline
Junior Member
Posts: 4
Joined: Apr 2012
Reputation: 0
Post: #5
A few more strange occurrences that I have observed with this build, all audio related.

Normally when I connect my macbook to a TV with audio being output via the 3.5mm port to optical, the volume control on the macbook itself would be disabled. But whenever XBMC is on, the laptop will regain control of the 3 volume keys.

I would only get sound (be it the hiss static noise described in OP, or regular audio) with the first video played in XBMC. Subsequent videos and the entire XBMC interface will be muted after that, unless the program is restarted.
find quote