XBMC Crashes

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
naicidrac Offline
Junior Member
Posts: 2
Joined: Apr 2012
Reputation: 0
Post: #1
Hello all,
I am new here and I am wondering if you can help me. I am running Natty 11.04 and I have an ATI GPU and AMD board. I heard that the new drivers within Eden would resolve past issues, but I am still having troubles. I just installed eden XBMC and it crashes when I try to play .MKV containers. I also cannot get it to play FLAC or .mp3 files from the music prompt. The music appears to be playing, but I cannot hear it.

Thanks for the help,
Naicidrac
find quote
wsnipex Online
Team-XBMC packaging monkey
Posts: 3,497
Joined: Jun 2011
Reputation: 84
Post: #2
a debug log would be helpful. or you can take a look here: http://forum.xbmc.org/showthread.php?tid=116996
find quote
naicidrac Offline
Junior Member
Posts: 2
Joined: Apr 2012
Reputation: 0
Post: #3
Thanks,
here is the most recent crash log. I have never got it to play .MKV or have audio with .MP3


############## XBMC CRASH LOG ###############

################ SYSTEM INFO ################
Date: Sat Apr 7 21:53:15 CDT 2012
XBMC Options:
Arch: x86_64
Kernel: Linux 2.6.38-13-generic #57-Ubuntu SMP Mon Mar 5 18:29:54 UTC 2012
Release:
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
############## END SYSTEM INFO ##############

############### STACK TRACE #################
=====> Core file: /home/naicidrac/core (2012-04-07 21:53:15.284213782 -0500)
=========================================
[New Thread 5199]
[New Thread 5152]
[New Thread 5157]
[New Thread 5159]
[New Thread 5160]
[New Thread 5161]
[New Thread 5166]
[New Thread 5177]
[New Thread 5178]
[New Thread 5179]
[New Thread 5197]
[New Thread 5200]
[New Thread 5196]
[New Thread 5198]
[New Thread 5138]

21:48:38 T:139703098615744 NOTICE: Running the application...
21:48:38 T:139703098615744 NOTICE: ES: Starting event server
21:48:38 T:139702594164480 NOTICE: ES: Starting UDP Event server on 0.0.0.0:9777
21:48:38 T:139702594164480 NOTICE: UDP: Listening on port 9777
21:48:38 T:139703098615744 NOTICE: starting zeroconf publishing
21:48:38 T:139702746846976 NOTICE: -->Python Interpreter Initialized<--
21:48:38 T:139702746846976 NOTICE: StorageServer Module loaded RUN
21:48:38 T:139702746846976 NOTICE: StorageClient-0.9.1 Starting server
21:48:38 T:139702562457344 NOTICE: -->Python Interpreter Initialized<--
21:51:24 T:139702501295872 WARNING: JpegIO: Error 53: Not a JPEG file: starts with 0x%02x 0x%02x
21:53:00 T:139703098615744 WARNING: Previous line repeats 12 times.
21:53:00 T:139703098615744 ERROR: Keymapping error: no such action 'xbmc.runscript()' defined
21:53:11 T:139702492903168 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
21:53:15 T:139703098615744 NOTICE: DVDPlayer: Opening: /media/FILE.1080p.Bluray.DTSFILE.x264-FILE.mkv
21:53:15 T:139703098615744 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
21:53:15 T:139702643451648 NOTICE: Creating InputStream
21:53:15 T:139702643451648 NOTICE: Creating Demuxer
21:53:15 T:139702643451648 NOTICE: Opening video stream: 0 source: 256
21:53:15 T:139702643451648 NOTICE: Creating video codec with codec id: 28
21:53:15 T:139702643451648 NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(1920x1040, 28)
21:53:15 T:139702643451648 NOTICE: vdp_device = 0xffffffff vdp_st = 0x00000001
21:53:15 T:139702643451648 ERROR: (VDPAU) unable to init VDPAU - vdp_st = 0x1. Falling back.
21:53:15 T:139702643451648 NOTICE: CDVDVideoCodecFFmpeg::Open() Failed to get VDPAU device
21:53:15 T:139702643451648 NOTICE: (VDPAU) Close
21:53:15 T:139702643451648 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
21:53:15 T:139702643451648 NOTICE: Creating video thread
21:53:15 T:139702643451648 NOTICE: Opening audio stream: 1 source: 256
21:53:15 T:139702643451648 NOTICE: Finding audio codec for: 86020
21:53:15 T:139702755239680 NOTICE: running thread: video_thread
21:53:15 T:139702643451648 NOTICE: Creating audio thread
21:53:15 T:139702643451648 NOTICE: Opening Subtitle stream: 2 source: 256
21:53:15 T:139702396913408 NOTICE: running thread: CDVDPlayerAudio::Process()
21:53:15 T:139702396913408 NOTICE: Creating audio device with codec id: 86020, channels: 6, sample rate: 48000, no pass-through


############### END LOG FILE ################

############ END XBMC CRASH LOG #############
(This post was last modified: 2012-04-08 18:04 by naicidrac.)
find quote
Benoit- Offline
Junior Member
Posts: 1
Joined: Jan 2010
Reputation: 0
Post: #4
Hi,

I had very similar crashes, on XBMC live. After deleting ~/.asoundrc (actually renaming it into something else), everything went OK.

Edit: file .asoundrc located in the home directory of the account used to run XBMC.

BenoƮt.
(This post was last modified: 2012-04-08 20:13 by Benoit-.)
find quote