Bad default audio track selection in Eden

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Uxorious Offline
Junior Member
Posts: 18
Joined: Nov 2009
Reputation: 0
Post: #1
I have a huge problem is that the “audio track selection” logic that has been changed.
Now, XBMC tries to intelligently pick the best audio track … only it’s not very intelligent.
I have a ton of files with a 5.1 AAC track first, followed by foreign language AC3 tracks … and now it always defaults to play the AC3 track!
It ignores the fact that the AAC track has the same number of channels, and it completely ignores the language tag in the tracks (MP4).

Is there any way to make XBMC default to playing the first audio track for all files?

EDIT:
I should add I suspect it has to do with this change:
http://trac.xbmc.org/ticket/5773
(This post was last modified: 2012-04-08 05:15 by Uxorious.)
find quote
firefly972 Offline
Junior Member
Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #2
Hi, I have the same problem. They are any parameter to desactivate this "feature".

Thanks.

P.S. Sorry, english is not my first language.
find quote
Uxorious Offline
Junior Member
Posts: 18
Joined: Nov 2009
Reputation: 0
Post: #3
It looks like there is some activity on this issue here:
http://forum.xbmc.org/showthread.php?tid=44450
https://github.com/xbmc/xbmc/pull/700
(This post was last modified: 2012-04-30 01:33 by Uxorious.)
find quote