Yellow Line through weather icons

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bry- Online
Donor
Posts: 1,126
Joined: Jan 2011
Reputation: 11
Post: #1
any ideas on how to correct this? unfortunately this happened on one box now goes across all 3. Not that serious but any insight would be appreciated.

[Image: 02KTi.png]

Adding debug Log - http://pastebin.com/1niijuZT
(This post was last modified: 2012-04-10 17:47 by bry-.)
find quote
CutSickAss Offline
Fan
Posts: 525
Joined: Dec 2011
Reputation: 33
Location: Greece
Post: #2
I think that's the fallback icon for when a connection to the weather server could not be established. There might be a problem with your internet connection.
find quote
Martijn Offline
Team Kodi
Posts: 11,548
Joined: Jul 2011
Reputation: 166
Location: Dawn of time
Post: #3
You have not selected a location, perhaps 'use proxy' is enabled or no internet connection

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote
bry- Online
Donor
Posts: 1,126
Joined: Jan 2011
Reputation: 11
Post: #4
(2012-04-10 16:41)Martijn Wrote:  You have not selected a location, perhaps 'use proxy' is enabled or no internet connection
Unfortunately that does not seem to be the issue all other features of the addon are in working order. Just the icon that seems to be messed up.
find quote
bry- Online
Donor
Posts: 1,126
Joined: Jan 2011
Reputation: 11
Post: #5
added debug log to original post - http://pastebin.com/1niijuZT
find quote
Martijn Offline
Team Kodi
Posts: 11,548
Joined: Jul 2011
Reputation: 166
Location: Dawn of time
Post: #6
Weather Plus is giving errors. According to the weatherplus thread it isn't getting update cause the creator hasn't gor time for it.

Try the default weather add-on Wunderground if that works

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
(This post was last modified: 2012-04-10 20:16 by Martijn.)
find quote
bry- Online
Donor
Posts: 1,126
Joined: Jan 2011
Reputation: 11
Post: #7
Will have to do. Thank you Martijn
find quote
daanwillems Offline
Junior Member
Posts: 12
Joined: Apr 2012
Reputation: 0
Post: #8
I experience the same behavior (yellow strokes through icons and missing weather data) right after evey system boot using Weather Underground. Once I trigger a manual refresh, the weather reports are pulled in and icons/data is updated.

I checked the debug log for errors, but frankly there's nothing related there.

I sense that XBMC is trying to update the weather before the networking has been established. It would be good to have some dependency for this.

Ubuntu 12.04 LTS (but happened on 11.10 as well)
XBMC Eden
find quote
gabbott Offline
Team-Kodi Member
Posts: 1,545
Joined: Jul 2007
Reputation: 27
Post: #9
(2012-05-05 16:15)daanwillems Wrote:  I experience the same behavior (yellow strokes through icons and missing weather data) right after evey system boot using Weather Underground. Once I trigger a manual refresh, the weather reports are pulled in and icons/data is updated.

I've noticed the same behavior on my setups. Haven't looked into it enough to see if it happens every time but whenever it does happen a manual refresh clears it up.
find quote
ronie Online
Team-Kodi Member
Posts: 9,294
Joined: Jan 2009
Reputation: 161
Post: #10
(2012-05-05 16:15)daanwillems Wrote:  I experience the same behavior (yellow strokes through icons and missing weather data) right after evey system boot using Weather Underground. Once I trigger a manual refresh, the weather reports are pulled in and icons/data is updated.

I checked the debug log for errors, but frankly there's nothing related there.

I sense that XBMC is trying to update the weather before the networking has been established.

that's indeed most likely the case.
the next version of wunderground will address this issue,
by trying to refetch weather at a 10 sec. interval when the previous attempt failed.

(2012-05-05 16:15)daanwillems Wrote:  It would be good to have some dependency for this.

agreed. i'm sure wunderground isn't the only addon that requires internet connectivity at startup.
i'm not 100% sure whether each addon should add a check for connectivity
or if this is something that would better be handled at xbmc level.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote