New FREE Control4 Driver Available (JSON)

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
penfolds Offline
Junior Member
Posts: 9
Joined: Apr 2012
Reputation: 0
Post: #16
(2012-04-21 15:28)Craig P Wrote:  I have done a little work, i was waiting for XBMC to move all (like context menu, etc) of the commands to the new JSON stuff (which i see is happening now).

i was also waiting for C4 to finish their new media proxy so that C4 can import the movie info from XBMC rather than C4 scanning a folder.

My driver might not load into Composer as i was playing around with it but you can copy and paste some code out of there. I use the WakeOnLan stuff every day with another driver i have...

http://dl.dropbox.com/u/14849352/mediapl...c_json.c4i

Hi Craig,
I gave it a try - The driver loads OK, but the menu navigation did not work. Is this because Json does not implement this feature yet?
find quote
brandonj Offline
Member
Posts: 51
Joined: Sep 2007
Reputation: 0
Post: #17
(2012-04-21 05:28)penfolds Wrote:  The driver posted here does not appear to allow media scanned into C4 to play (unless I have the wrong version)

The problem with scanning media is because of a limitation of the media_player proxy in their SDK. It's pretty much a copy of the dvd_player proxy, and as such is severely limited. C4 has said in their documentation that they are developing a new proxy that will allow scanning media, etc. but a little birdie told me that it may not happen for another year.

This is why I started with navigation first, since it is the most "implementable". There are some ways around it - one of which is to scan in media from a "Network Storage" driver using the proper samba credentials. When you select a media item from the c4 navigator, it sends the samba uri to the XBMC driver to try to play it. In turn, my XBMC driver instructs XBMC to play the file at the same URI. I haven't been able to get it to work, unless XBMC has a video source defined with the same credentials as what is used in "Network Storage". It will then play the file.

Another method I could use (but don't want to), is to use a DVD Changer proxy instead of Media_Player, and pretty much just make c4 think it's a changer, and scan in dvd titles.
This has other limitations, and I'd rather just wait until the new media player proxy is available.



Craig P,
Your driver has some useful features. Would you mind if I tried to implement some things from your driver into mine? We could even try to merge the two projects if you are interested. No sense in duplicating effort.

-Brandon
find quote
penfolds Offline
Junior Member
Posts: 9
Joined: Apr 2012
Reputation: 0
Post: #18
(2012-04-24 23:14)brandonj Wrote:  
(2012-04-21 05:28)penfolds Wrote:  The driver posted here does not appear to allow media scanned into C4 to play (unless I have the wrong version)

... There are some ways around it - one of which is to scan in media from a "Network Storage" driver using the proper samba credentials. When you select a media item from the c4 navigator, it sends the samba uri to the XBMC driver to try to play it. In turn, my XBMC driver instructs XBMC to play the file at the same URI. I haven't been able to get it to work, unless XBMC has a video source defined with the same credentials as what is used in "Network Storage". It will then play the file.
...
-Brandon

I scan my media from a Network Storage device (this is how it works with Craigs driver also for me), but still did not play with yours. I suspect this is because my media share in c4 points the NAS root, but my xbmc share is only NAS\videos based on what you are saying?
find quote
Craig P Offline
Junior Member
Posts: 14
Joined: Apr 2012
Reputation: 1
Post: #19
I know my media importing doesn't work but I was sure the navigation worked.

I'm more than happy merging the project, I started creating the driver to learn to make
Driver works drivers, very much a sideline projects for me that's why I haven't done anything for a while.

Another way of importing from XBMC is to use the iPod Proxy, that's what guys like Exrta Veg use and I'm sure I read that the new media player proxy (when it comes out) is a modified version of the iPod dock proxy. That way you can import video and audio and view it on the Navigator.

My driver should play stuff from a NAS but I don't think I have the username a password parsing in there but it's easily done (that might be your problem Penfolds). Does your NAS require a username and a password to view the shared folder where your media is?
find quote
penfolds Offline
Junior Member
Posts: 9
Joined: Apr 2012
Reputation: 0
Post: #20
Unless I have managed to confuse myself:

Craig - yours plays movies I scan from my NAS into C4. I select the movie from the c4 touch screen navigator and it plays on xbmc without any problems. I can pause and play and on your older version I could press a number and it would jump to a percentage of the movie based on x10. eg 2 = 20% through the movie.
However left,right,up,down and select are not working for me on either of the versions of your driver I have, including the one you posted above

I have C4 2.2 and xbmc eden on windows. If you think these menu features are working on the version you posted I'll have another look, but I even tried assigning the left, right etc to the programmable colour buttons and it did not work.
find quote
kedda Offline
Senior Member
Posts: 135
Joined: Feb 2011
Reputation: 0
Post: #21
I am having the same issue below as penfolds. Any chance you can take another look at the driver?

(2012-04-25 09:37)penfolds Wrote:  Unless I have managed to confuse myself:

Craig - yours plays movies I scan from my NAS into C4. I select the movie from the c4 touch screen navigator and it plays on xbmc without any problems. I can pause and play and on your older version I could press a number and it would jump to a percentage of the movie based on x10. eg 2 = 20% through the movie.
However left,right,up,down and select are not working for me on either of the versions of your driver I have, including the one you posted above

I have C4 2.2 and xbmc eden on windows. If you think these menu features are working on the version you posted I'll have another look, but I even tried assigning the left, right etc to the programmable colour buttons and it did not work.
find quote
Craig P Offline
Junior Member
Posts: 14
Joined: Apr 2012
Reputation: 1
Post: #22
I have been away for a week but I'm hoping to have a few hours tomorrow to sit down and take a look and get mine working propperly and then look at bringing all the code together and start working together to make a kick ass driver Smile
(This post was last modified: 2012-04-30 20:11 by Craig P.)
find quote
Craig P Offline
Junior Member
Posts: 14
Joined: Apr 2012
Reputation: 1
Post: #23
So I'm running C4 Version 2.2.1 and Eden on a Windows PC

I didn't have as much time as i had hoped but i have modified some of the code and tested that the menu navigation should be working, skip forward and back as well as stop.

here is my latest driver...

http://dl.dropbox.com/u/14849352/mediapl...c_json.c4i
find quote
penfolds Offline
Junior Member
Posts: 9
Joined: Apr 2012
Reputation: 0
Post: #24
Craig,
I quickly added it to my project and tested.
Looks much better. WELL DONE.
Movie selection from C4 touchscreen - Working
Menu navigation in xbmc menus -working,
Menu navigation inside .iso images of DVD menus (which did not work on Brandon's driver for me) - Working

One question
There is a somewhat hidden menu in xbmc that I can get by pressing a "+" key on an iphone app/ remote, that I cannot replicate with the C4 drivers yet.
This pop-up menu has a number of options, including the ability to do an adhoc library scan, which is critical if you add a new tv show and want to watch it then and there.
any ideas of your driver already allows access to this menu?

This is the only way I know of rescanning for media outside of the boot-up scan (which often does not work) and using a add-on, which scans every hour on a schedule at best.
Below is a picture of the menu to which I refer.
http://dl.dropbox.com/u/7566313/xbmc%20submenu.JPG


Ps. I tried to asign POP-UP-MENU to a "*" remote key in the driver - but the assignments to keys does not seem to work
(This post was last modified: 2012-05-06 03:05 by penfolds.)
find quote
Craig P Offline
Junior Member
Posts: 14
Joined: Apr 2012
Reputation: 1
Post: #25
Hey Penfolds

the menu you are looking for is the Context Menu, this was not added to the JSON protocol until recently. See here: http://forum.xbmc.org/showthread.php?tid...pid1055011

This is one of the reasons i put my driver on hold at the time.

I forgot that i had copied and pasted the assignments from my Netgear NTV550 driver so the assignments probably wont work. I can look into that next.
find quote
penfolds Offline
Junior Member
Posts: 9
Joined: Apr 2012
Reputation: 0
Post: #26
Thanks Craig,
Look forward to seeing that context menu in a driver build when you have time.

Can I ask do you use a particular editor, other than notepad?
did you learn the skills from the driverworks doco?

I was wondering if I revisit my long lost developer days and learn how to code these drivers.
find quote
Craig P Offline
Junior Member
Posts: 14
Joined: Apr 2012
Reputation: 1
Post: #27
Hey penfolds

I use a combination of programs, to edit the driver XML stuff I use XML Marker. For general Lua scripting in the driver I use Notepad ++ with the Gmod Lua addon. To debug it I use the method in the Driverworks documentation with SciTE.

I never learned a programming language so im learning this as i go, but for someone who knew a language I'm sure you will pick it up quickly Smile

The new XBMC April release is giving me a bit of grief on my laptop, so as soon as I have it all running again I'll see what new JSON stuff has been added and add it to my driver.
find quote
Bahndit Offline
Donor
Posts: 127
Joined: Jul 2008
Reputation: 0
Location: Salt Lake City, UT
Post: #28
Craig and Brandon,

Thanks for working on this. I am in the same boat as penfolds, I thought I was going to revisit my long lost developer days as well. Keep up the good work!

Thanks,
Will
find quote
dondulla Offline
Junior Member
Posts: 15
Joined: Jun 2012
Reputation: 0
Post: #29
Thanks for the great work on this.

It seems like it has been a while since this thread was active so I have a few questions maybe someone else can help me out with it:

-Some transport controls do not work (fast forward, rewind) is this correct?
-When browsing media in XBMC, i was unable to find a way to open the hidden menu on the left (where options such as play trailer are located), Is there any way to access this?
-Do any 2-way events work to tell C4 if content is playing, stopped, etc?
-Is there any integration into navigator yet?

Currently I just use C4 to switch to XBMC, and then the remote for partial control with constellation on IPAD for the remaining control.
find quote
penfolds Offline
Junior Member
Posts: 9
Joined: Apr 2012
Reputation: 0
Post: #30
Fast forward did not work for me (but not sure if it was the driver or the movie) Skipping movie "stages"or channels works though.

The pop up menu does not work yet, but the slide out one from the left does by using the left arrow key

I have my kids movies on the C4 navigator. Id don't bother putting them all there - xbmc interface is better.

Craig has done a great job. The only thing id like to get working is the pop-up menu so I can scan for movies, without getting my iphone remote out also.
find quote
Post Reply