Audio Sync problem with DTS at start and on each pause.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jurrabi Offline
Moderator
Posts: 201
Joined: Jan 2005
Reputation: 5
Location: Las Palmas, Canary Islands
Post: #1
I detected this problem a few days ago. I'm pretty sure it didn't happening in my previous XBMC configuration based on Windows, but I might be wrong. And also I don't have many DTS video files (you'll understand soon enough)

My configuration is a Desktop PC Alienware Aurora with an ATI Radeon 5870. Linux x64 installation (mythbuntu) with xbmc installed from standard ppa:team-xbmc (version numbers at the end).

I must clarify that historically (with all my xbmc configurations) I have to set a delay in sound for all videos (I set it as a default in the audio options of XBMC) due to the delay in the image caused by the combination Denon sound system / LG LCD hdmi connection. This, as I said was working fine in the past.

The problem now is that every time I start a video with DTS audio track the sound is not properly synced. Even more, the audio delay adjustment lever has no effect.

But, if I set the audio delay lever in the correct (theoretical) delay and then change the Audio Output to another value (anyone HDMI, SPDIF or analog) then the sound works in correct sync until I pause the movie and play it again or jump ahead or backwards (with the arrow keys). Whenenver I interrupt the playing the sync problem repeats. Seems like XBMC forgets about the delay and resets to 0 ms delay.

This behavior occurs only with DTS sound tracks. With AC3 or mp3 sound everything works as expected. Even the audio resyncs on the fly with the audio sync lever option.

The system is connected to the sound system via SPDIF cable.


I played with several sync configurations in the video preferences but with no change in behavior...

Any Ideas? Can this be a XBMC bug?

PD.
VersiĆ³ns: Linux 3.0.0-17-generic#30 Ubuntu SMP Thu Mar 8 20:45:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ATI Drivers: amd-driver-installer-12-3-x86.x86_64
XBMC: 11.0 Git: Unknown (Compilled: Mar 24 2012)

Always read the XBMC Online Manual,Frequently Asked Questions and search the forum before posting.
For troubleshooting and bug reporting use -> Log file.
Read the new posting policy!

find quote