Linux - HOW-TO The Complete Linux N00bs' Guide To Installing ZSNES on XMBCbuntu

  Thread Rating:
  • 3 Votes - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
staticn0de Offline
Junior Member
Posts: 7
Joined: Sep 2013
Reputation: 0
Post: #76
How do you start ZSNES from Advanced Launcher? Are you using exactly this following arguments?

Code:
-m -s -v 22 %rom%

Or do you have modified it to use a resolution that is supported by your graphical card and your screen?

Code:
;  ----
; -- Video --
;  ----

; Video Mode [0..22]
;   0 = 256x224      R WIN     1 = 256x224      R FULL
;   2 = 512x448     DR WIN     3 = 512x448     DR FULL
;   4 = 640x480     DR FULL
;   5 = 256x224    O R WIN     6 = 512x448    ODR WIN
;   7 = 640x480    ODS FULL    8 = 640x480    ODS WIN
;   9 = 640x560    ODR WIN    10 = 768x672    ODR WIN
;  11 = 800x600    ODS FULL   12 = 800x600    ODS WIN
;  13 = 896x784    ODR WIN    14 = 1024x768   ODS FULL
;  15 = 1024x768   ODS WIN    16 = 1024x896   ODR WIN
;  17 = 1280x960   ODS FULL   18 = 1280x1024  ODS FULL
;  19 = 1600x1200  ODS FULL   20 = VARIABLE   ODR WIN
;  21 = VARIABLE   ODS WIN    22 = CUSTOM     OD  FULL
; You need to select the custom video mode and modify CustomResX/Y to properly
; use custom res support.
cvidmode=2
; Last windowed & fullscreen modes (used when alt-tabbing)
PrevWinMode=2
PrevFSMode=3

; Custom Resolution X and Y for Custom Video Modes [256x224..2048x1536]
CustomResX=640
CustomResY=480

Custom video mode of ZSNES is defined by the -v 22 argument. If you are using it the screen resolution values, defined by CustomResX and CustomResY, must be compatible with your system. Also, if you want to use, for example the 1280x1024 fullscreen mode, the argument must be -v 18. You can also force the custom mode by modifying the cvidmode value (to 22).
[/quote]

Hi there,

Thanks for your reply.

I have tried starting zsnes in OpenGL resolutions using Advanced Launcher (With the exact arguments), from within the GUI of xbmcubuntu and I have also launched it remotely using SSH -X. All of these methods give me a black screen when I use any mode which has the OpenGL feature.

I normally use 1080p when watching movies and this is also the resolution which xbmx is running at, so I don't think that resolution is the problem. I think it is more likely the OpenGL.

When running Zsnes from the GUI, the [b]-v 22[b] argument wont matter right?
find quote
Angelscry Offline
Skilled Python Coder
Posts: 3,304
Joined: Sep 2010
Reputation: 53
Location: MTL, Canada
Post: #77
Are you sure that OpenGL is supported with your video card and the actual NVidia drivers on Linux?

Code:
glxinfo
(This post was last modified: 2013-09-29 16:01 by Angelscry.)
find quote
Komerad Offline
Junior Member
Posts: 37
Joined: Oct 2010
Reputation: 1
Post: #78
Big fistpump and booyah!

Now following your guide still left me without sound (been searching for almost 2 days to get it fixed) searching around the web trying all kind of stuff I reached the breaking point last night.
I'm using xbmcbuntu and figured out that when logged in the xbmcbuntu I had no hdmi sound neither. Whats more is that I could not even select any hdmi output.
So this evening i shifted my aproach from how to get zsnes to work over hdmi to how to get openbox/ubuntu to work over hdmi.

And I stumbled on this sollution wich worked like a charm (gigabyte c1037un-eu) :

Quote:Ubuntu disable and hide digital audio output SPDIF in all Realtek / Nvidia Cards by default in fact it does same in all flavor of Ubuntu because no body cares the final user.
The prosedure to fixit is the same in all verssion of ubuntu and works for all sound cards Ati Nvidia Realtek Creative Bosse etc. You need to edit a file to do work get a terminal and tipe this

sintax: sudo nano /etc/modprobe.d/alsa-base.conf (enter)

then add this line to the end of the file

sintax: options snd-hda-intel model=auto (then use the end page controls to rewrite and save the file, then exit console)

At this time you need to reboot the machine, and then realize the missing digital audio spdif its work! go to task bar icon to select propper devise (its show now) to avoid get sound for all speackers at same time. if you need mute ubuntu alets or whatever you need to do enjoy.
for spanish take this link: http://www.fermu.com/es/articulos/linux/...-en-ubuntu

Boggart Akerley NASA Space Ship Program Sofware Engineer.
(This post was last modified: 2013-12-26 17:57 by Komerad.)
find quote
holmen Offline
Member
Posts: 65
Joined: Apr 2011
Reputation: 0
Post: #79
I have found a simpler solution for using Zsnes with openbox in XBMCbuntu. When following this guide i'll get no sound or the rom file did'nt get loaded correctly but when creating a simple script i've managed to solve it.

Advanced Launcher Settings:
Path to executable: <path to script file> (in my case ~/scripts/run_zsnes)
Arguments: "%rom%"

run_zsnes script:
Code:
#!/bin/bash
openbox &
/usr/bin/zsnes -s -v 22 "$1"
killall -9 openbox

I've removed the -m argument since i want to access the menus.
This solution works perfectly for me.
find quote
vitalizm Offline
Junior Member
Posts: 25
Joined: Jan 2013
Reputation: 0
Post: #80
I have XBMCubuntu and XBMC 12.3 installed. Latest version of Advanced Launcher.

The issue that I have is that when I exit ZSNES, i get kicked back into a really small windowed version of XBMC, this issue seems inconsistent. Sometimes ZSNES would exit fine into xbmc and sometimes not. To fix it, I have to go back to XBMC video output settings and switch to fullscreen 1080p resolution.

Any ideas?
find quote
Angelscry Offline
Skilled Python Coder
Posts: 3,304
Joined: Sep 2010
Reputation: 53
Location: MTL, Canada
Post: #81
(2014-02-03 21:24)vitalizm Wrote:  I have XBMCubuntu and XBMC 12.3 installed. Latest version of Advanced Launcher.

The issue that I have is that when I exit ZSNES, i get kicked back into a really small windowed version of XBMC, this issue seems inconsistent. Sometimes ZSNES would exit fine into xbmc and sometimes not. To fix it, I have to go back to XBMC video output settings and switch to fullscreen 1080p resolution.

Any ideas?
Create a .sh script that will restore the resolution after ZSNES will be closed and before giving back the focus to XBMC.
find quote
vitalizm Offline
Junior Member
Posts: 25
Joined: Jan 2013
Reputation: 0
Post: #82
How would have make the .sh script execute when zsnes is closed? Is there an option for this via Advanced Launcher?
find quote
Angelscry Offline
Skilled Python Coder
Posts: 3,304
Joined: Sep 2010
Reputation: 53
Location: MTL, Canada
Post: #83
You need to make a script that will start ZSNES and then restore the display resolution. For example :

Code:
#!/bin/bash
/usr/bin/zsnes -m -s -v 22 "$1"
xrandr -s 1024x768

If your display resolution is 1024x768. Then start this script from Advanced Launcher by taking care to replace the launcher argument by only "%rom%", a make your .sh script executable.
find quote
vitalizm Offline
Junior Member
Posts: 25
Joined: Jan 2013
Reputation: 0
Post: #84
Thank you, so far so good. I'll keep you updated. I have two issues which may be related other than this.

I have an issue with stuttering sound. I run the zsnes with the "-ad sdl" lines to get sound to work. Ive noticed that when I run zsnes with advanced launcher through xbmc, I get very high CPU usage (see screenshot). As soon as the load average hits above 1.2 the sound become stuttery. When zsnes is not running, the system idles at 0.10 in xbmc.

I noticed that when I exit XBMC and run it through the user, load average stays at about 0.5 and sound seems to be good. What can it be?
find quote
Angelscry Offline
Skilled Python Coder
Posts: 3,304
Joined: Sep 2010
Reputation: 53
Location: MTL, Canada
Post: #85
(2014-02-04 02:03)vitalizm Wrote:  Thank you, so far so good. I'll keep you updated. I have two issues which may be related other than this.

I have an issue with stuttering sound. I run the zsnes with the "-ad sdl" lines to get sound to work. Ive noticed that when I run zsnes with advanced launcher through xbmc, I get very high CPU usage (see screenshot). As soon as the load average hits above 1.2 the sound become stuttery. When zsnes is not running, the system idles at 0.10 in xbmc.

I noticed that when I exit XBMC and run it through the user, load average stays at about 0.5 and sound seems to be good. What can it be?
XBMC state after starting and application and into an addon is not the same than XBMC simply displaying its home menu. XBMC is using more CPU usage in the first case. Also XBMC and the application could use the same ressources (audio, video). Finally it also depend of the power of your system.

What you can try, is to force XBMC to be suspended (less memory usage) before starting your application. Then restore it once the application is closed. You can modify your script like this :

Code:
#!/bin/bash
killall -STOP xbmc.bin
/usr/bin/zsnes -m -s -v 22 "$1"
xrandr -s 1024x768
killall -CONT xbmc.bin
find quote
vitalizm Offline
Junior Member
Posts: 25
Joined: Jan 2013
Reputation: 0
Post: #86
Excellent, looks like the load goes to .90 max and everything is running pretty smooth most of the time.

Here is what my script looks like:

#!/bin/bash
killall -STOP xbmc.bin
/usr/bin/zsnes -m -s -v 22 -ad sdl "$1"
killall -HUP xbmc.bin

the last line restarts xbmc and prevents it from getting stuck in a small window even though ubuntu is in 1920x1080 resolution.
find quote
Angelscry Offline
Skilled Python Coder
Posts: 3,304
Joined: Sep 2010
Reputation: 53
Location: MTL, Canada
Post: #87
Thak you for the -HUP command line argument tips.
find quote
vitalizm Offline
Junior Member
Posts: 25
Joined: Jan 2013
Reputation: 0
Post: #88
Would you happen to know how to get 2 wireless xbox 360 remotes working with zsnes in xbmcubuntu? I got one to work using the instructions here:

http://forum.xbmc.org/showthread.php?tid=159561

They both pair, but only one controller works when I select multilayer games for both player one and player two. the script in the guide does say it works for both controllers, but it doesnt seem to be the case. Not sure what Im doing wrong.

I can manually run:

sudo xboxdrv --wid 0 -c /usr/share/doc/xboxdrv/examples/xbmc.xboxdrv

and

sudo xboxdrv --wid 1 -c /usr/share/doc/xboxdrv/examples/xbmc.xboxdrv

and the remotes do work, just not together...
find quote
Levi59 Offline
Junior Member
Posts: 45
Joined: Jun 2012
Reputation: 0
Post: #89
Hello,
I installed on my HTPC XBMCbuntu (the latest version available) and I wanted to install zsnes with RCB. I can well run using the command you use and in fullscreen but I stuck on 2 problems:
- I have sound in desktop mode but not in xbmc (the system sounds and movies work)

- I use a usb-cec Adaptater to control XBMC with the remote control of my TV, but as it is not detected by "irw". So, I can not stop znes once launched.
(This post was last modified: 2014-05-09 16:04 by Levi59.)
find quote
verybigleen Offline
Junior Member
Posts: 8
Joined: Aug 2013
Reputation: 0
Post: #90
Im tried everything!! I am still unable to get audio through advanced launcher in xbmc. Not just ZSNES either, but for anything launched within Advanced Launcher.

I have set my default.pcm device in /etc/asound.conf to 7 (my HDMI audio device) and set XBMC to use the default device but no go... Audio in XBMC but no audio from programs launched via XBMC.

I have tried using sdl also with no luck. If I launch zsnes outside of XBMC all works fine. Im pulling my hair out at this point.

I would greatly appreciate ant help.
find quote
Post Reply