XBMC Crashing Immediately/Almost Immediately on Lion

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
floydigus Offline
Junior Member
Posts: 3
Joined: Apr 2012
Reputation: 0
Post: #1
Hi,

OSX Version: Lion 10.7.3
Platform: MacMini 2.26 GHz Intel Core 2 Duo, 2GB RAM x86_64
Install Method: dmg download from xbmc.org (xbmc-11.0.dmg)

Steps to reproduce:
Note: I have just upgraded from Snow Leopard where I was also having similar problems since recently upgrading XBMC to 11 from 10(?)

There seem to be two kinds of crash:
1. Start XBMC and it crashes right after the splash screen.
2. Sometimes it is necessary to click around a bit (e.g. click once on TV Shows) before it crashes. xbmc.log: http://pastebin.com/EHK3bZHZ

Although I am having a lot of type 1 at the moment, the whole problem was originally characterised by type 2. About 1 time in 10, it seems to work pretty seamlessly.

Thanks very much in advance for any help!
find quote
davilla Offline
Team-XBMC Developer
Posts: 11,390
Joined: Feb 2008
Reputation: 64
Post: #2
crashreport logs please


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
floydigus Offline
Junior Member
Posts: 3
Joined: Apr 2012
Reputation: 0
Post: #3
Crash log:
http://pastebin.com/ULsBFWaZ

And the corresponding xbmc.log:
http://pastebin.com/sEckdhq0

Thank you!
find quote
jopie Offline
Senior Member
Posts: 150
Joined: Apr 2012
Reputation: 1
Post: #4
Just a wild guess. For a little while XBMC was crashing with me too the moment I started up, and I "identified" the problem as being caused by one TV show that XBMC was trying to update against TVDB and that made it crash. When I deleted the show the problem was "solved". I never found out what caused it, though. I did remove all nfos and made new ones, but it made no difference.
find quote
floydigus Offline
Junior Member
Posts: 3
Joined: Apr 2012
Reputation: 0
Post: #5
Currently, XBMC is crashing before or right after the splash screen, so I have no way of changing anything from within XBMC.

Can anyone suggest a practical strategy for getting it working again? Based on jopie's suggestion, I guess I could move files out of my library directories.

Thanks,

Floydigus
find quote
Chris! Offline
Donor
Posts: 1,012
Joined: Apr 2010
Reputation: 16
Location: England
Post: #6
Or turn off Update on start up (if that is causing the problem)


Flirc now has a forum: forum.flirc.tv
find quote