Chinese Characters

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
HarryRosen Offline
Senior Member
Posts: 255
Joined: Dec 2009
Reputation: 0
Post: #1
My gf likes to watch chinese shows and the episode names are in chinese, but every time i click on one of the shows, the skin and read it and the words get messed up. is it possible to add a language pack or something so the skin can display them properly?
find quote
Kooshi Offline
Junior Member
Posts: 7
Joined: Sep 2012
Reputation: 0
Post: #2
Not sure if you have found a solution to this, I was in the same boat and this worked for me Big Grin
Under Setting -> Appearance -> Skin set Fonts to Neon-All Languages
Under Setting -> Appearance -> International -> Character set needs to be Chinese Simplified(GBK)
You no longer see the squares and Chinese Characters show up
find quote
Dezz Offline
Junior Member
Posts: 12
Joined: Jul 2013
Reputation: 1
Post: #3
Unfortunately, this does not work for me (XBMCbuntu/Frodo/2.5.9).

Neon still shows the rectangles instead of characters.

Does anyone know of a way to get Simplified Chinese characters to display properly?
find quote
learningit Offline
Senior Member
Posts: 129
Joined: Aug 2012
Reputation: 7
Post: #4
Which font do you have selected under Settings-Appearance-Skins-Fonts?
I have no problems with Arial for simplified characters, there are occasionally issues with traditional chars though.
I have Settings-Appearance-International-Character Set set to default.
I'm running Gotham Alpha7 XBMC
(This post was last modified: 2013-10-07 01:54 by learningit.)
find quote
Dezz Offline
Junior Member
Posts: 12
Joined: Jul 2013
Reputation: 1
Post: #5
Yeah. Arial works fine for the Confluence skin.

In the Neon skin there is only a choice of Default and Neon - All Languages for fonts. Neither of these appear to be working for Chinese characters.
Arabic and a few others seem to work fine.

The International Character Set I'm using is Chinese Simplified (GBK). None of the other Chinese character sets (or Default) seem to work either.
(This post was last modified: 2013-10-07 02:07 by Dezz.)
find quote
mayoman Offline
Fan
Posts: 407
Joined: Dec 2012
Reputation: 10
Post: #6
This is a skin related issue. You can try replacing one of the skin font files with an arialuni.ttf file from Windows in the Neon/fonts folder. This will have a negative effect on English text display though. (Size, aspect ration, and "look" will not be correct). Don't use Neon myself, but names will probably be default.ttf and something like neon.ttf.
If you feel up to it, you can also add Arial as a third option using the same arialuni.ttf file - see here
find quote
Dezz Offline
Junior Member
Posts: 12
Joined: Jul 2013
Reputation: 1
Post: #7
Thanks a lot for your response and the link Mayoman.

I'll give it a try and add Arial as a 3rd option.
find quote