How to switch from XBMC to Ubuntu in XBMCbuntu

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
nickr Offline
Donor
Posts: 8,443
Joined: May 2009
Reputation: 149
Location: Christchurch NZ
Post: #31
Just log out. When it gets back to the login menu, choose xbmc session.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
incognegro76 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #32
(2014-01-02 10:23)nickr Wrote:  Just log out. When it gets back to the login menu, choose xbmc session.

It really should be this easy but it's not.

Once in the Gnome-like desktop under the XBMCbuntu session, there is no obvious way to logout or exit. Ctrl-Alt-Del doesn't work, none of the escape keys work, even when you restart it puts you right back into that blank space desktop.

I even started up XBMC through the XTERM terminal by simply typing in "XBMC" but after it started nothing worked: the movies wouldn't play, the library wouldn't update.

I googled around and found a way out and that is what I posted.

If you know a faster or more intuitive way out, then by all means please share. Smile
find quote
soderlind Offline
Junior Member
Posts: 1
Joined: Feb 2014
Reputation: 0
Post: #33
TL;DR: Remove autologin and select GUI

Had the same problem, here's what I did:

- Switch to console: ctrl+alt F2
- Changed user to root: sudo su
- nano /etc/lightdm/lightdm.conf
- Comment out the lines with autologin-user by inserting a # in front of them
- Save the file and exit nano
- Restart the PC: shutdown -r now

When it starts you'll get the choice to select GUI, select XBMC. Remove the comments you added to /etc/lightdm/lightdm.conf if you want autologin back
find quote
nickr Offline
Donor
Posts: 8,443
Joined: May 2009
Reputation: 149
Location: Christchurch NZ
Post: #34
Guys you are making it too complex.

When in the xbmcbuntu session click the 'start' button - bottom left and choose 'logout', then in the dialog box click 'logout'. OR click the button on the bottom right that looks like an on off switch and get the same dialog. Again click logout.

This will go back to the login screen, where you can choose the xbmcbuntu session or the xbmc session.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
(This post was last modified: 2014-02-19 21:00 by nickr.)
find quote
moonfunk Offline
Junior Member
Posts: 3
Joined: Mar 2014
Reputation: 0
Post: #35
Hi all,

I have a similar but not exactly the same problem. I upgraded my ubuntu in xbmcbuntu to 13.10 and everything went wrong. I am looking to access my xbmcbuntu desktop but it is simply not there and I don't know how to access it.

To explain in further detail when I exit from XBMC I have only have two login options my "user name" and "other" in the drop down menu I cant see"xbmcbuntu" or "xbmc". I can boot into XBMC but the xbmcbuntu desktop has simply disappeared. I am guessing the log in settings were changed in the upgrade.

Can anyone help? I am a Linux noob so a great deal of patience will be required.

Thank you in advance
find quote
mcfang Offline
Junior Member
Posts: 28
Joined: Mar 2011
Reputation: 0
Post: #36
(2014-03-11 23:55)moonfunk Wrote:  To explain in further detail when I exit from XBMC I have only have two login options my "user name" and "other" in the drop down menu I cant see"xbmcbuntu" or "xbmc". I can boot into XBMC but the xbmcbuntu desktop has simply disappeared. I am guessing the log in settings were changed in the upgrade.

In the Ubuntu 13.10 greeter there is a tiny icon right up on the top-right corner of the screen to choose a different desktop session. However 'XBMCbuntu' has disappeared leaving only 'GNOME/Openbox', 'Openbox', and 'XBMC'.
find quote
nickr Offline
Donor
Posts: 8,443
Joined: May 2009
Reputation: 149
Location: Christchurch NZ
Post: #37
Quote:I upgraded my ubuntu in xbmcbuntu to 13.10
Why?

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
moonfunk Offline
Junior Member
Posts: 3
Joined: Mar 2014
Reputation: 0
Post: #38
McFang, Yes I realised that. When I click on Gnome/Openbox and then log on using my user name, it goes to the blue screen with the XBMCbunu logo in the middle nothing else. I cant work out where to go from there.

Nickr - sometimes you have to make silly mistakes to learn from them.
find quote
nickr Offline
Donor
Posts: 8,443
Joined: May 2009
Reputation: 149
Location: Christchurch NZ
Post: #39
(2014-03-12 10:55)moonfunk Wrote:  McFang, Yes I realised that. When I click on Gnome/Openbox and then log on using my user name, it goes to the blue screen with the XBMCbunu logo in the middle nothing else. I cant work out where to go from there.

Nickr - sometimes you have to make silly mistakes to learn from them.
LOL Lesson 1: The first rule of HTPC - if it ain't broke, don't fix it!

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
mcfang Offline
Junior Member
Posts: 28
Joined: Mar 2011
Reputation: 0
Post: #40
(2014-03-12 10:55)moonfunk Wrote:  McFang, Yes I realised that. When I click on Gnome/Openbox and then log on using my user name, it goes to the blue screen with the XBMCbunu logo in the middle nothing else. I cant work out where to go from there.

tried right clicking? you might get a menu
find quote
moonfunk Offline
Junior Member
Posts: 3
Joined: Mar 2014
Reputation: 0
Smile  RE: How to switch from XBMC to Ubuntu in XBMCbuntu
Post: #41
@nickr - I know, I know. I resisted the update reminders for Ringtail and then the ones for the "saucy" salamander began, my curiosity got the the better of me and BANG....I suddenly had a misconfigured HTPC Confused.

@McFang - thanks for replying, I will try what you suggest, when I return home later.
find quote
incognegro76 Offline
Junior Member
Posts: 10
Joined: Jan 2014
Reputation: 0
Post: #42
Okay the reason I couldn't see anything in the posts I made above and had to logout via the methods I had above was because my first XBMCBuntu installation was on my media server attached to 55 inch flat screen. My TV cut off the start menu that should have been at the bottom of the screen. It was my first time so I didn't know it was supposed to be down there.
find quote
nickr Offline
Donor
Posts: 8,443
Joined: May 2009
Reputation: 149
Location: Christchurch NZ
Post: #43
You need to turn overscan off on your TV. Quite how you do this is manufacturer dependent.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
myle Offline
Junior Member
Posts: 39
Joined: Jul 2011
Reputation: 0
Post: #44
Have to Change the login Type

XBMC -> will boot into xbmc

XBMCbuntu -> will boot into a desktop


was under the password box then they move it to the top right hand corner

password is the same

if are coming from windows think of like this

login
password
desktop i want to see

XBMC -> will boot into xbmc
XBMCbuntu -> will boot into a buntu desktop

rember what u do here does have a impact on the XBMC
(This post was last modified: 2014-04-17 02:17 by myle.)
find quote
ananoxoto Offline
Junior Member
Posts: 4
Joined: May 2014
Reputation: 0
Location: Cambre (Galicia)
Post: #45
Hi guys!

I've just installed XBMCbuntu Gotham from scratch. All seemed to work fine, but when I want to exit to the desktop, I can't.

I get to the login window, but I can only change the login and enter the password. There is no combo box to select xbmc or xbmcbuntu, or whatever, so when I enter my login/password I always return to XBMC.

Can anybody help me? Thanks a lot.
find quote