Linux - [Solved]TVHeadend crashing on startup

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
datty Offline
Junior Member
Posts: 7
Joined: Jan 2012
Reputation: 0
Post: #1
Hi all,

Hope its ok for me to get help with this here, the tvheadend forums seem pretty quiet. I've been using XBMC and tvheadend for about 6 months and until a few days ago it was all working fine. On startup tvheadend now crashes totally, the errors output I've pasted below.

[INFO]:dvr: Creating new configuration 'Std'
[ALERT]:CRASH: Signal: 11 in PRG: /usr/local/bin/tvheadend (git-8f76d0c) [54a95c68574e8b7c69120e61bfbfe72e11cd92cd] CWD: /home/datty
[ALERT]:CRASH: Fault address (nil) (Address not mapped)
[ALERT]:CRASH: Loaded libraries: /lib64/librt.so.1 /lib64/libdl.so.2 /usr/lib64/libavahi-common.so.3 /usr/lib64/libavahi-client.so.3 /usr/lib64/libssl.so.1.0.0 /usr/lib64/libcrypto.so.1.0.0 /lib64/libpthread.so.0 /lib64/libm.so.6 /lib64/libc.so.6 /lib64/ld-linux-x86-64.so.2 /usr/lib64/libdbus-1.so.3 /lib64/libz.so.1 /lib64/libnss_compat.so.2 /lib64/libnsl.so.1 /lib64/libnss_nis.so.2 /lib64/libnss_files.so.2
[ALERT]:CRASH: Register dump [23]: 00007f02405429d0 00007f02405429f0 0000000000000064 a3d70a3d70a3d70b 000000004f95db6c 000000004f95e5f8 00007f0240ab1b70 00007f0240aa0680 00007f0240aa0640 0000000000000000 00000000019afdb0 00007f0240aa0680 00007f0240a98ce0 0000000000000000 0000000000000000 00007fff85568cc8 00007f024915b93a 0000000000010283 0000000000000033 0000000000000004 000000000000000e fffffffe7ffbfa17 0000000000000000
[ALERT]:CRASH: STACKTRACE
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/trap.c:139 0x421b88
[ALERT]:CRASH: ??:0 0x7f02497037d0
[ALERT]:CRASH: ??:0 0x7f024915b93a
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_db.c:271 0x4268bc
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_db.c:359 0x426c3a
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_db.c:379 0x426c9d
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_autorec.c:509 0x429166
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_autorec.c:374 0x4295fc
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dtable.c:86 0x406bbb
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/dvr/dvr_db.c:921 0x42781d
[ALERT]:CRASH: /opt/tvheadend/src/tvheadend/src/main.c:414 0x4051df
[ALERT]:CRASH: __libc_start_main+0xec (/lib64/libc.so.6)
[ALERT]:CRASH: ??:0 0x404749
Segmentation fault

I have recently updated my box, as shown its running tvheadend from opdenkamp built this morning (git 8f76d0c). Not sure if its relevant but I have glibc 2.14.1 installed (just because it mentions libc in the crash).

Would greatly appreciate any help with this!

Edit:
Just to let anyone know who's having similar problems, if i remove epgdb from the .hts userdata folder it is able to start up fine. There seems to be an issue with tvheadend and the data supplied by tv_grab_dvb_plus, using EIT data works fine.
(This post was last modified: 2012-04-23 10:11 by datty.)
find quote
Prof Yaffle Offline
Donor
Posts: 1,166
Joined: Mar 2011
Reputation: 28
Location: UK - in the middlish (mostly).
Post: #2
Just to confirm this behaviour - I updated my system tonight and everything resolutely refused to work. Starting tvheadend from the command line, it would appear in the process list and then vanish shortly after... I saw the same behaviour restarting it as a service. However, removing ~/.hts/tvheadend/epgdata and I could restart the service, and then re-enable the PVR client in XBMC.

From /var/log/syslog:


Code:
May 21 21:09:34 XBMCLive tvheadend[23810]: dvb: Found adapter /dev/dvb/adapter0 (DiBcom 7000PC) via USB (480 Mbit/s)
May 21 21:09:34 XBMCLive tvheadend[23810]: dvb: Found adapter /dev/dvb/adapter1 (Conexant CX24116/CX24118) via USB (480 Mbit/s)
May 21 21:09:35 XBMCLive kernel: [1557158.066633] tbsqboxs2: tbsqboxs2_set_voltage 0
May 21 21:09:40 XBMCLive tvheadend[23810]: EPG: Injected 50644 event from disk database
May 21 21:09:40 XBMCLive tvheadend[23810]: dvr: Creating new configuration ''
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: Signal: 11 in PRG: /usr/bin/tvheadend (2.12.99~pulse-6) [07f24a20ca129aaabd5d3dd2487a8f36b6477bc2] CWD: /
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: Fault address (nil) (Address not mapped)
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: Loaded libraries: /lib/tls/i686/cmov/librt.so.1 /lib/tls/i686/cmov/libdl.so.2 /usr/lib/libavahi-common.so.3 /usr/lib/libavahi-client.so.3 /lib/i686/cmov/libssl.so.0.9.8 /lib/i686/cmov/libcrypto.so.0.9.8 /lib/tls/i686/cmov/libpthread.so.0 /lib/tls/i686/cmov/libm.so.6 /lib/tls/i686/cmov/libc.so.6 /lib/ld-linux.so.2 /lib/libdbus-1.so.3 /lib/libz.so.1 /lib/tls/i686/cmov/libnss_compat.so.2 /lib/tls/i686/cmov/libnsl.so.1 /lib/tls/i686/cmov/libnss_nis.so.2 /lib/tls/i686/cmov/libnss_files.so.2
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: Register dump [19]: 00000033 c0100000 ffff007b 0000007b b624a4f0 4fbba9f0 bfef2ca8 bfef2bcc b09a5948 b09a5130 b0992900 00000000 0000000e 00000004 00241228 00000073 00210286 bfef2bcc 0000007b
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: STACKTRACE
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: ??:0 0x80692ba
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: __kernel_rt_sigreturn+0x0  ()
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: ??:0 0x806e883
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: ??:0 0x806e90a
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: ??:0 0x807049c
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: ??:0 0x8070d8a
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: ??:0 0x804db77
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: ??:0 0x8070713
May 21 21:09:40 XBMCLive tvheadend[23810]: CRASH: ??:0 0x806e003
May 21 21:09:41 XBMCLive tvheadend[23810]: CRASH: ??:0 0x804c06f
May 21 21:09:41 XBMCLive tvheadend[23810]: CRASH: __libc_start_main+0xe6  (/lib/tls/i686/cmov/libc.so.6)
May 21 21:09:41 XBMCLive tvheadend[23810]: CRASH: ??:0 0x804b411
May 21 21:09:41 XBMCLive kernel: [1557163.478858] tvheadend[23810]: segfault at 0 ip 00241228 sp bfef2bcc error 4 in libc-2.11.1.so[129000+153000]

I'll go and see if I can raise a ticket on PulseEight or Lonely Coder...

-----

EDIT: Seems to be similar to https://www.lonelycoder.com/redmine/issues/996
(This post was last modified: 2012-05-22 00:07 by Prof Yaffle.)
find quote
Prof Yaffle Offline
Donor
Posts: 1,166
Joined: Mar 2011
Reputation: 28
Location: UK - in the middlish (mostly).
Post: #3
New bug report for a more specific tvheadend version (2.12.99~pulse-6) filed here: https://www.lonelycoder.com/redmine/issues/1019
find quote
Prof Yaffle Offline
Donor
Posts: 1,166
Joined: Mar 2011
Reputation: 28
Location: UK - in the middlish (mostly).
Post: #4
Looks like it's resolved now - no explicit bugfix, but it appears to be no longer apparent in 2.99-7~lucid/2.99.37.1332f9f.
find quote