Solved Issue - XBMCbuntu Wireless option?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
hunterx Offline
Junior Member
Posts: 48
Joined: Feb 2012
Reputation: 0
Post: #1
Living in an apartment, it's difficult to run an rj45 through walls and under carpets. I wanted to simplify the purpose of my laptop in the bedroom so I installed XBMCbuntu per the Wiki instructions, but there's no wireless? I have never played with a linux system, so if there is a way to run some type of script to install a wireless driver, or some other way such as hosting the drivers on a thumbdrive, please let me know. If you have a tutorial on it, I would love to learn.

The system requirements did not mentioned a physical connection, and I didn't think it would have mattered.

http://wiki.xbmc.org/index.php?title=XBM..._XBMCbuntu

Thanks for any help you can provide.
(This post was last modified: 2013-05-15 15:42 by Kib.)
find quote
John410312 Offline
Junior Member
Posts: 26
Joined: Jan 2012
Reputation: 0
Post: #2
Eden 11 is easy...exit into XBMCBuntu. (The little circle in the bottom left)

Login to Xbmcbuntu. Network setup is in the bottom right.
find quote
hunterx Offline
Junior Member
Posts: 48
Joined: Feb 2012
Reputation: 0
Post: #3
I will have a look when I get home, but if it matters the installation was setup so that it logs straight into XBMC. Inside of that software, I couldn't find a wireless network setting. I don't recall seeing a circle in the bottom left within XBMC software, just the "playlist" and shutdown options.
find quote
vikjon0 Offline
---
Posts: 2,463
Joined: Apr 2009
Reputation: 7
Location: Sweden
Post: #4
when you installed you had the option to connect to wireless. If you did not do that you can re-install or follow the advice from John410312
find quote
John410312 Offline
Junior Member
Posts: 26
Joined: Jan 2012
Reputation: 0
Post: #5
I didn't have the option to connect to wireless...BUT...

@hunterx. Click the Shutdown options button and click EXIT. You'll be presented with a dropdown box either XBMC or XBMCbuntu. Select XBMCbuntu. Select login as XBMC (not other) and whatever your password was you set during install.
find quote
hunterx Offline
Junior Member
Posts: 48
Joined: Feb 2012
Reputation: 0
Post: #6
I did not have the option to connect to wireless, but I was connected directly to an RJ45 during installation (as I am accustomed to for Windows installations). I wonder if I were to get that option if I installed it without being plugged in directly.

John, thanks, I will look for that option. There's a lot of wiki articles on running commands from the terminal, I just can't figure out how to get to that point. I will look for that option later.

Thanks again.
find quote
hunterx Offline
Junior Member
Posts: 48
Joined: Feb 2012
Reputation: 0
Post: #7
I got into the XBMC Buntu OS, and found the wireless but it must not have the right wireless drivers. Now I need to figure out how to install them...
find quote
hunterx Offline
Junior Member
Posts: 48
Joined: Feb 2012
Reputation: 0
Post: #8
I've ran through the guides on here: https://help.ubuntu.com/community/WifiDo...de/Drivers

running the LSHW command gives me a list of all my hardware and drivers. There seems to be 2 *-network for my wireless...one is in a disabled state.

Quote:*-network
description: Network controller
product: BCM4311 802.11a/b/g
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:0c:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=b43-pci-bridge latency=0
resources: irq:17 memory:efdfc000-efdfffff

*-network DISABLED
description: Wireless interface
physical id: 1
logical name: wlan0
serial: 00;19:7e:8c:49:ff
capabilities: ethernet physical wireless
configuration: braodcast=yes driver=b43 driverversion=3.0.0-17-generic firmware=N/A multicast=yes wireless=IEEE 802.11bg

Here is the IWCONFIG command results:

Quote:wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on

Unfortunately I know my wireless is working and on. The bluetooth light is on, and I actively used the wireless up until minutes before I installed XBMCbunto.
find quote
hunterx Offline
Junior Member
Posts: 48
Joined: Feb 2012
Reputation: 0
Post: #9
Found this on ubuntu forums, and it worked Smile

1)Ubuntu 11.04 Natty Narwhal
2)Dell
3)Latitude D620

Everything works out of the box but Wi-Fi. To enable it, install two packages:

b43-fwcutter
firmware-b43-installer

They can be installed from the Software Center or through the command line:

sudo apt-get install b43-fwcutter firmware-b43-installer

A reboot is not necessary - after the install is complete you should have working wifi and the wifi light should light up as well.
find quote
Bets Offline
Junior Member
Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #10
hunterx, I have a Dell too and it also worked. Thanks!
(This post was last modified: 2012-04-29 16:32 by Bets.)
find quote
Rhyknowscerious Offline
Junior Member
Posts: 2
Joined: Mar 2012
Reputation: 0
Location: Florida
Post: #11
(2012-04-25 06:01)hunterx Wrote:  Found this on ubuntu forums, and it worked Smile

1)Ubuntu 11.04 Natty Narwhal
2)Dell
3)Latitude D620

Everything works out of the box but Wi-Fi. To enable it, install two packages:

b43-fwcutter
firmware-b43-installer

They can be installed from the Software Center or through the command line:

sudo apt-get install b43-fwcutter firmware-b43-installer

A reboot is not necessary - after the install is complete you should have working wifi and the wifi light should light up as well.

I'm using an hp dv9500. Just got this to work. My God. It took me like months. THAAAANNNNK YOUUUUUU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
find quote