[Release] Universal Movie Scraper

  Thread Rating:
  • 7 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
olympia Offline
Team-Kodi Member
Posts: 2,502
Joined: May 2008
Reputation: 32
Post: #901
(2014-10-05 01:29)mortstar Wrote:  It seems that RottenTomatoes isn't returning the correct rating (at least for TomatoMeter/All), nor the Critics' Consenus. Every movie gets a score of 1.0, they've recently updated their site layout so I'm guessing that is connected. Here's a log refreshing a movie's info http://xbmclogs.com/show.php?id=310648

EDIT:

ParseRTTomAll RegExp needs changing to: "all-critics-meter".*?([0-9]+).*?Reviews Counted:.*?([0-9]+)
ParseRTTomTop RegExp needs changing to: "top-critics-meter".*?([0-9]+).*?Critic Reviews: ([0-9]+) (plus above RegExp in first function)
ParseRTOutline RegExp needs changing to: Critics Consensus:</span> ([^<]+)</p>

ParseRTAveAll and ParseRTAveTop are fine.

This is extremely quick research, tested against only two movies not on boundary conditions, caveat emptor!

This should be fixed by now.
find quote
bmac88 Offline
Junior Member
Posts: 9
Joined: Mar 2013
Reputation: 0
Post: #902
(2014-10-09 09:11)olympia Wrote:  
(2014-10-05 01:29)mortstar Wrote:  It seems that RottenTomatoes isn't returning the correct rating (at least for TomatoMeter/All), nor the Critics' Consenus. Every movie gets a score of 1.0, they've recently updated their site layout so I'm guessing that is connected. Here's a log refreshing a movie's info http://xbmclogs.com/show.php?id=310648

EDIT:

ParseRTTomAll RegExp needs changing to: "all-critics-meter".*?([0-9]+).*?Reviews Counted:.*?([0-9]+)
ParseRTTomTop RegExp needs changing to: "top-critics-meter".*?([0-9]+).*?Critic Reviews: ([0-9]+) (plus above RegExp in first function)
ParseRTOutline RegExp needs changing to: Critics Consensus:</span> ([^<]+)</p>

ParseRTAveAll and ParseRTAveTop are fine.

This is extremely quick research, tested against only two movies not on boundary conditions, caveat emptor!

This should be fixed by now.

Are you saying that this should be fixed as in "why hasn't it been fixed?" or that we should no longer be seeing this problem? I checked last night that the Universal Scraper plugin was updated then re-scraped on a movie which had a 1.0 rating, and it came back again with the 1.0 rating (obviously using Rotten Tomatoes for ratings).
find quote
olympia Offline
Team-Kodi Member
Posts: 2,502
Joined: May 2008
Reputation: 32
Post: #903
Means that you should no longer be seeing this problem... If you are, try a force refresh on the xbmc repo from within the addon browser. If it still comes back with 1.0 after a refresh, give me an example.

Edit: ..and if I am saying "by now", don't think a check last night is good enough Tongue
(This post was last modified: 2014-10-09 22:35 by olympia.)
find quote
Kedryn Offline
Junior Member
Posts: 4
Joined: Mar 2013
Reputation: 0
Post: #904
Hello
i'm using Universal Movie Scraper, but i have a problem.
For some movies i have trailers stored in the movie folder.
When UMS scans those folders, it generates 2 entries in the db, where the only difference between them is the c19 field,
one has the path plugin: with the url of the trailer on youtbe, the other has the smb: with the path to the movie trailer in the movie folder
is that a bug?
find quote
wgstarks Offline
Posting Freak
Posts: 1,143
Joined: Jun 2013
Reputation: 7
Location: North Carolina, USA
Post: #905
(2014-10-11 16:23)Kedryn Wrote:  Hello
i'm using Universal Movie Scraper, but i have a problem.
For some movies i have trailers stored in the movie folder.
When UMS scans those folders, it generates 2 entries in the db, where the only difference between them is the c19 field,
one has the path plugin: with the url of the trailer on youtbe, the other has the smb: with the path to the movie trailer in the movie folder
is that a bug?

You can have UMS ignore trailers. If you haven't already created an advancedsettings.xml file you will need to do so, and include this code-
Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<advancedsettings>
    <video>
        <excludefromscan>
            <regexp>-trailer</regexp>    
        </excludefromscan>
        <excludetvshowsfromscan>
            <regexp>-trailer</regexp>
    </video>
</advancedsettings>

This will tell UMS to ignore any video files as long as they are named like this-
[Image: 2wgrbyc.jpg]

Trailer is named exactly the same as the associated video file with the -trailer tag appended.

[Image: all-thin-banner.jpg]
MacMini5,2 HTPC (Gotham 13.2/Aeon Nox Redux 5.1.5/MacOSX 10.8.5)/Onkyo TXNR609/Panny65VT30
(This post was last modified: 2014-10-11 16:58 by wgstarks.)
find quote
Kedryn Offline
Junior Member
Posts: 4
Joined: Mar 2013
Reputation: 0
Post: #906
Ok done... i'll do a new scan soon.

But i would like to know if it's a bug, or i'm doing something wrong, with trailers

my trailers are named exaclty like the one you posted
find quote
wgstarks Offline
Posting Freak
Posts: 1,143
Joined: Jun 2013
Reputation: 7
Location: North Carolina, USA
Post: #907
I wouldn't call it a bug really. Just a requirement to have Kodi ignore these videos. There are other addons that also have to use regexp's.

Make sure you clean your DB to remove the old listings of the trailers.

[Image: all-thin-banner.jpg]
MacMini5,2 HTPC (Gotham 13.2/Aeon Nox Redux 5.1.5/MacOSX 10.8.5)/Onkyo TXNR609/Panny65VT30
find quote
Post Reply