Windows - No more animated Fanart on the mainscreen

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Chang Offline
Junior Member
Posts: 26
Joined: Jun 2010
Reputation: 0
Post: #1
Hi forum, hi ronie,

I updated xbmc to eden and updated also transparency to the current version.
After the update lost the animated fanart on the movie screen (see picture). I looked through all the settings and compared with the older version were animated fanart worked fine but I could not find what I did wrong.

[Image: 3hxy1qv56rk4.jpg]

Any hint what I can do to bring back the animation on the movie screen?

Thank you very much.
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #2
this settings should be enabled:
Settings > Skin Settings > Backgrounds > Home - Movies > Fanart

and disable this one:
Settings > Skin Settings > Backgrounds > Home - Movies > Options > Custom backgrounds

that should be all there's too it.


if you want custom backgrounds, you can enable that setting again and select the appropriate folder where your fanart is located.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Chang Offline
Junior Member
Posts: 26
Joined: Jun 2010
Reputation: 0
Sad  RE: No more animated Fanart on the mainscreen
Post: #3
Thank you for jumping on this thread ronie.

My settings are as pictured, but no animated fanart .

[Image: 5jjakvb643j.png]
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #4
ok, let's start with a Debug Log then :-)

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Chang Offline
Junior Member
Posts: 26
Joined: Jun 2010
Reputation: 0
Post: #5
So i enabled the debugger an my debug log is here.

Thank you for your help.
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #6
thanx for the log. i don't spot any errors there.

could you check if any images are available in this folder:
C:\Users\Torsten\AppData\Roaming\XBMC\userdata\Thumbnails\Video\Fanart

that's where the skin tries to load them from.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Chang Offline
Junior Member
Posts: 26
Joined: Jun 2010
Reputation: 0
Post: #7
Thank you ronie.

There are no images in this location, only TBN files.

If there is no easier way, my best guess is to uninstall xbmc and to reinstall it. I save the database as seperate files so i can re-import very easy.
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #8
(2012-05-01 16:35)Chang Wrote:  There are no images in this location, only TBN files.
those are cached image files and the ones the skin uses for the fanart slideshow on home.

i'm clueless why it doesn't work at your end.

you could try if the 'custom folder' option does work:
Settings > Skin Settings > Backgrounds > Home - Movies > Options > Custom backgrounds

and select a folder containing some images.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Chang Offline
Junior Member
Posts: 26
Joined: Jun 2010
Reputation: 0
Post: #9
I followed your suggestion.

Your skin works ! The pictures are animated as it was before. I will try a complete re-install of xbmc.

Thank you very much for your kind help.
find quote
Chang Offline
Junior Member
Posts: 26
Joined: Jun 2010
Reputation: 0
Post: #10
This is strange!

I reinstalled xbmc and imported my database.

T! works with my prefered settings and shows animated fanart. But the wired thing is that the folder C:\Users\Torsten\AppData\Roaming\XBMC\userdata\Thumbnails\Video\Fanart still contains only tbn files and no images.
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #11
(2012-05-01 17:46)Chang Wrote:  This is strange!

I reinstalled xbmc and imported my database.

T! works with my prefered settings and shows animated fanart. But the wired thing is that the folder C:\Users\Torsten\AppData\Roaming\XBMC\userdata\Thumbnails\Video\Fanart still contains only tbn files and no images.

tbn files are images Smile
xbmc changes the extension to .tbn, but they are just regular jpeg files.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Chang Offline
Junior Member
Posts: 26
Joined: Jun 2010
Reputation: 0
Lightbulb  RE: No more animated Fanart on the mainscreen
Post: #12
OK, i got it.

Thank you.
find quote
ag3141 Offline
Junior Member
Posts: 32
Joined: Aug 2012
Reputation: 0
Post: #13
This skin is only getting cooler! I didn’t know this existed. What else have I missed?

Q: Is it possible to have the moving fanart displayed on the “golden cinema” screen instead of the ugly blue?

No wonder I was depressed using Collectorz. Compared to XBMC it’s a steam driven 8 bit software.
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #14
(2012-08-16 05:43)ag3141 Wrote:  Q: Is it possible to have the moving fanart displayed on the “golden cinema” screen instead of the ugly blue?

nope, there's no option the change the background screen on which the fanart is displayed.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote