Touch screen in full screen mode

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
rupansansei1973 Offline
Junior Member
Posts: 2
Joined: May 2012
Reputation: 0
Post: #1
Hi,

I'm testing a setup of XBMC on Ubuntu 12.04 running on an old ASUS EeeTop with touchscreen.

The resistive touch screen natively installed on the PC works well with ubuntu 12.04 without installing any driver.
When I launch XBMC in full screen mode the touch screen stop working.
It seems to be not calibrated.
Exiting XBMC the touch screen works again.

If I start XBMC in windowed mode (no full screen) the touch screen works.

Someone can help me to solve this issue?
find quote
boblablah Offline
Junior Member
Posts: 14
Joined: Sep 2011
Reputation: 0
Post: #2
Have you enabled the touchscreen support in the XBMC settings menus? I believe it's under the input area where you would add additional info about how your remote control works...
find quote
rupansansei1973 Offline
Junior Member
Posts: 2
Joined: May 2012
Reputation: 0
Post: #3
Hi boblablah,

yes, the touchscreen / mouse support is enabled.
If I disable this setting also the mouse stop working then it has to be enabled.

In the settings menu there is no other parameter related to the touchscreen.

What do you mean with remote control?
I'm not using any remote control right now, I only need to control XBMC (in full screen) with the builtin touchscreen of the eeeTop.

Lucio
find quote
mmoalem Offline
Junior Member
Posts: 4
Joined: Nov 2008
Reputation: 0
Post: #4
hi there - wondered if you have solved this as i am facing same...
find quote
onny Offline
Junior Member
Posts: 5
Joined: Aug 2011
Reputation: 0
Post: #5
Hi,
I had setup XMBC in ArchLinux, see http://www.project-insanity.org/2011/12/...-frontend/
Touch support is fine after calibrating and configuring it in Xorg.conf. But one-finger scrolling in the file or playlist browsers won't work. Any hint for that?
I saw someone did this in XBMC using Ubuntu but I cannot tell iyet f this is driver-, theme- or config-related.
find quote
yokosuna Offline
Junior Member
Posts: 5
Joined: Jan 2011
Reputation: 0
Post: #6
Same Problem for me, too
Any solution ?
find quote
yokosuna Offline
Junior Member
Posts: 5
Joined: Jan 2011
Reputation: 0
Post: #7
No idea ?
find quote
yokosuna Offline
Junior Member
Posts: 5
Joined: Jan 2011
Reputation: 0
Sad  RE: Touch screen in full screen mode
Post: #8
I cannot believe that nobody can answer this question ...
find quote
Muschl Offline
Junior Member
Posts: 4
Joined: Jan 2012
Reputation: 0
Lightbulb  RE: Touch screen in full screen mode
Post: #9
try to set in /etc/environment the following parameter and restart the windowmanager

SDL_VIDEO_X11_DGAMOUSE=0
find quote
Jules Offline
Donor
Posts: 53
Joined: Jul 2012
Reputation: 0
Post: #10
+1 on a solution here. Nothing is working. Multitouch working great in Ubuntu 12.04, as soon as I start XBMC-Frodo, No more touchscreen!

Any other solutions out there?
Skin = ReTouched
(This post was last modified: 2013-10-18 01:30 by Jules.)
find quote
BuddyLuvve Offline
Junior Member
Posts: 3
Joined: Dec 2013
Reputation: 0
Post: #11
Hey all... I was having this problem, and I found this:

http://trac.xbmc.org/ticket/11051

It appears the problem is related to the non-system mouse cursor in xbmc... As per comment 1, I added the line "export SDL_MOUSE_RELATIVE=0" (without quotes) to my /usr/bin/xbmc script, and it worked like a charm... Hope it helps you guys. :-) Long live Tux!
find quote