"Display refresh rate to match video" on Intel based systems

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
NickoP Offline
Junior Member
Posts: 23
Joined: Apr 2012
Reputation: 0
Post: #1
Hi there,
I am new to this forum and new to HTPC at all, so please be patient.
My system is based on Intel Z77 and i3 2100 Win7 x64 and I don’t use any additional graphics card (maybe I should?). The HDMI of the MB is connected to Sharp TV through Yamaha receiver. Both they support all standard refreshed rates.
After a lot of experimentation the only way to play smoothly our m2ts home videos came out to be the dsplayer option with LAV filters.
Now about the question I have: When I turn on the “Adjust display refresh rate to match video” option nothing seems to happen: the refresh rate stays 60p as set in Intel Graphics, although the source refresh rate may be different (tried with 24, 23.97, 30, 50, etc.).
Any ideas?
(This post was last modified: 2012-05-09 17:32 by NickoP.)
find quote
bluray Offline
Posting Freak
Posts: 8,316
Joined: May 2011
Reputation: 145
Post: #2
For Intel HD2000 iGPU, these settings will work better.......

1. Install the latest Intel driver- Check your system for the latest updates
2. Install- Intel Management Engine Interface Driver]Intel Magagement Engine Interface Driver
3. Disable DXVA2 and everything else in XBMC settings/video/playback
4. Disable "Use a fullscreen window rather than true fullscreen" in XBMC settings/system/video output
5. Turn off UAC "Disable User Account Control (UAC) in Windows 7". If you want to read what others said about it, you can check out this thread- Let's set this straight - No one can do 24p consistently well

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
(This post was last modified: 2012-05-09 18:11 by bluray.)
find quote
NickoP Offline
Junior Member
Posts: 23
Joined: Apr 2012
Reputation: 0
Post: #3
(2012-05-09 18:02)bluray Wrote:  For Intel HD2000 iGPU, these settings will work better.......

1. Install the latest Intel driver- Check your system for the latest updates
2. Install- Intel Management Engine Interface Driver]Intel Magagement Engine Interface Driver
3. Disable DXVA2 and everything else in XBMC settings/video/playback
4. Disable "Use a fullscreen window rather than true fullscreen" in XBMC settings/system/video output
5. Turn off UAC "Disable User Account Control (UAC) in Windows 7". If you want to read what others said about it, you can check out this thread- Let's set this straight - No one can do 24p consistently well

Thanks bluray. By "these settings will work better......." I should go back to the standrd Eden version (not dsplayer - LAV filters)?
I have all latest updates from ASUS (the MB is P8Z77 M Pro). I was reluctant to install the Intel Management Engine as it was written that it is for Intel MB only, but I will give it try. And yes, I will read the thread you suggested.
find quote
bluray Offline
Posting Freak
Posts: 8,316
Joined: May 2011
Reputation: 145
Post: #4
(2012-05-09 20:16)NickoP Wrote:  
(2012-05-09 18:02)bluray Wrote:  For Intel HD2000 iGPU, these settings will work better.......

1. Install the latest Intel driver- Check your system for the latest updates
2. Install- Intel Management Engine Interface Driver]Intel Magagement Engine Interface Driver
3. Disable DXVA2 and everything else in XBMC settings/video/playback
4. Disable "Use a fullscreen window rather than true fullscreen" in XBMC settings/system/video output
5. Turn off UAC "Disable User Account Control (UAC) in Windows 7". If you want to read what others said about it, you can check out this thread- Let's set this straight - No one can do 24p consistently well

Thanks bluray. By "these settings will work better......." I should go back to the standrd Eden version (not dsplayer - LAV filters)?
I have all latest updates from ASUS (the MB is P8Z77 M Pro). I was reluctant to install the Intel Management Engine as it was written that it is for Intel MB only, but I will give it try. And yes, I will read the thread you suggested.
The settings above work great with XBMC (Current Stable Release: 11.0 “Eden”) on the HD2000. Some users cannot get Intel iGPU to bitstream HD audio correctly till they installed management engine driver. If any of the above don't make any different, you can always un-do it.....

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
NickoP Offline
Junior Member
Posts: 23
Joined: Apr 2012
Reputation: 0
Post: #5
Bluray, I read the thread you suggested, but it did not seem to reflect my problem: what bothered me was not periodical frame skipping due to frequency mismatch, it was that the graphic engine would never switch to the refresh rate of the material being played – it always stayed 60 fps as set in Intel Graphics.
Anyhow, it seems to be solved. I tried all this:
- Checked the drivers - all current;
- Turned UAC OFF - didn’t make any difference
- Turned On/Off DXVA2, DXVA2 copy-back, Intel QuickSync in LAV filters also didn’t make difference other than without them the CPU load would jump high.

Finally what made difference was installing the beta version of Intel HD Graphics Driver for Windows - http://downloadcenter.intel.com/SearchRe...amilyId=39
http://downloadcenter.intel.com/SearchRe...amilyId=39
Maybe it was not the Beta version, but the current version simply needed reinstallation? Anyways, it works now.
Thanks for your help 
find quote
bluray Offline
Posting Freak
Posts: 8,316
Joined: May 2011
Reputation: 145
Post: #6
(2012-05-10 16:48)NickoP Wrote:  Maybe it was not the Beta version, but the current version simply needed reinstallation? Anyways, it works now.
Thanks for your help 
I threw all the scenarios in there, and I know one of them will work. Most of the time it is not XBMC problem and driver is the main cause of playback problem.

I'm glad that it work for you now........Nod

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote