[SOLVED] Preventing system sleep when using Advanced Launcher

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
deadwolfbones Offline
Senior Member
Posts: 141
Joined: Aug 2007
Reputation: 0
Post: #1
Hey guys,

Kind of a weird one...

I have no problems with video playback when watching things inside of XBMCbuntu.

However, I set up Advanced Launcher (per this guide) to launch a full-screen Chromium browser window so I can watch flash-based streaming sites (ESPN3, SPEED2, etc) that don't have great plugin support in XBMC. Everything works fluidly, except that after about 10 minutes my receiver loses its HDMI connection with the HTPC. At first, I only noticed this happening while watching full-screen video, and I found that if I hit ESC to exit the full-screen video mode, the HDMI connection was immediately re-established.

Then, I left the Chromium window open on a random website, with no video playing, and walked away. About 10 minutes later, it lost its HDMI connection again. So, I'm assuming this has nothing to do with video playback and is instead some general setting somewhere in LXDE.

Anyone have any ideas as to what might be causing it?
(This post was last modified: 2012-05-14 00:02 by deadwolfbones.)
find quote
wsnipex Online
Team-XBMC packaging monkey
Posts: 3,511
Joined: Jun 2011
Reputation: 84
Post: #2
maybe xbmcs screensaver/powersaving?
find quote
deadwolfbones Offline
Senior Member
Posts: 141
Joined: Aug 2007
Reputation: 0
Post: #3
I have XBMC set to turn off the display after 60 minutes idle, but this is definitely happening much, much sooner. Could be the screensaver, I'll look into that.
find quote
Angelscry Offline
Skilled Python Coder
Posts: 3,247
Joined: Sep 2010
Reputation: 52
Location: MTL, Canada
Post: #4
(2012-05-12 20:27)deadwolfbones Wrote:  I have XBMC set to turn off the display after 60 minutes idle, but this is definitely happening much, much sooner. Could be the screensaver, I'll look into that.
You will found here a way to disable system sleep : http://forum.xbmc.org/showthread.php?tid...pid1073943

Advanced Launcher | Manual | WiKi | Forums | Tutorials | Gallery | GitHub | Archives | Donate

find quote
deadwolfbones Offline
Senior Member
Posts: 141
Joined: Aug 2007
Reputation: 0
Post: #5
Thanks, that's potentially quite helpful.
find quote
Plaguester Offline
Senior Member
Posts: 262
Joined: May 2010
Reputation: 7
Post: #6
It's actually better to just turn it off in your script that launches your application: See this post. That way the screensaver or screenblank and other DPMS functions will behave normally when your script finishes.

HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
find quote
deadwolfbones Offline
Senior Member
Posts: 141
Joined: Aug 2007
Reputation: 0
Post: #7
Thanks, I'll give it a try.

Does your solution have exactly the same effect for my purposes (preventing X from going to sleep)?
find quote
Plaguester Offline
Senior Member
Posts: 262
Joined: May 2010
Reputation: 7
Post: #8
Yup. "xset s off" turns the screensaver off and "xset -dpms" prevents X from going into any of the power saving modes (standby, suspend, hibernate, etc). I use it for SNES emulation because X doesn't count gamepad input as input. Just put the rest of your launch script in place of the zsnes line in the example.

HTPC 1 - Zotac ZBOX ID80U | 4GB RAM | 64GB SSD | Openelec | Confluence
HTPC 2 - Zotac ZBOX ID41U | 4GB RAM | 60GB SSD | Openelec | Confluence
Server - unRAID Server | 3 x 2TB WD Green HDD, 1TB WD Black HDD (Cache) | Sabnzbd | CouchPotato | Sickbeard
find quote
deadwolfbones Offline
Senior Member
Posts: 141
Joined: Aug 2007
Reputation: 0
Post: #9
Yep, this worked great. Thanks so much!
find quote
Aperkins Offline
Junior Member
Posts: 32
Joined: Mar 2014
Reputation: 0
Post: #10
Would it be possible for anyone to explain this in a little more detail? I have a similar issue I am running xbmcubuntu from a pc out hdmi to my av receiver, and when the pc goes to sleep I lose my hdmi handshake and have to reboot the pc to get xbmc picture back. I need to disable the system from going to sleep but I have no idea how to edit scripts or even where to begin that process. Any help would be greatly appreciated. Thanks.
find quote