[Linux] XBMCbuntu unusable FPS in menus

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
F-Wolf Offline
Member
Posts: 63
Joined: Apr 2009
Reputation: 0
Post: #1
I just recently installed XBMCbuntu to dual boot on one of my kids PC's, the idea being that when Windows 7 parental control kicked in, they could still reboot the computer into XBMC to watch TV Shows, etc.

The computer runs windows 7 fine, has 2 gigs of ram, a ATI x1900, and AMD Athlon 64 FX-60 processor.

System info in XBMC always has one of the cores at 95-100% and the other at 1-3%, 1927MB free of ram, and the FPS between .5-.9

Obviously with that low of a FPS, its pretty much unusable. Am I missing something? Some kind of incompatibility?
find quote
Snippo Offline
Senior Member
Posts: 142
Joined: Dec 2011
Reputation: 4
Post: #2
Try updating the GPU driver (your card isn't supported by the latest fglrx so you are limited to the open source driver):
Code:
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get purge fglrx*
sudo apt-get install xserver-xorg-video-ati
sudo dpkg-reconfigure xserver-xorg
Then change /etc/X11/xorg.conf to:
Code:
Section "Device"
    Identifier "Radeon"
    Driver "radeon"
EndSection
I had the same problem a few days ago on an ancient notebook. If I remember correctly I fixed it by doing the above.
find quote
F-Wolf Offline
Member
Posts: 63
Joined: Apr 2009
Reputation: 0
Post: #3
(2012-05-14 23:41)Snippo Wrote:  Try updating the GPU driver (your card isn't supported by the latest fglrx so you are limited to the open source driver):
Code:
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get purge fglrx*
sudo apt-get install xserver-xorg-video-ati
sudo dpkg-reconfigure xserver-xorg
Then change /etc/X11/xorg.conf to:
Code:
Section "Device"
    Identifier "Radeon"
    Driver "radeon"
EndSection
I had the same problem a few days ago on an ancient notebook. If I remember correctly I fixed it by doing the above.

I followed all your steps, but I don't seem to have a xorg.conf

[Image: xorg.png]

EDIT: I just pulled out the old card and replaced it with a AMD 4650 HD. I ran all the commands you suggest above, but never found xorg.conf to edit it, will I be ok or should I reinstall XBMCbuntu?

EDIT2: Answered my own question, won't even post video to the XBMCbuntu with the new card in it, reinstalling now.
(This post was last modified: 2012-05-15 00:43 by F-Wolf.)
find quote
Snippo Offline
Senior Member
Posts: 142
Joined: Dec 2011
Reputation: 4
Post: #4
You're right. xorg.conf isn't created by default. You can just create it yourself.
If you're using the AMD 4650 HD you should get fglrx-updates instead of xserver-xorg-video-ati. When you get a black screen you can boot to recovery mode in grub (holding shift or space while booting loads the grub menu).
With the 4650 HD you should do the following (http://wiki.cchtml.com/index.php/Ubuntu_...tion_Guide)
Code:
sudo apt-get update
sudo apt-get install fglrx-updates fglrx-amdcccle
With the 4650 HD you can also use Xvba.
find quote
F-Wolf Offline
Member
Posts: 63
Joined: Apr 2009
Reputation: 0
Post: #5
What I did so far was just re-install XBMCbuntu from scratch with the 4650 HD in it. Do you still suggest I do the whole fglrx thing? It seems to be running fine so far.

Also, as this is primarily for the kids (oldest one 8) I was trying to make grub a little more friendly. I managed to default the selection to Windows 7 (as that's what they will be primarily using), but is there a way to make it, I dunno...look pretty? Maybe a GUI type grub? Ideally I would like It two boot, and there be two options Windows 7 and XBMC. Maybe with just there logos. One giant Windows Logo and One giant XBMC logo, and the kids can easily distinguish what is what (the youngest doesn't read well yet).

It's a minor thing tho.
find quote
Snippo Offline
Senior Member
Posts: 142
Joined: Dec 2011
Reputation: 4
Post: #6
I'd advise to update the fglrx(-updates) driver and use the Xvba build of xbmc instead of the normal one. The topic I linked to is quite detailed on how to do this.

For the grub menu you might take a look at BURG.
find quote
F-Wolf Offline
Member
Posts: 63
Joined: Apr 2009
Reputation: 0
Post: #7
(2012-05-15 17:29)Snippo Wrote:  I'd advise to update the fglrx(-updates) driver and use the Xvba build of xbmc instead of the normal one. The topic I linked to is quite detailed on how to do this.

For the grub menu you might take a look at BURG.

Cool, I check it out then for sure. I just test played some 720p stuff with no issues, but of the driver will give better performance, I'll give it a install.

What version of Ubuntu is XBMCbuntu build off of? So I know what version of BURG to try.

EDIT: http://www.unixmen.com/how-to-install-burg-in-ubuntu/

Using that guide, should be ok I guess.

Got Burg on with no issue, its pretty much exactly what I wanted, thank you. Just have to figure out how to get entries off of that list that I don't want showing up.

Which I did by pressing "f" to fold all the entries, perfect!
(This post was last modified: 2012-05-15 18:02 by F-Wolf.)
find quote
cr33ch Offline
Junior Member
Posts: 2
Joined: Jun 2012
Reputation: 0
Post: #8
Hello,

I'm having the same issue on my setup... I use the boot pen as my only bootable option with the hard drive only storing videos (I previously used Geexbox)

My computer setup includes an AMD X2 3800+, ATI X1900XTX, 2GB RAM. I'm experiencing the same issue when XBMC loads the whole system drops to 1FPS and if you open the system info you can see the CPU usuage darting between the 2 cores at 99%

I understand there is an issue with the GPU drivers but I'm a total Linux beginner so I don't know how to get it into recovery mode or anything. As I run the system from a boot pen how do I get it into recovery mode?

Is there a beginners guide to XBMCubuntu graphics card driver update? is it possible to add the drivers to the USB pen while using another windows computer?

Thanks in advanced!!!
find quote