[BUG] Colordiffuse for slider control

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
phil65 Offline
Skilled Skinner
Posts: 4,455
Joined: Mar 2009
Reputation: 60
Location: Cologne, Germany
Bug  [BUG] Colordiffuse for slider control
Post: #1
Colordiffuse only applies to slider itself, not to the focustexture for example.
for radiobuttons everything (except labels of course) gets colored.
(This post was last modified: 2012-05-22 03:16 by phil65.)
find quote
phil65 Offline
Skilled Skinner
Posts: 4,455
Joined: Mar 2009
Reputation: 60
Location: Cologne, Germany
Post: #2
bump. should i add this as a trac ticket? any comment from one of the devs here? Smile
find quote
pieh Offline
Team-XBMC Member
Posts: 672
Joined: Aug 2010
Reputation: 13
Location: Poland
Post: #3
Any code snippet? it seems to diffuse here just fine.

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

My previous forum/trac nickname: grajen3
find quote
phil65 Offline
Skilled Skinner
Posts: 4,455
Joined: Mar 2009
Reputation: 60
Location: Cologne, Germany
Post: #4
visible when using nox 3.0, choosing a color different from white for video area, and opening audo settings from within video osd. the focus texture for volume and volume amplification do not get colored. (those are built-in controls, perhaps that matters?)
find quote
phil65 Offline
Skilled Skinner
Posts: 4,455
Joined: Mar 2009
Reputation: 60
Location: Cologne, Germany
Post: #5
sorry, it´s a "sliderex" control, not "slider"

this is the code:

Code:
<control type="sliderex" id="10">
            <description>Default Slider</description>
            <width>1172</width>
            <height>60</height>
            <colordiffuse>$VAR[ColorDiffuseVar]</colordiffuse>
            <texturefocus>views/tripanel/listselect_fo.png</texturefocus>
            <texturenofocus>osd/osd_settings_buttonnf.png</texturenofocus>
            <texturesliderbar>osd/osd_slider_bg_settings.png</texturesliderbar>
            <textureslidernib>osd/osd_slider_nib_nf.png</textureslidernib>
            <textureslidernibfocus>osd/osd_slider_nib.png</textureslidernibfocus>
            <font>Font_Reg20</font>
            <textcolor>grey2</textcolor>
            <textoffsetx>45</textoffsetx>
            <focusedcolor>white</focusedcolor>
        </control>
(This post was last modified: 2012-05-28 18:59 by phil65.)
find quote
pieh Offline
Team-XBMC Member
Posts: 672
Joined: Aug 2010
Reputation: 13
Location: Poland
Post: #6
fixed in https://github.com/xbmc/xbmc/commit/38ba...14af5be560
thanks for report (and bump) Wink

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

My previous forum/trac nickname: grajen3
(This post was last modified: 2012-05-29 08:50 by pieh.)
find quote
BlackRose Offline
Senior Member
Posts: 117
Joined: Sep 2008
Reputation: 0
Post: #7
(2012-05-29 00:03)pieh Wrote:  fixed in https://github.com/xbmc/xbmc/commit/38ba...4af5be560,
thanks for report (and bump) Wink

Oh wow, great find. How do I update my XBMC to the latest build including this change. Never used github for much thus far. I've looked at it, felt foolish, looked some more, felt retarded, looked some more, and then their was an electricity shortage across half of civilization. Help. I'm blonde!

I'm using windows by the way!
(This post was last modified: 2012-05-29 01:46 by BlackRose.)
find quote
phil65 Offline
Skilled Skinner
Posts: 4,455
Joined: Mar 2009
Reputation: 60
Location: Cologne, Germany
Post: #8
(2012-05-29 01:45)BlackRose Wrote:  
(2012-05-29 00:03)pieh Wrote:  fixed in https://github.com/xbmc/xbmc/commit/38ba...4af5be560,
thanks for report (and bump) Wink

Oh wow, great find. How do I update my XBMC to the latest build including this change. Never used github for much thus far. I've looked at it, felt foolish, looked some more, felt retarded, looked some more, and then their was an electricity shortage across half of civilization. Help. I'm blonde!

I'm using windows by the way!

should be fixed in next daily build if you do not want to compile it yourself
find quote
phil65 Offline
Skilled Skinner
Posts: 4,455
Joined: Mar 2009
Reputation: 60
Location: Cologne, Germany
Post: #9
(2012-05-29 00:03)pieh Wrote:  fixed in https://github.com/xbmc/xbmc/commit/38ba...4af5be560,
thanks for report (and bump) Wink

...and forgot to say thx for this Smile
find quote
BlackRose Offline
Senior Member
Posts: 117
Joined: Sep 2008
Reputation: 0
Post: #10
Thanks on behalf of everyone who's run into this issue... do I simply need to install the next daily build over my other xbmc installation. I have 11.0 Eden. Thanks for the knowledge
find quote
Martijn Offline
Team-XBMC
Posts: 10,257
Joined: Jul 2011
Reputation: 153
Location: Dawn of time
Post: #11
(2012-05-29 04:10)BlackRose Wrote:  Thanks on behalf of everyone who's run into this issue... do I simply need to install the next daily build over my other xbmc installation. I have 11.0 Eden. Thanks for the knowledge

Yes. Do make a backup of your settings!

Always read the XBMC online-manual, FAQ and search the forums before posting.
Do NOT e-mail Team-XBMC members asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting, make sure you read this first

For your mediacenter artwork go to
[Image: fanarttv.png]
find quote