Linux - Stuttering tv<->commercial break

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
LastCoder Offline
Fan
Posts: 433
Joined: Dec 2011
Reputation: 0
Question  Stuttering tv<->commercial break
Post: #1
Hi folks,

I discovered that very often the switch from a regular program to a commercial break and vice versa is accompanied by a visible stuttering of the live tv picture. It doesn't depend on the channel, but on some channels it's more (for example HD channels) or less marked.

Perhaps it's a country-specific (germany) problem, or a tv server [TVHeadend] specific problem...

But maybe it's a XBMC fault too ?! Would it be possible that the channel providers switch the video/audio codec or other parameters when they switch to a commercial break ? And in this case the XBMC video player can't handle it fast enough ?

Did you discover comparable problems ?

Greetz

LastCoder

Ubuntu 12.04 LTS Server, Xfce, XBMC Gotham, Skin reFred, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM
16 GB CnMemory 300x CF, 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 3,064
Joined: Jul 2010
Reputation: 60
Location: Munich
Post: #2
Quote:Would it be possible that the channel providers switch the video/audio codec or other parameters when they switch to a commercial break

Yes, that's possible. What exactly happens, does the video stream close/re-open? Can you provide a log?

BTW: I don't notice this behavior in Germany, DVB-S.
find quote
LastCoder Offline
Fan
Posts: 433
Joined: Dec 2011
Reputation: 0
Post: #3
(2012-05-24 17:37)FernetMenta Wrote:  Yes, that's possible. What exactly happens, does the video stream close/re-open?

It's like the behaviour if xbmc syncs video and audio stream .. video stutters, no audio for a moment .. lasts for some seconds .. stream is not closed ..

Quote:Can you provide a log?

Will try .. I have to check if recordings and playback of recordings are affected too ...

Quote:BTW: I don't notice this behavior in Germany, DVB-S.

I use DVB-S too. RTL is my favorite channel for that, seems to depend on the program too; clocklike with "blockbusters"/movies and other series starting at 20:15 ..

While this problem only lasts for some seconds on regular free SD channels, the stuttering when I enabled HD+ channels with a smartcard only disapeared when I switched the channel for a moment ... maybe the codec difference between real HD material for the program and the commercial break is much greater ?!? I checked the oscam logs and tvheadend logs and it was no decoding problem.

Greetz

LastCoder

Ubuntu 12.04 LTS Server, Xfce, XBMC Gotham, Skin reFred, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM
16 GB CnMemory 300x CF, 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
(This post was last modified: 2012-05-24 18:01 by LastCoder.)
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 3,064
Joined: Jul 2010
Reputation: 60
Location: Munich
Post: #4
I only watch HD channels and don't notice this behavior (backend is vdr). If stream parameters changed on RTL, I guess I would have noticed. I wait for your log.
find quote
tlanfer Offline
Junior Member
Posts: 22
Joined: Nov 2008
Reputation: 0
Post: #5
I have the same issue, also using tvheadend as a backend and watching hd-channels in germany Smile

Ill see if i can provide a log shortly.
find quote
bilbonvidia Offline
Fan
Posts: 458
Joined: Jun 2011
Reputation: 2
Location: Britain
Post: #6
I noticed the same when I was using tvheadend, sometimes the channel would lock completely and I'd have to change channel. I noticed it on 4hd. (uk)
find quote
LastCoder Offline
Fan
Posts: 433
Joined: Dec 2011
Reputation: 0
Post: #7
(2012-05-24 18:16)FernetMenta Wrote:  I only watch HD channels and don't notice this behavior (backend is vdr).

OT: would you recommend vdr over tvheadend ? At least the tvmovie/web epg sounds very interesting to me Wink And obviously there are less errors than with tvheadend ?!?

@tlandfer & bilbonvidia: excellent .. but points to a tvheadend error Sad

Greetz

LastCoder

Ubuntu 12.04 LTS Server, Xfce, XBMC Gotham, Skin reFred, tvheadend tv backend
ASUS P8H61-M LE/USB3, Celeron G530, Geforce 210, 4 GB DDR3 RAM
16 GB CnMemory 300x CF, 1 TB Samsung 2,5" HDD
iHOS104 BluRay Drive, TT DVBS2-1600
Silverstone GD05B Case, Sony PS3 BD Remote control, Logitech Cordless Mediaboard Pro for PS3
find quote
Swifty Offline
Fan
Posts: 602
Joined: Nov 2008
Reputation: 5
Post: #8
(2012-05-25 12:12)LastCoder Wrote:  @tlandfer & bilbonvidia: excellent .. but points to a tvheadend error Sad

Maybe not, I see the same issue on 4HD with VDR... I think it's where there is an audio stream change, I get stuck video for ~1 second and repeating audio (like a stuck record) which clears in around 1 second, it's always when the commercials start/finish...
find quote
FernetMenta Offline
Team-XBMC Developer
Posts: 3,064
Joined: Jul 2010
Reputation: 60
Location: Munich
Post: #9
An audio stream change would show up in the log. Is this the case? I notice that audio volume pumps up during commercials but no stuttering. can someone post a log?
find quote
Swifty Offline
Fan
Posts: 602
Joined: Nov 2008
Reputation: 5
Post: #10
I've not looked to be honest, as it didn't bother me that much.. just thought i'd chime in to say it was visible with VDR too Smile

I will see if I can grab a log over the weekend for you.
find quote
Dogchow Offline
Junior Member
Posts: 6
Joined: May 2012
Reputation: 0
Post: #11
I think your problems are due to the AAC stream changing from 5.1 -> 2.0

https://github.com/opdenkamp/xbmc/issues/522
find quote
tsp42 Offline
Senior Member
Posts: 222
Joined: Aug 2011
Reputation: 11
Location: Denmark
Post: #12
http://forum.xbmc.org/showthread.php?tid=115383
The master branch includes the ffmpeg fix.

Libcmyth MythTV addon for xbmc-pvr [source] [forum thread]
(This post was last modified: 2012-05-27 00:56 by tsp42.)
find quote