Mac OS X - "Music -> Files" causes crash, other submenus work

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Vogateer Offline
Junior Member
Posts: 2
Joined: Jun 2012
Reputation: 0
Post: #1
Machine Info
OSX Version: 10.5.8
Platform: MacBook 2GHz Intel Core 2 Duo
Install Method: dmg
GIT Revision: Eden (11.0 GIT:20120321-14FEB09)
Skin: Rapier

Description of Problem
The music files have already been scanned from the (User)/Music folder, and music can be selected and played from the XBMC library menus without issue. But when I try to go to "Music" then "Files" from the main menu (so I can try to add a new source), XBMC consistently crashes within 10 seconds of trying to navigate to this screen. This happens after a reboot, after using XBMC for a while, or after trying to get to the "Music -> Files" screen right after startup of computer and XBMC.

I'm using the Rapier skin, but I've also experienced the crash under another skin (Aeon, I think), so I haven't seen a reason to believe the skin is the issue.

If I need to include other helpful info, please let me know. I'm pretty comfortable with the command line, so I can open up a terminal and get around pretty easily if information from such command-line programs might prove useful.

Logs
xbmc.log: http://pastebin.com/KV2SrTvR
Crashreporter: http://pastebin.com/PxQRW3Bv
(This post was last modified: 2012-06-03 01:41 by davilla.)
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 176
Post: #2
Looks like a race in UPnP::StartClient() by the looks. Caused by 2 threads hitting it in close succession.

Mind creating a bug report over at trac.xbmc.org and include your logs there? cc elupus.

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
Vogateer Offline
Junior Member
Posts: 2
Joined: Jun 2012
Reputation: 0
Post: #3
Sure I'll head over there and do that. Thank you, Jonathan.
find quote
jmarshall Offline
Team-XBMC Developer
Posts: 26,181
Joined: Oct 2003
Reputation: 176
Post: #4
Thanks - much appreciated. You can remove your upnp sources by editing userdata/sources.xml if that's any use before a fix is slotted in.

I'll try and sort out a fix so that it doesn't hit upnp looking for thumbs (which is an invalid operation to begin with) - it won't fix the root cause, but might stop the crashes.

Cheers,
Jonathan

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
find quote
gerryyoung1977 Offline
Senior Member
Posts: 106
Joined: Nov 2008
Reputation: 0
Location: Scotland
Post: #5
im getting this prolem, is there a fix yet?
find quote