Xbmc Eden: ogm file no audio

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Tinellus Offline
Junior Member
Posts: 6
Joined: Jun 2012
Reputation: 0
Post: #1
Today upgraded my Xbmc to V11.0 Eden.
Now I have audio missing in ogm files, any other video file plays flawelessly.
Before the upgrade, ogm files had normal audio.

While xmbc has trouble decoding the audio stream, VLC plays the ogm files just fine, without audio problems.

I've found threads in the Windows and Mac OS support forums about this same issue, my own system is an Ubuntu 10.04 (Lucid)
The problems in Windows and Mac aren't (yet) solved, at least not in the forum...

Below a copy/paste of a relevant section in xbmc.log

Any help would be appreciated.

Thx

21:07:28 T:80829296 INFO: ffmpeg[4D15B70]: Stream #0.1(Nederlands): Audio: vorbis, 48000 Hz, 2 channels, 112 kb/s
21:07:28 T:80829296 NOTICE: Opening video stream: 0 source: 256
21:07:28 T:80829296 NOTICE: Creating video codec with codec id: 13
21:07:28 T:80829296 DEBUG: CDVDFactoryCodec: compiled in hardware support: CrystalHD:yes OpenMax:no VDPAU:yes VAAPI:no
21:07:28 T:80829296 DEBUG: FactoryCodec - Video: - Opening
21:07:28 T:80829296 DEBUG: SECTION:LoadDLL(special://xbmcbin/system/players/dvdplayer/avfilter-1-i486-linux.so)
21:07:28 T:80829296 DEBUG: Loading: /usr/lib/xbmc/system/players/dvdplayer/avfilter-1-i486-linux.so
21:07:28 T:80829296 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: MPEG-4 part 2
21:07:28 T:80829296 DEBUG: FactoryCodec - Video: ff-mpeg4 - Opened
21:07:28 T:80829296 NOTICE: Creating video thread
21:07:28 T:3057642352 DEBUG: Thread CDVDPlayerVideo start, auto delete: 0
21:07:28 T:3057642352 NOTICE: running thread: video_thread
21:07:28 T:80829296 NOTICE: Opening audio stream: 1 source: 256
21:07:28 T:80829296 NOTICE: Finding audio codec for: 86021
21:07:28 T:80829296 DEBUG: FactoryCodec - Audio: FFmpeg - Opening
21:07:28 T:80829296 ERROR: ffmpeg[4D15B70]: [vorbis] Extradata missing.
21:07:28 T:80829296 DEBUG: CDVDAudioCodecFFmpeg::Open() Unable to open codec
21:07:28 T:80829296 DEBUG: FactoryCodec - Audio: FFmpeg - Failed
21:07:28 T:80829296 ERROR: Unsupported audio codec
21:07:28 T:80829296 WARNING: OpenAudioStream - Unsupported stream 1. Stream disabled.
find quote
Tinellus Offline
Junior Member
Posts: 6
Joined: Jun 2012
Reputation: 0
Post: #2
Got a bit deeper into this today.

Since mplayer plays the ogm file well, I ran it from terminal in verbose.
Here's a snippet from the output:

==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 192000 + 65536 = 257536 bytes for output buffer.
FFmpeg's libavcodec audio codec
[vorbis @ 0x5d989c0]partition out of bounds: type, begin, end, size, blocksize: 2, 0, 192, 16, 1024
[vorbis @ 0x5d989c0] Vorbis setup header packet corrupt (residues).
[vorbis @ 0x5d989c0]Setup header corrupt.
Could not open codec.
ADecoder init failed Sad
ADecoder init failed Sad
Requested audio codec family [vorbis] (afm=libvorbis) not available.
Enable it at compilation.
Opening audio decoder: [tremor] Ogg/Vorbis audio decoder
dec_audio: Allocating 4096 + 65536 = 69632 bytes for output buffer.
ad_vorbis, extradata seems is 3917 bytes long
ad_vorbis, offset: 2, length: 30
ad_vorbis, offset: 3, length: 52
ad_vorbis, header sizes: 30 52 3832
OggVorbisComment: LANGUAGE=Nederlands
OggVorbis: Bitstream is 2 channels, 48000Hz, 112000bit/s VBR
OggVorbis: Encoded by: ogmtools v1.5
OggVorbis: Init OK!
AUDIO: 48000 Hz, 2 ch, s16le, 112.0 kbit/7.29% (ratio: 14000->192000)
Selected audio codec: [tremor] afm: tremor (OggVorbis audio)
==========================================================================

Mplayer also has trouble opening the audio stream.
Just like xbmc, it can't use ffmpeg, but contrary to xbmc it can switch to 'tremor'.

Any idea how I can make xbmc use 'tremor'?

Thanks for any suggestions...
find quote
spiff Offline
Retired Developer
Posts: 12,386
Joined: Nov 2003
Post: #3
i personally reported and got a couple of ogm audio issues fixed in ffmpeg. not in eden, but can you try a nightly?

if it still does not work, get me a sample.
(This post was last modified: 2012-06-22 15:59 by spiff.)
find quote
Tinellus Offline
Junior Member
Posts: 6
Joined: Jun 2012
Reputation: 0
Post: #4
@spiff

Thank you for your reply.

I agree the fault must be in ffmpeg, also mplayer reports this...

I'd like to test, but I don't know how:

1. how to find and install a nightly build?
2. is it safe to install on the same machine, without losing the settings of the xbmc I'm using at the moment
(I have it on a HTPC for a long time, but I'm not what you can call a 'power user', linux still has a lot of secrets for me...)
I'll do some searching...
3. give you a sample of what?

Thx for your reply
find quote
Tinellus Offline
Junior Member
Posts: 6
Joined: Jun 2012
Reputation: 0
Post: #5
Nevermind, I've converted all my .ogm and .ogg files to avi (about 15 of 'em)

I'd liked to have helped solving the issue, though, I can't imagine I'm the only one with the problem...

Thanks anyway...
find quote
Horscht Offline
Member
Posts: 97
Joined: Jan 2006
Reputation: 2
Post: #6
I today noticed the same issue. When you say you converted your ogm files to ogg, did you simply rename them or what tool did you use?
find quote
Tidirium Offline
Junior Member
Posts: 1
Joined: Aug 2012
Reputation: 0
Post: #7
Same here: OGM File with two Vorbis audio tracks (DE, EN):

xbmc DEBUG: https://trash.ctdo.de/a/034kaqxl407

ogminfo
https://trash.ctdo.de/a/035xuyia387

FYI:
OpenSUSE 12.1 (xfce)
RPM files:
xbmc-11.0-3.10.x86_64 (with xbmc-11.0-3.30.x86_64 same problem)
ffmpeg-0.11.1-1.2.x86_64
liboggz2-1.1.1-10.1.2.x86_64
libogg0-1.3.0-5.4.x86_64

If I try to play it with mplayer2, it says:
Detected file format: Ogg (libavformat)
[vorbis @ 0xa72c80]Extradata missing.
[vorbis @ 0xa72c80]Extradata missing.
---snip
[ogg @ 0x9ff3a0]max_analyze_duration reached
[lavf] stream 0: video (h264), -vid 0, StarTrek-TNG-S4-04_Endars-Sohn
[lavf] stream 1: audio (vorbis), -aid 0, -alang Deutsch
[lavf] stream 2: audio (vorbis), -aid 1, -alang English
[lavf] stream 3: subtitle (unknown), -sid 0, -slang Deutsch
[lavf] stream 4: subtitle (unknown), -sid 1, -slang English
VIDEO: [H264] 720x544 0bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
Opening video filter: [scale]
[ass] auto-open
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Asking decoder to use 2 threads if supported.
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[vorbis @ 0xa72c80]Extradata missing.
Could not open codec.
ADecoder init failed Sad
ADecoder init failed Sad
Requested audio codec family [vorbis] (afm=libvorbis) not available.
Enable it at compilation.
Requested audio codec family [tremor] (afm=tremor) not available.
Enable it at compilation.
Cannot find codec for audio format 0x566F.
Audio: no sound
Starting playback..

It seems to be a problem with ffmpeg/libavcodec

Same behavior with compiled V0.11.1 from git://source.ffmpeg.org/ffmpeg.git
and with the static version N-43574-g6093960.
(This post was last modified: 2012-08-15 16:59 by Tidirium.)
find quote