Quartz - Home Menus disappear randomly (ATV2)

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ChurdCFG Offline
Junior Member
Posts: 5
Joined: Jul 2012
Reputation: 0
Post: #1
I'm having a problem where the main menus (Movies, Music, etc) disappear randomly within Quartz. I don't see the issue with Confluence, and thanks to some help in the IOS support thread, I've eliminated error messages I was seeing in debug logs (permissions errors, etc.).

Basically, if left alone, the menu goes from this:

http://i.imgur.com/W7aBI.png

to this:

http://i.imgur.com/MwBrb.png

The XBMC Library Auto Update plugin scans the NFS shares while idling, but other than that there's no interaction between the before and after pics.

XBMC log is at the following location: http://xbmclogs.com/show.php?id=5706

Any ideas?
find quote
pecinko Offline
Donor
Posts: 3,671
Joined: Dec 2008
Reputation: 48
Location: Prague / Belgrade
Post: #2
Basically, skin is performing 2 checks to determine if section should be visible on home

- is there a skin setting to turn it off (hide section from skin settings)
- is movie library empty

My guess is something is wrong with your movie library check, but I see no problem in the log.

Can you disable library update addon and see if this happen with manual updates or built-in function "update library on startup"?

My skins:

Amber
Quartz

find quote
ChurdCFG Offline
Junior Member
Posts: 5
Joined: Jul 2012
Reputation: 0
Post: #3
I disabled the Library Update, and was still able to trigger the event by adding a new file to the NFS share and restarting XBMC (Update on Startup).

It looks like anytime a new item shows up in my share, a library update while sitting on the home screen will trigger the behavior. If there's nothing new in the folders, no problems during an update.
Actually, it's a little more specific than that - every time I create a new Folder on the NFS share (like for a new TV Show), and then have it update, that's when it happens. Just adding files won't do it alone, but when I create an empty folder (no new files), I can trigger it.
(This post was last modified: 2012-07-29 02:00 by ChurdCFG.)
find quote
pecinko Offline
Donor
Posts: 3,671
Joined: Dec 2008
Reputation: 48
Location: Prague / Belgrade
Post: #4
(2012-07-29 01:53)ChurdCFG Wrote:  I disabled the Library Update, and was still able to trigger the event by adding a new file to the NFS share and restarting XBMC (Update on Startup).

It looks like anytime a new item shows up in my share, a library update while sitting on the home screen will trigger the behavior. If there's nothing new in the folders, no problems during an update.
Actually, it's a little more specific than that - every time I create a new Folder on the NFS share (like for a new TV Show), and then have it update, that's when it happens. Just adding files won't do it alone, but when I create an empty folder (no new files), I can trigger it.

Nice troubleshooting. Maybe you can discuss this with the devs so it gets fixed.

My skins:

Amber
Quartz

find quote
d_g_ Offline
Junior Member
Posts: 2
Joined: Aug 2012
Reputation: 0
Post: #5
I was having a similar issue the other day and what occurred with me specifically was:

When updating the library in the default confluence skin the UI has often "jumped around" a bit within the onscreen menus (I mention this because I believe the problem is related)
If this occurs on the Quartz skin, I was left with the menu on "Browse" under Movies or TV Shows.
If "Browse" had been removed from the category, then instead of ending up on "Browse" the entire category vanished.

So, if this is the same thing I was seeing, enabling "Browse" under those menus is a workaround--I've not had it occur since. If you can recreate the issue reliably you should be able to confirm.
find quote
pecinko Offline
Donor
Posts: 3,671
Joined: Dec 2008
Reputation: 48
Location: Prague / Belgrade
Post: #6
(2012-08-03 21:26)d_g_ Wrote:  I was having a similar issue the other day and what occurred with me specifically was:

When updating the library in the default confluence skin the UI has often "jumped around" a bit within the onscreen menus (I mention this because I believe the problem is related)
If this occurs on the Quartz skin, I was left with the menu on "Browse" under Movies or TV Shows.
If "Browse" had been removed from the category, then instead of ending up on "Browse" the entire category vanished.

So, if this is the same thing I was seeing, enabling "Browse" under those menus is a workaround--I've not had it occur since. If you can recreate the issue reliably you should be able to confirm.

Which confirms that there is a bug in XBMC nighties manifesting as "disappearing library" while scanning for new video items.

All other items except for browse should be hidden if no movie library is present and if no submenu items are active, whole section hides itself. All is as it is supposed to be and working nicely with Eden final. Sorry for your trouble boys.

My skins:

Amber
Quartz

find quote
d_g_ Offline
Junior Member
Posts: 2
Joined: Aug 2012
Reputation: 0
Post: #7
I was ambiguous with my language. If it wasn't clear: When I said I was "left with browse" I mean "the 'browse' menu item was highlighted--the menu was fully intact".

i.e. The problem appear(s/ed) to be that an attempt was made to highlight 'browse' but if 'browse' wasn't enabled in my skin settings then that category got hidden.

In ChurdCFG's case the before image shows 'browse' has been disabled within the skin so I'm guessing it's the same issue.
find quote