Linux - Xbmcbuntu NEVER auto login xbmc or desktop!

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bboy_h Offline
Junior Member
Posts: 6
Joined: Aug 2011
Reputation: 0
Post: #1
Hi all,

Don't know what happened but xbmcbuntu was auto logging in fine until recently. It now ALWAYS boots to a log on screen. I have tried the logging into the desktop and logging out to login to xbmc which works fine, but it never remembers my last login state. When I shut down from xbmc it exits to a blue screen then shuts down via a command line/terminal with some text on screen. It used to just show the xbmc logo with the alternating smaller dots below to indicate shutting down, but now its always as mentioned above.

Anyone have any suggestions/help/ideas? Auto login was great and good for the Wife user ability. Was hoping I could get this back again with a fresh install'

Thanks
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,358
Joined: Jul 2010
Reputation: 109
Location: USA
Post: #2
Switch over to the XBMCbuntu desktop session and launch a terminal session (Start menu > System Tools > XTerm).

Enter the following command:
Code:
cat /etc/lightdm/lightdm.conf

Post the results here.
find quote
bboy_h Offline
Junior Member
Posts: 6
Joined: Aug 2011
Reputation: 0
Post: #3
As requested.

chris@htpc:~$ cat /etc/lightdm/lightdm.conf[SeatDefaults]
autologin-user=chris
chris@htpc:~$
user-session=XBMC
greeter-session=lightdm-gtk-greeter
allow-guest=false
default-user=chris

Hope this helps. Thanks for replying.
(This post was last modified: 2012-08-04 11:51 by bboy_h.)
find quote
Aenima99x Offline
Donor
Posts: 1,098
Joined: Aug 2007
Reputation: 7
Location: California
Post: #4
under autologin-user=chris add this
autologin-user-timeout=1
find quote
artrafael Offline
Team-XBMC Forum Moderator
Posts: 6,358
Joined: Jul 2010
Reputation: 109
Location: USA
Post: #5
As Aenima99x stated above, try adding an "autologin-user-timeout" statement to the file.

From a terminal session, do the following:
  1. Enter the command: sudo nano /etc/lightdm/lightdm.conf
  2. When prompted, enter your password
  3. Insert a line after the autologin-user=chris statement and enter this text: autologin-user-timeout=0
  4. The final result should look like the code below
  5. Press Ctrl-O
  6. Press ENTER
  7. Press Ctrl-X
  8. Cloose your terminal session

Code:
[SeatDefaults]
autologin-user=chris
autologin-user-timeout=0
user-session=XBMC
greeter-session=lightdm-gtk-greeter
allow-guest=false
default-user=chris

Reboot your system and see if autologin works now.
find quote
bboy_h Offline
Junior Member
Posts: 6
Joined: Aug 2011
Reputation: 0
Post: #6
(2012-08-04 20:04)artrafael Wrote:  As Aenima99x stated above, try adding an "autologin-user-timeout" statement to the file.

From a terminal session, do the following:
  1. Enter the command: sudo nano /etc/lightdm/lightdm.conf
  2. When prompted, enter your password
  3. Insert a line after the autologin-user=chris statement and enter this text: autologin-user-timeout=0
  4. The final result should look like the code below
  5. Press Ctrl-O
  6. Press ENTER
  7. Press Ctrl-X
  8. Cloose your terminal session

Code:
[SeatDefaults]
autologin-user=chris
autologin-user-timeout=0
user-session=XBMC
greeter-session=lightdm-gtk-greeter
allow-guest=false
default-user=chris

Reboot your system and see if autologin works now.

Hi guys,

It seems I must have copied the text entry in my last post wrong, as following the directions above, when I opened the file again, it actually already showed the "autologin-user-timeout=0" line, set to as suggested. Apologies for the incorrect text listed above. I was actually copying the text from an SSH client on a tablet computer and obviously something happened with between the copy and paste into this thread.

If it's any additional help, not too long ago I had to update/reinstall my NVIDIA drivers as I was having issues playing Mp4 video files. The new upgrade work and the reinstall fixed the issues I was having but not long after, this problem occurred. "lightdm" is the graphical user interface if I'm correct? I am sure during installation I was asked to choose between lightdm and gdm. If I selected gdm would this cause any issues?

Thanks in advance
(This post was last modified: 2012-08-05 03:01 by bboy_h.)
find quote
bboy_h Offline
Junior Member
Posts: 6
Joined: Aug 2011
Reputation: 0
Post: #7
Some more info, when I reboot from within XBMC, it closes to a terminal screen where it mentions "Checking for running unattended upgrades". Sometimes it successfully restarts or shuts down, but other times it freezes on this screen and I have to power off by the power button on the physical box.

Thanks
find quote
Aenima99x Offline
Donor
Posts: 1,098
Joined: Aug 2007
Reputation: 7
Location: California
Post: #8
If you choose GDM instead of LightDM, then from a terminal do "sudo dpkg-reconfigure lightdm" and when it gives you the choice of gdm or lightdm, choose lightdm.
find quote
bboy_h Offline
Junior Member
Posts: 6
Joined: Aug 2011
Reputation: 0
Post: #9
(2012-08-05 03:20)Aenima99x Wrote:  If you choose GDM instead of LightDM, then from a terminal do "sudo dpkg-reconfigure lightdm" and when it gives you the choice of gdm or lightdm, choose lightdm.

Awesome. Worked a treat. Thank you soooo much for all your help.

Can you explain exactly what the problem was for future reference?

Thanks again.
find quote
Aenima99x Offline
Donor
Posts: 1,098
Joined: Aug 2007
Reputation: 7
Location: California
Post: #10
By choosing GDM as the display manager, you basically rendered the LightDM config files useless. You could have gone in and changed the GDM config files to autologin, but you should really stickwith LightDM as it's replaced GDM.
find quote
FuryStryker Offline
Junior Member
Posts: 22
Joined: Apr 2012
Reputation: 0
Post: #11
I had a similar problem and tried the methods above, but I get the message below when I run the reconfigure:


dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_NAME missing
dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_PACKAGE missing


Which I assume means I'm don't have lightdm installed properly?
find quote
Aenima99x Offline
Donor
Posts: 1,098
Joined: Aug 2007
Reputation: 7
Location: California
Post: #12
try sudo apt-get install --reinstall lightdm
find quote
FuryStryker Offline
Junior Member
Posts: 22
Joined: Apr 2012
Reputation: 0
Post: #13
Ok, I ran that command, and got this:


root@xbmc:/etc/lightdm# apt-get install --reinstall lightdm
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
libshairport1 libglew1.6 libass4 libpcrecpp0 python-bluez ttf-liberation python-qt3 libenca0 python-sip python-imaging libhal1 libmikmod2 xbmc-bin libhal-storage1 liblzo2-2
libmicrohttpd5 libsdl-mixer1.2 libtinyxml2.6.2 libyajl1 libqt3-mt libva-glx1 libsmpeg0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/97.2 kB of archives.
After this operation, 0 B of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 172060 files and directories currently installed.)
Preparing to replace lightdm 1.0.6-0ubuntu1.7 (using .../lightdm_1.0.6-0ubuntu1.7_i386.deb) ...
Unpacking replacement lightdm ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up lightdm (1.0.6-0ubuntu1.7) ...

Ran the reconfigure again, and then still got the warnings:

root@xbmc:/etc/lightdm# dpkg-reconfigure lightdm
dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_NAME missing
dpkg-maintscript-helper: warning: environment variable DPKG_MAINTSCRIPT_PACKAGE missing

Sadly I'm not at home right now so I can't view if rebooting will show me the xbmcbuntu login screen again...
find quote
Aenima99x Offline
Donor
Posts: 1,098
Joined: Aug 2007
Reputation: 7
Location: California
Post: #14
try
Quote:apt-get update && apt-get install unity-greeter;dpkg-reconfigure lightdm
what worries me though is that you have xbmc-bin listed as a no longer required package
find quote
FuryStryker Offline
Junior Member
Posts: 22
Joined: Apr 2012
Reputation: 0
Post: #15
Yeah, still no dice.

I did try to update/upgrade using wsnipex's repo a while back...seems to coincide with this? I'm not sure what else to make of xbmc-bin not being present.

When i try to log in, i don't even have an "xbmc" option, just xbmcubuntu and openbox.
find quote
Post Reply