Linux - XBMCbuntu desktop is empty

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
evanb Offline
Junior Member
Posts: 6
Joined: Aug 2012
Reputation: 0
Post: #1
I just installed XBMCbuntu 11.0 on my Acer Revo RL100 U20P (dual-boot with Win7), configuring it for automatic login. First time I booted XBMC came up as expected. Once I discovered that "Exit" in the menu under XBMC's power-icon button got me to a login screen, I switched over to XBMCbuntu and found...nothing. The desktop is completely blank; no icons, no panels. I can right-click on the desktop to get a very short menu that offers a terminal window, a small configuration dialog for selecting the desktop font (which doesn't appear to change anything) and a couple of other choices like 'reconfigure' and 'exit'. All choices but the terminal and configuration dialog serve only to make whatever displays the menu stop working altogether. Worse, now that I've shut down from XBMCbuntu, that's where my automatic login takes me every time.

Is a blank desktop the intended default condition on the Ubuntu side?
Can someone suggest some packages to install to get a panel with at least a logout button?

Thanks.

-evan
find quote
neil.j1983 Offline
Donor
Posts: 589
Joined: Jun 2009
Reputation: 28
Post: #2
are you sure you chose "XBMCBuntu" and not "openbox"?

xbmcbuntu looks like http://www.byopvr.com/wp-content/uploads...cbuntu.png
(This post was last modified: 2012-08-20 10:57 by neil.j1983.)
find quote
flonews Offline
Junior Member
Posts: 15
Joined: Sep 2011
Reputation: 0
Post: #3
Hello,

I get the same thing but finally get the trick after 2 reboots ... It doesn't come from XBMCBuntu but from the display screen (my Samsung TV). The TV was set by default to the 16/9 mode and crop pixels all around the picture (a kind of zoom). So I get only the blue background screen with the logo without seeing any menu. Switching the TV in scan mode restore the missing pixels on the display.

Regards
find quote
evanb Offline
Junior Member
Posts: 6
Joined: Aug 2012
Reputation: 0
Post: #4
neil.j1983, it's funny you say that because one of the messages from one of the menu selections said something about openbox. (The text is too small to read, which is the problem I'm trying to solve.) What I see looks just like the image at your link, though, minus the panel on the bottom.

flonews, I suspect yours is the right answer. I recall now that had a similar problem with Win7, but its task bar is thick enough that part of it was still visible on the edge of the screen. I fished around off the edges of XBMCbuntu's desktop but did not click anything interesting. With neil.j1983's screen shot as a guide I'll have another go tonight.

Thanks for your help.

-evan
find quote
neil.j1983 Offline
Donor
Posts: 589
Joined: Jun 2009
Reputation: 28
Post: #5
if the text is too small you need to change your DPI in your xorg.conf.

http://ubuntuforums.org/showthread.php?t=1903400&page=2
find quote
evanb Offline
Junior Member
Posts: 6
Joined: Aug 2012
Reputation: 0
Post: #6
The missing panels were, of course, there, but off the screen. Thanks again, flonews, for pointing that out. I also managed to locate the Openbox configuration dialog and set larger fonts, but that seems to only affects the fonts used by desktop context menu itself; the start menu and other dialogs continue to use unreadably-small fonts. neil.j1983, thanks for the additional information. My HTPC has an Nvidia card, so the link is especially pertinent.

As I was sitting on the floor in front of my TV with a keyboard in my lap and a mouse an awkward reach away, it occurred to me that I'd be better off setting up remote access on the HTPC so I can sit at my regular computer in a comfortable chair when I need to do configuration or other computer-like things to it. Once I get a minimally-functional desktop configured to work with the TV I'll install xrdp and likely never visit it again. Smile

-evan
find quote
flonews Offline
Junior Member
Posts: 15
Joined: Sep 2011
Reputation: 0
Post: #7
Very happy to help you evanb !

On the XBMCBuntu desktop, I have the opposite trouble: the fonts are too big ! So I will follow the link of neil.j1983.

Cool.
find quote