Slow and Sluggish on Raspberry Pi

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
mikey1582 Offline
Junior Member
Posts: 4
Joined: Nov 2012
Reputation: 0
Sad  Slow and Sluggish on Raspberry Pi
Post: #1
Hi I have the Open Elec version of XBMC installed on a 16gb class 10 SD card on my pi with a 2tb hard drive attached with 250+ films going through 500mbps home plugs.
Ok the problem is that going through the menu's and cycling through my films it's very very slow and sluggish, is there a setting I have wrong or is it something else.

Please please help it's driving me mad..

Thankyou. Frown
find quote
stuCONNERS Offline
Fan
Posts: 329
Joined: Nov 2012
Reputation: 0
Post: #2
Is the hard drive attached by a powered hub? Is the Rpi overclocked? Instead of installing Open Elec to an SD card, try installing to a USB pendrive. Raspbmc has this option with the windows installer. Is your power-supply giving enough power the Rpi?

Total XBMC spend so far: £76
Rpi (£24) + Pogoplug V2 (£15) + HD Star DVB-S2 (£29) + GPIO Ir (£3) + NOOBS 8GB SD (£5) = Cheap Media Center
find quote
mafitz Offline
Junior Member
Posts: 1
Joined: Nov 2012
Reputation: 0
Post: #3
My Pi is very sluggish as well after I first enter the 'Movies' selection or after I exit 'Information' for a movie. I have turned on debug, and what is occuring is the following:

DEBUG: DoWork - trying to extract filestream details from video file smb://pcdoctorg/movies/Zodiac DVD (2007)/Zodiac (2007).iso

The above line appears for many of my movies in my large movie database. I don't know if this is maybe what you are seeing, but it definitely is impacting my performance until it goes through the list of movies. I would suggest turning on debug to maybe get some more informaiton as to what is impacting your system.

So it appers that xbmc is trying to extract filestream details for many movies from my large move database everytime I enter or reenter the 'Movies' selection.

I don't know if there is a reason for this or how to correct this. Hopefully someone can address this issue.
find quote
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 20,241
Joined: Jan 2011
Reputation: 253
Location: Arizona, USA
Post: #4
Raspberry_Pi/FAQ#Performance: Turn off thumbnails, XBMC > Settings > Video > File and deselect 'generate thumbnails'.

You can make easy links to the XBMC wiki using double brackets around common XBMC words: debug log = debug log, Video library = Video library, SMB = SMB , userdata = userdata, etc
find quote
mikey1582 Offline
Junior Member
Posts: 4
Joined: Nov 2012
Reputation: 0
Post: #5
stuConners: Hi it's plugged in directly into the pi usb port an I am using the 12v 2amp psu aswell that came with the pie. My 2tb external drive is powered by mains it's not a portable drive.
It's not overclocked it's completely standard as I am a newbie to the pi. Where can I get Raspbmc from? Thanks.

Ned Scott: If I do this will I loose the fan art stuff? Thankyou
find quote
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 20,241
Joined: Jan 2011
Reputation: 253
Location: Arizona, USA
Post: #6
Nope, you'll only lose the auto generated thumbs whenever you have a file that doesn't have an actual set thumb (the ones where it just takes a raw screen shot and uses it as a thumb). Anything scanned into the library will still work normally.

You can make easy links to the XBMC wiki using double brackets around common XBMC words: debug log = debug log, Video library = Video library, SMB = SMB , userdata = userdata, etc
find quote
Dilligaf Offline
Fan
Posts: 731
Joined: Dec 2008
Reputation: 29
Post: #7
When you go to movies do you see the total duration at the bottom right of the screen? That's what's slowing you down until it is calculated. You could probably remove it by editing some xml file somewhere, I haven't been bothered to look.

@mikey raspbmc.com

If I have been of help, please add to my reputation as a way of saying thanks, it's free.
(This post was last modified: 2012-11-14 22:32 by Dilligaf.)
find quote
xbs08 Offline
Posting Freak
Posts: 1,707
Joined: May 2008
Reputation: 7
Location: Portugal
Post: #8
From the wiki: "Extract thumbnail and video information - When enabled, XBMC will extract thumbnails from videos that have no thumb in the library and information such as codecs and aspect ratio to display in Library Mode."

Loosing the video information is not nice at all Confused

Noticed that lately the calculation seem much faster... it could be the OC kicking in thou Smile

  • Intel NUC Kit DN2820FYKH
  • Crucial DDR3L SO-DIMM 4GB
  • SanDisk ReadyCache 32GB SSD
  • Microsoft MCE model 1039 RC6 remote
(This post was last modified: 2012-11-15 20:14 by xbs08.)
find quote
Dilligaf Offline
Fan
Posts: 731
Joined: Dec 2008
Reputation: 29
Post: #9
I don't think that's the same as the duration calculation, thumbnails/codec info should only be extracted once. The total duration seems to update every time you open/return to the screen, If it was static and only updated on scans or once per session it wouldn't be so annoying

If I have been of help, please add to my reputation as a way of saying thanks, it's free.
find quote
xbs08 Offline
Posting Freak
Posts: 1,707
Joined: May 2008
Reputation: 7
Location: Portugal
Post: #10
There should be a skin option to disable it on the RPi.

btw if you want to remove it manually look in includes.xml

  • Intel NUC Kit DN2820FYKH
  • Crucial DDR3L SO-DIMM 4GB
  • SanDisk ReadyCache 32GB SSD
  • Microsoft MCE model 1039 RC6 remote
find quote
Ned Scott Offline
Team-Kodi Wiki Guy
Posts: 20,241
Joined: Jan 2011
Reputation: 253
Location: Arizona, USA
Post: #11
(2012-11-15 11:17)xbs08 Wrote:  From the wiki: "Extract thumbnail and video information - When enabled, XBMC will extract thumbnails from videos that have no thumb in the library and information such as codecs and aspect ratio to display in Library Mode."

Loosing the video information is not nice at all Confused

Noticed that lately the calculation seem much faster... I could be the OC kicking in thou Smile

The only information you lose is a little media flag that says something like "H.264" or "AAC". It's a trade off; if you want better performance for core features then you have to turn off extra features. It's no different than if someone used a heavy-feature skin vs a light feature skin on the Pi.

You can make easy links to the XBMC wiki using double brackets around common XBMC words: debug log = debug log, Video library = Video library, SMB = SMB , userdata = userdata, etc
find quote
sdsnyr94 Offline
Fan
Posts: 476
Joined: Aug 2009
Reputation: 2
Location: Greensboro, NC
Post: #12
(2012-11-15 19:28)Ned Scott Wrote:  
(2012-11-15 11:17)xbs08 Wrote:  From the wiki: "Extract thumbnail and video information - When enabled, XBMC will extract thumbnails from videos that have no thumb in the library and information such as codecs and aspect ratio to display in Library Mode."

Loosing the video information is not nice at all Confused

Noticed that lately the calculation seem much faster... I could be the OC kicking in thou Smile

The only information you lose is a little media flag that says something like "H.264" or "AAC". It's a trade off; if you want better performance for core features then you have to turn off extra features. It's no different than if someone used a heavy-feature skin vs a light feature skin on the Pi.

Slightly off topic, but can't you have the "H.264" and "AAC" information stored in the NFO file, eliminating the "trade-off"?
(This post was last modified: 2012-11-15 22:52 by sdsnyr94.)
find quote
mikey1582 Offline
Junior Member
Posts: 4
Joined: Nov 2012
Reputation: 0
Post: #13
Hi thanks guys for all your support I installed the Raspbmc version an all seems to be working fine now. Once again thankyou for all your help. peace
find quote
Dilligaf Offline
Fan
Posts: 731
Joined: Dec 2008
Reputation: 29
Post: #14
In the build from the 19th it appears that the total duration in the movie library doesn't update every time you open the page. whoever fixed/changed this Thank You

If I have been of help, please add to my reputation as a way of saying thanks, it's free.
find quote