Solved: Can't view live TV on 2nd Computer

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ghost5 Offline
Junior Member
Posts: 22
Joined: Oct 2012
Reputation: 0
Post: #1
XBMC RC 2
Argus 2.0.1
Windows 7

Hi,

I can not view live TV on the computer in my bedroom through XBMC. I have connected to the server OK as I have the channels, guide data and logos but whenever I try to watch a live stream I get a buffer timeout error.
I can watch recorded TV ok, and if I use the scheduler console TV streams play fine. It is only within XBMC that I get this error.

Code:
12:40:46 T:5020  NOTICE: Running database version Addons15
12:40:46 T:5020  NOTICE: Running database version ViewModes4
12:40:46 T:5020  NOTICE: Running database version Textures13
12:40:46 T:5020  NOTICE: Running database version MyMusic32
12:40:46 T:5020  NOTICE: Running database version MyVideos75
12:40:46 T:5020  NOTICE: Running database version TV22
12:40:46 T:5020  NOTICE: Running database version Epg7
12:40:46 T:5020  NOTICE: initializing playlistplayer
12:40:46 T:5020  NOTICE: DONE initializing playlistplayer
12:40:47 T:4500  NOTICE: Thread Jobworker start, auto delete: true
12:40:47 T:4500  NOTICE: PVRManager - starting up
12:40:47 T:4908  NOTICE: Thread PVR manager start, auto delete: false
12:40:47 T:5020  NOTICE: initialize done
12:40:47 T:4268  NOTICE: Thread PVR add-on updater start, auto delete: false
12:40:47 T:5020  NOTICE: Running the application...
12:40:47 T:5020  NOTICE: ES: Starting event server
12:40:47 T:4036  NOTICE: Thread CEventServer start, auto delete: false
12:40:47 T:4036  NOTICE: ES: Starting UDP Event server on 0.0.0.0:9777
12:40:47 T:4036  NOTICE: UDP: Listening on port 9777
12:40:47 T:1648  NOTICE: Thread CTCPServer start, auto delete: false
12:40:47 T:4204  NOTICE: Thread CRssReader start, auto delete: false
12:40:47 T:4668  NOTICE: Thread Jobworker start, auto delete: true
12:40:48 T:5056  NOTICE: Thread PVR GUI info updater start, auto delete: false
12:40:48 T:4908  NOTICE: EPG::CEpgContainer::Start - EPG thread started
12:40:48 T:4228  NOTICE: Thread EPG updater start, auto delete: false
12:40:55 T:3652  NOTICE: Thread PVR Channel Window start, auto delete: false
12:41:03 T:5020  NOTICE: DVDPlayer: Opening: pvr://channels/tv/All TV channels/2.pvr
12:41:03 T:5020 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
12:41:03 T:1212  NOTICE: Thread CDVDPlayer start, auto delete: false
12:41:03 T:1212  NOTICE: Creating InputStream
12:41:36 T:1212   ERROR: AddOnLog: ARGUS TV client: FileReader::OpenFile(), open file \\HTPC\Time Shift\Card3-1-1.ts.tsbuffer failed.
12:41:37 T:1212   ERROR: AddOnLog: ARGUS TV client: MultiFileReader: timed out while waiting for buffer file to become available
12:41:37 T:1212   ERROR: AddOnLog: ARGUS TV client: CTsReader::OpenFile failed.
12:41:38 T:1212  NOTICE: Creating Demuxer
12:41:38 T:1212  NOTICE: AddOnLog: ARGUS TV client: ReadLiveStream requested 32768 but only read 32768 bytes.

Windows firewall is off on both computers.

Does anyone have any ideas?

Thanks

Edit:

Well this has been doing my head in for over a week and it turns out solving it was really simple.
I had already set up sharing of the individual folders for recorded tv / timeshift but that gave the timeout error above.
So I shared the whole drive with everyone and added sharing of the folders to the homegroup.
Now live TV is working

Edit 2: I thought I had solved this but after a restart it is back to how it was.

I can get live TV to work as long as do the following first
On my bedroom PC (within Windows) go to Network, HTPC (enter username / password), timeshift folder
Then live TV will work fine within XBMC
Is this because I have the same user name / password on both my HTPC and bedroom PC?
I have input the username / password details inside the argusTV plugin

Edit 3;
I've solved the problem by creating a new user on the server machine and putting them details into the Argus plugin configuration page.
I then also had to map the Timeshift folder as a network drive on my bedroom PC. This seems to reconnect at boot up and give XBMC the correct permissions to stream the file.
Is this the correct way of setting up, by always mapping the Timeshift folder?
Or did I miss a step out somewhere?

Cheers
(This post was last modified: 2012-12-21 18:32 by ghost5.)
find quote
Bearhunter73 Offline
Junior Member
Posts: 2
Joined: Apr 2013
Reputation: 0
Post: #2
Howdy,

I was having the same problem until I saw your post and consulted the argus setup manual.

Did you change the scheduler service to a user account that will be network share compatible (as per the manual)?

My current dillemma is one of the pcs I'm trying to stream to (a iMac running xbmc) streams for about 30 seconds at then buffers/stops. The other pcs btw are android tv devices and work to some degree. Anyway back to the iMac... Watching the progress bar, it seems to stop when the cached and the current meet (ie it runs out of something to display I guess).

If anyone can assist, that'd be great.

Regards,
BH
find quote