Comskip for Linux released

  Thread Rating:
  • 6 Votes - 4.17 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
MarcAngelo Offline
Junior Member
Posts: 15
Joined: May 2012
Reputation: 0
Post: #46
(2013-01-01 23:31)cbxbiker61 Wrote:  OK, I think I figured out what you guys have been saying about the 30 second delay.

My default setup is creating .ts files. With the .ts files the commercial flagging seems to have timestamps that work correctly with xbmc.

I have processed some of my older .mkv files and what I see here is that xbmc is interpreting the timestamps off by 30 seconds. When I manually change to .edl files and add 30 seconds to each of the timestamps playback is correct.

What I may have to do is add a new parameter to comskip.ini that tells it to create an .edl file for the 30 second xbmc bug (I'm assuming it's a bug in xbmc, which may prove to be wrong). In this case it would add 30 seconds to each of the timestamps.

If we figure out a more correct way of dealing with this we can then just turn off the 30 second delay in comskip.ini.

I'm using XBMCbuntu 11.0 Eden, but with the package from PulseEight (http://packages.pulse-eight.net/), which provide XBMC packages
with PVR-support (PVR-support was missing in original XBMCbuntu distro), since I'm using TVheadend as a backend. (only records in .mkv format)

Comskip works and creates .edl and .txt files.

It doesn't matter if I use .edl or .txt, but the offset is wrong.
When it automatically tries to skip commercials during playback, it starts with a delay (video freezes), but than the playback is stopped!
When I resume playback it seems to resume on the right location.

The delay was solved by updating XBMC to the most recent package. In my case to 11.0-pvr build103.
After updating XBMC the delay is gone, but offset doesn't seem to be correct yet.

So, if a parameter could be added to comskip.ini to define for example a 30 second offset, would be nice.

I do have 1 other question : I'm using output_edl=1
All created .edl-files use parameter 0 (cut), but I would like to use option 3 (Commercial Break).
Where do I define this option?

I would like to use it, for wrongly added entries, to be able to skip back and watch a part anyway.


Marc

Acer Aspire Idea 500 with 2 Yuan MPC718 MiniPCI hybrid DVB-T Tuners running
XBMCbuntu 11.0 "Eden", TVheadend 3.2 and Comskip 0.91e.
(This post was last modified: 2013-01-01 23:54 by MarcAngelo.)
find quote
Razor_109 Offline
Senior Member
Posts: 234
Joined: Nov 2007
Reputation: 0
Location: Netherlands
Post: #47
couldn't get it to work under ubuntu 10.4, would not recognize the argtable2 package somehow, just upgraded to 12.04 was time anyway Wink so now its compiling..

any news about the 30sec delay how to bypass this?

HTPC + Mediaserver
E8400 - ABIT I-N73HD - 2GB DDR2 - 3.5TB - Geforce G210 - ANTEC FUSION V2 - Ubuntu 10.04 - XBMC-PVR

TV-Server
Ubuntu 10.04 - Tvheadend - Smargo Reader - Oscam Card Server - 2x PCI DVB-C
find quote
MarcAngelo Offline
Junior Member
Posts: 15
Joined: May 2012
Reputation: 0
Post: #48
I'm not sure about the 30 second delay.
As you might know XBMC is capable to handle .edl, .txt (comskip), and .vdr files.

I'm checking if using the comskip .txt file instead of the .edl file, the time when auto skipping IN the videofragment is more acurate.
Still investigating though. If that works, then I'm thinking of using the comskip .txt file for my recordings instead of the .edl file format.

I would move the created .edl file to a backup-folder, in case this 'bug' might get fixed in XBMC in the near future, instead of using
a (technically) wrong .edl-file because of the added 30 second offset.

If XBMC gets fixed in the near future, then the existing .edl files would be incorrect, making it useless until a new file is generated by
re-running comskip.

If .txt file works correctly, I don't mind to use that instead of a manipulated .edl file. Wink


-- EDIT --

Well...
No luck sofar. It seems that the comskip .txt file is completely ignored in XBMC. Sad
Back to the drawingboard... Perhaps a 30 second offset parameter for .edl isn't such a bad idea Smile


Marc

Acer Aspire Idea 500 with 2 Yuan MPC718 MiniPCI hybrid DVB-T Tuners running
XBMCbuntu 11.0 "Eden", TVheadend 3.2 and Comskip 0.91e.
(This post was last modified: 2013-01-02 01:24 by MarcAngelo.)
find quote
cbxbiker61 Offline
Senior Member
Posts: 179
Joined: Nov 2010
Reputation: 2
Post: #49
OK, the 0.91d version now has the ability to add nn.n second offset to the .edl file.

It also had a new option to allow you to specify the edl skip mode that can be 0 for cut or 3 for commercial break. The other modes are also allowed, but I'm not sure whether they would be useful for xbmc.

See post 1 for details.

BTW, the latest version of tvheadend can be configured to output to .ts files rather than .mkv. If you use .ts files it does not have the 30 second offset bug.
(This post was last modified: 2013-01-02 03:03 by cbxbiker61.)
find quote
MarcAngelo Offline
Junior Member
Posts: 15
Joined: May 2012
Reputation: 0
Post: #50
(2013-01-02 02:57)cbxbiker61 Wrote:  BTW, the latest version of tvheadend can be configured to output to .ts files rather than .mkv. If you use .ts files it does not have the 30 second offset bug.

I downloaded your latest and compiled it.
It's processing an mkv at this moment, which I'll check in a couple of minutes.

I'm also downloading the updated version of TVheadend from PulseEight, to check if recording to .ts
is possible. Would be a nice solution as well...

I'll keep you posted.
Is 02:30 AM overhere, so might be going to bed shortly Wink


Marc

Acer Aspire Idea 500 with 2 Yuan MPC718 MiniPCI hybrid DVB-T Tuners running
XBMCbuntu 11.0 "Eden", TVheadend 3.2 and Comskip 0.91e.
find quote
MarcAngelo Offline
Junior Member
Posts: 15
Joined: May 2012
Reputation: 0
Post: #51
One quick reply...
Version number is shown as 0.91c instead of 0.91d. Smile

Will be testing mkv's tomorrow Wink


Marc

Acer Aspire Idea 500 with 2 Yuan MPC718 MiniPCI hybrid DVB-T Tuners running
XBMCbuntu 11.0 "Eden", TVheadend 3.2 and Comskip 0.91e.
(This post was last modified: 2013-01-02 09:37 by MarcAngelo.)
find quote
MarcAngelo Offline
Junior Member
Posts: 15
Joined: May 2012
Reputation: 0
Post: #52
Another update....

Updated TVheadend to enable .ts support.
Unfortunatly it no longer wanted to run as service, which was cause by an old /etc/default/tvheadend file, which was
missing parameters for the new version of tvheadend. Fixed that!

In case someone else experiences the same as me after updating TVheadend : https://www.lonelycoder.com/redmine/boar...opics/6493

I did a recording to .ts and noticed that, while the "edl_mode=3" in the comskip ini-file, it wrote value "0" to the .edl file.
So it seems that the parameter doesn't work correctly (yet).

While playing back the .ts file, the .edl file seems to be ignored (no auto skips), while it seems to be used when playing .mkv.


Marc

Acer Aspire Idea 500 with 2 Yuan MPC718 MiniPCI hybrid DVB-T Tuners running
XBMCbuntu 11.0 "Eden", TVheadend 3.2 and Comskip 0.91e.
(This post was last modified: 2013-01-02 13:21 by MarcAngelo.)
find quote
xxxnelly Offline
Senior Member
Posts: 193
Joined: Dec 2010
Reputation: 1
Post: #53
Hi cbxbiker61 - thanks for the quick turnaround in changes - here is a summary of my finding.

1. Using Tvheadend .ts files does not require the offset ( so thats great)
2. Using the edl_mode=3 does output the correct value in the .edl file -> although xbmc seems to disregard it.
3. This setting mkv_time_offset does move the time out by 30seconds for mkv files.
4. I had to use this flag (in the script) to pick up the comskip.ini --ini=/usr/etc/comskip/comskip.ini

So it now all works as expect apart from one main point, it doesnt seem to detect the commercials correctly..... Do I need to play with the comskip settings... does anyone have any advice for UK sky channels.

Thanks

--
Frontend : OpenELEC PVR runnig on Acer Revo 3700
Backend : Ubuntu 11.10 running with TVHeadend 1 x DVB-T, 1 x Dual DVB-S2
(This post was last modified: 2013-01-02 14:26 by xxxnelly.)
find quote
cbxbiker61 Offline
Senior Member
Posts: 179
Joined: Nov 2010
Reputation: 2
Post: #54
(2013-01-02 14:25)xxxnelly Wrote:  Hi cbxbiker61 - thanks for the quick turnaround in changes - here is a summary of my finding.

1. Using Tvheadend .ts files does not require the offset ( so thats great)
2. Using the edl_mode=3 does output the correct value in the .edl file -> although xbmc seems to disregard it.
3. This setting mkv_time_offset does move the time out by 30seconds for mkv files.
4. I had to use this flag (in the script) to pick up the comskip.ini --ini=/usr/etc/comskip/comskip.ini

So it now all works as expect apart from one main point, it doesnt seem to detect the commercials correctly..... Do I need to play with the comskip settings... does anyone have any advice for UK sky channels.

Thanks

Commercial detection is as much an art as a science. So tweeking the comskip.ini settings may be necessary to improve detection with some video. For those who are able to read/write code there is also the potential that they may come up with improved algorithms and I'm happy to accept patches that improve commercial detection.

One other thing to note is that comskip will look for a comskip.ini in the current directory to override the default settings in /etc/comskip/comskip.ini. So if you have a particular program/series that requires different settings than the majority you can segregate those in a specific directory and copy/tweek a comskip.ini there.
find quote
cbxbiker61 Offline
Senior Member
Posts: 179
Joined: Nov 2010
Reputation: 2
Post: #55
(2013-01-02 12:14)MarcAngelo Wrote:  Another update....

Updated TVheadend to enable .ts support.
Unfortunatly it no longer wanted to run as service, which was cause by an old /etc/default/tvheadend file, which was
missing parameters for the new version of tvheadend. Fixed that!

In case someone else experiences the same as me after updating TVheadend : https://www.lonelycoder.com/redmine/boar...opics/6493

I did a recording to .ts and noticed that, while the "edl_mode=3" in the comskip ini-file, it wrote value "0" to the .edl file.
So it seems that the parameter doesn't work correctly (yet).

While playing back the .ts file, the .edl file seems to be ignored (no auto skips), while it seems to be used when playing .mkv.


Marc

Just in case you downloaded a version that wasn't quite ready here is a version that I know works. After a while the original comskip-0.91d.tar.xz will be the same, just have to wait for the web caches to flush.

http://www.xilka.com/xilka/source/comski...er2.tar.xz

Note that comskip uses a comskip.ini in the current directory to override the defaults in /etc/comskip/comskip.ini. So that may cause unexpected results if you're not aware of it.
find quote
salnajjar Offline
Member
Posts: 50
Joined: Jan 2009
Reputation: 0
Post: #56
(2013-01-02 18:22)cbxbiker61 Wrote:  Just in case you downloaded a version that wasn't quite ready here is a version that I know works. After a while the original comskip-0.91d.tar.xz will be the same, just have to wait for the web caches to flush.

http://www.xilka.com/xilka/source/comski...er2.tar.xz

Note that comskip uses a comskip.ini in the current directory to override the defaults in /etc/comskip/comskip.ini. So that may cause unexpected results if you're not aware of it.

Just compiled and tested on Gentoo. Took a little work (I had libav installed so had to unmerge that and emerge ffmpeg then do a revdep-rebuild). Seems to work fine, just testing on a recording now.

Thanks for the good work.
find quote
MarcAngelo Offline
Junior Member
Posts: 15
Joined: May 2012
Reputation: 0
Post: #57
I'm not sure if I'm happy with the new version of TVheadend.
Several scheduled recordings failed because of "waiting for stream", which I never experienced with the previous version Sad

I found that, even though I compiled 0.91d, the 0.91c was executed.
I must have forgotten to adjust the prefix location once... Sorry for that...

I find the behaviour in XBMC instable.
I processed a MKV file, with and without the 30 second offset.
Both didn't skip any commercial.

I tried another MKV file.
It skipped 1 time on the correct location without 30 second offset.
The other 'chapters' were ignored. With the 30 second offset, it skipped on the wrong position.

Checking for a solution regarding the "waiting for stream" 'feature'. Perhaps it's because I configured it
to use .TS media container... Not sure yet.


Marc

Acer Aspire Idea 500 with 2 Yuan MPC718 MiniPCI hybrid DVB-T Tuners running
XBMCbuntu 11.0 "Eden", TVheadend 3.2 and Comskip 0.91e.
find quote
cbxbiker61 Offline
Senior Member
Posts: 179
Joined: Nov 2010
Reputation: 2
Post: #58
(2013-01-03 00:54)MarcAngelo Wrote:  I'm not sure if I'm happy with the new version of TVheadend.
Several scheduled recordings failed because of "waiting for stream", which I never experienced with the previous version Sad

I found that, even though I compiled 0.91d, the 0.91c was executed.
I must have forgotten to adjust the prefix location once... Sorry for that...

I find the behaviour in XBMC instable.
I processed a MKV file, with and without the 30 second offset.
Both didn't skip any commercial.

I tried another MKV file.
It skipped 1 time on the correct location without 30 second offset.
The other 'chapters' were ignored. With the 30 second offset, it skipped on the wrong position.

Checking for a solution regarding the "waiting for stream" 'feature'. Perhaps it's because I configured it
to use .TS media container... Not sure yet.


Marc

FYI, I'm using tvheadend 3.2.18 which seems to work almost flawlessly.
find quote
cbxbiker61 Offline
Senior Member
Posts: 179
Joined: Nov 2010
Reputation: 2
Post: #59
0.91e is out with a fix for segfaulting on media files with bad audio stream.
find quote
MarcAngelo Offline
Junior Member
Posts: 15
Joined: May 2012
Reputation: 0
Post: #60
I'm using tvheadend 3.2. Can't seem to determine which subversion, since it doesn't show.
I updated it 2 days ago using apt-get and lonelycoder as a repository.
Since then I'm able to save recordings using the .ts Media Container.

Had some issues yesterday regarding "waiting for stream", that seems to be fixed now.
Seems that the old configs weren't working properly for the newer version (muxes dissapeared), so reconfigured with fresh configs.
Seems ok now...

downloaded and compiled 0.91e.
Scheduled some tv-shows, to check if my script for post-processing the recordings runs correct.
Then I'll check if skipping is done at the right positions...

the "edl_mode=" parameter works great!

I'll keep ya informed.



Marc

Acer Aspire Idea 500 with 2 Yuan MPC718 MiniPCI hybrid DVB-T Tuners running
XBMCbuntu 11.0 "Eden", TVheadend 3.2 and Comskip 0.91e.
(This post was last modified: 2013-01-03 11:31 by MarcAngelo.)
find quote
Post Reply