Comskip for Linux released

  Thread Rating:
  • 6 Votes - 4.17 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
cbxbiker61 Offline
Senior Member
Posts: 180
Joined: Nov 2010
Reputation: 2
Post: #241
(2014-07-07 14:41)snickers2k Wrote:  oh, thx. You're right. So it DOES work. I get the metadata files.
so i tried it with XBMC. and the commercials are skipped mostly. but this results in a very weird behavior of XBMC at manually skipping forward or backward.
So to really cut out the commercials, for making it work with any player and for saving disk-space - there is an Windows app "Comclean". But i can't find a Linux alternative. Anyone having an idea?

You don't need an executable to strip the commercials. What you do need is a bash script that uses the .edl file to determine the ranges to strip (with for example ffmpeg). I haven't had a need to do this but you should be able to google it.

As far as Xbmc skipping and such, the later versions work the best. If you use edl_mode 3, the commercials will be initially skipped during playback, but if you skip backwards the commercials will be included in the rewind. This is a good thing in that if the comskip isn't perfect you can play the ranges that were skipped.

(2014-09-03 23:52)menno Wrote:  
Code:
configure: error: Package requirements (libavcodec >= 53.42) were not met:

Requested 'libavcodec >= 53.42' but version of libavcodec is 52.107.0

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables AVCODEC_CFLAGS
and AVCODEC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
pimp-ass-server:/var/tmp/ComSkipWork/comskip-0.93h# ffmpeg -version
ffmpeg version N-62510-g2799845
built on Apr 18 2014 05:12:39 with gcc 4.6 (Debian 4.6.3-1)
configuration: --prefix=/root/ffmpeg-static/32bit --arch=x86_32 --extra-cflags='-m32 -I/root/ffmpeg-static/32bit/include -static' --extra-ldflags='-m32 -L/root/ffmpeg-static/32bit/lib -static' --extra-libs='-lxml2 -lexpat -lfreetype' --enable-static --disable-shared --disable-ffserver --disable-doc --enable-bzlib --enable-zlib --enable-postproc --enable-runtime-cpudetect --enable-libx264 --enable-gpl --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-gray --enable-libass --enable-libfreetype --enable-libopenjpeg --enable-libspeex --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-version3 --enable-libvpx
libavutil      52. 77.100 / 52. 77.100
libavcodec     55. 58.103 / 55. 58.103
libavformat    55. 37.100 / 55. 37.100
libavdevice    55. 13.100 / 55. 13.100
libavfilter     4.  4.100 /  4.  4.100
libswscale      2.  6.100 /  2.  6.100
libswresample   0. 18.100 /  0. 18.100
libpostproc    52.  3.100 / 52.  3.100
server:/var/tmp/ComSkipWork/comskip-0.93h#

Ive install ffmpeg in /usr/local/bin/ffmpeg
why doesnt it see its a new enough version?

Just use the static directions in post 1.
(This post was last modified: Yesterday 12:17 by cbxbiker61.)
find quote
Post Reply