Change channel really slow

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
boofty Offline
Junior Member
Posts: 2
Joined: Jan 2013
Reputation: 0
Post: #1
Hi,

I've just started playing around with MediaPortal server XBMC client and so far, I have to say I'm blown away by how slick and responsive XBMC is. I've spent 2 years with Windows MC and an Xbox 360 as an extender and while it was fine, I want to try something different. I have a ResberryPi and I'd like to eventually use it as a client. I've seen and heard alot about XBMC so I decided to give it a try - I can see now why it's so popular!

I have a Win7 PC in my office with dual DVB-S and DVB-T tuners with MediaPortal 1.2.3 with MediaPortal_v123_TVServerXBMC_plugin_bin_rev118.
I'm using a Win8 laptop for client testing with XBMC installed.
XBMC version: 12.0-RC3 Git:20130102-7a6cb7f), Platform: Windows 8 64-bit, build 9200. Built on Jan 3 2013 (compiler 1600)

So, I'm almost there in terms of setup - everything is functional but I'm left with one major problem - it's taking 7 seconds to change a channel (all channels are DVB-S and DVB-T ... no DVB-S2). The delay happens when changing any channel sequence (DVB-S -> DVB-S, DVB-T -> DVB-T, DVB-S -> DVB-T, DVB-T -> DVB-S). If I use MediaPortal as the client on the same laptop connected to the same MediaPortal server on the PC in the office, then the channel changes is 2 seconds or less.

I've enabled logging in XBMC client and I can see a clear 5 second delay in the logs:
14:09:06 T:4904 ERROR: ffmpeg[1328]: [mpeg2video] mpeg_decode_postinit() failure
14:09:11 T:4904 ERROR: Previous line repeats 9 times.
14:09:11 T:4904 DEBUG: ffmpeg[1328]: [mpegts] max_analyze_duration 5000000 reached at 5016000
14:09:11 T:4904 DEBUG: ffmpeg[1328]: [mpegts] decoding for stream 3 failed
This delay happens every time and is 100% reproducible.

I've also recorded 2 shows, and playing them back is instantaneous - i.e. to switch between recordings is instantaneous. The really strange thing is from the logs, the point at which I switch has the same error messages but it does not cause any problems (there is no 5 second delay).
14:44:02 T:2324 ERROR: ffmpeg[914]: [mpeg2video] mpeg_decode_postinit() failure
14:44:02 T:4624 ERROR: Previous line repeats 1 times.
14:44:02 T:4624 DEBUG: SECTION:UnloadDelayed(DLL: special://xbmcbin/system/ImageLib.dll)
14:44:02 T:5716 NOTICE: Thread Jobworker start, auto delete: true
14:44:02 T:5716 DEBUG: CSaveFileStateJob::DoWork - Saving file state for video item \\HTPC\Share\Reccording\Made in Chelsea - E4 - 2013-01-05.ts
14:44:03 T:2324 DEBUG: ffmpeg[914]: [mpegts] max_analyze_duration 5000000 reached at 5016000
14:44:03 T:2324 DEBUG: ffmpeg[914]: [mpegts] decoding for stream 3 failed

I'm pretty sure the 5 second delay is what's causing my problems as without this delay, everything would be fine. I've checked the logs on the MediaPortal side on the server and everything is fine.
I've uploaded both logs here:
http://dl.dropbox.com/u/14047643/xbmc_pl...ive_tv.log
http://dl.dropbox.com/u/14047643/xbmc_pl...ording.log

Any feedback on a workaround would be greatly appreciated - I think this is the last stumbling block that's preventing me from making the change.

Thanks
find quote
wileecoyote Offline
Senior Member
Posts: 179
Joined: Jul 2010
Reputation: 6
Location: Cary, NC
Post: #2
This is a known issue and something Margro (MediaPortal addon developer) has been working hard to fix. Here is a discussion on the very same a few days ago... http://forum.xbmc.org/showthread.php?tid=141039&page=2

Good luck with the switch & welcome to XBMC!

XBMC PVR Addon Unofficial Builds for Frodo Nightly Builds.
http://www.dotnetdevelopers.net/xbmc
find quote
boofty Offline
Junior Member
Posts: 2
Joined: Jan 2013
Reputation: 0
Post: #3
Thanks for letting me know wileecoyote - I appreciate it.
I won't be switching to XBMC while it has this problem - this is something I couldn't live with!

Is it known if this problem is with certain hardware/software combinations? i.e. is there something I can do to avoid it? If I bought an Rasberry Pi or something else and ran OpenElec for example, would I experience the same problem?
From reading the other thread, it doesn't sound like everyone is having this problem switching channels.
One other thing that struck me ... I have included 2 scenarios above. The 2nd scenario where I've zapping between 2 recoreded shows - this is instant. Why would that be? If the problem is codec related then I would expect to see the same problem with the recorded media!
(This post was last modified: 2013-01-07 22:13 by boofty.)
find quote
DoubleM Offline
Junior Member
Posts: 2
Joined: Sep 2012
Reputation: 0
Post: #4
It looks like I am in the same boat as you Boofty. I have Windows MCE and it all works flawlessly, ok it isn't that sexy and so that is why I am messing about with XBMC since aesthetically it is amazing and has a larger userbase to bounce ideas off. But, and this is a big one, TV does not work! this is in my eyes fundamentally what a media center is all about. I have four tuners in my system and having the system freeze up all the time and take 10 seconds+ to change channel (when it does) is unfortunately not usable. I have tweaked as many settings as i can find but to no avail. I am happy to be a guinea pig if anyone has any ideas, but until this can be fixed I will have to stick with Windows MCE since otherwise my wife will go up the wall

FYI I am using NextPVR as the backend and it seems to channel change very quickly.

thanks all, if anyone can post me a fix or point me in the right direction when there is one, then it would be greatly appreciated

these are the errors in the log file, if anyone can shed any light on it

18:15:00 T:4984 ERROR: ffmpeg[1378]: [mpeg2video] mpeg_decode_postinit() failure
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #5
@doubleM: no fix at the moment for Frodo, athough I'm testing a workaround with promising results... The ffmpeg library spends max (read: always for Live tv) 5 seconds on stream analysis during a channel switch and I've changed this to 0.5 s in the XBMC code. It is not a proper fix, but it seems to work.

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
DoubleM Offline
Junior Member
Posts: 2
Joined: Sep 2012
Reputation: 0
Post: #6
@margro: Cheers for the quick response, how can I go about making this change is this something I can apply via a setting or do I need to download code from git hub? Can you point me in the right direction please
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #7
@DoubleM: not a setting. Requires building both XBMC and the development version of the MediaPortal pvr addon from my github repository.
The particular change that reduces the channel switch time for me is this commit.

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
sub3 Offline
Fan
Posts: 362
Joined: Sep 2012
Reputation: 5
Post: #8
(2013-03-02 23:55)margro Wrote:  The particular change that reduces the channel switch time for me is this commit.
That's a surprisingly small change. Hopefully it helps.
find quote
krycek Offline
Junior Member
Posts: 32
Joined: Jan 2011
Reputation: 0
Post: #9
@someone, those changes, are they going to be fixed in the monthly updates or in the next major release (eg v13?)
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #10
The planned changes from FernetMenta will probably reduce the switching times in a proper way. They are planned for v13.
I'm not aware of planned changes in this aread for a v12.1 release.

When time permits, I will test his changes and post a modified Frodo build to reduce the channel switch times...
I'm quite busy at the moment, so it may take a few weeks...

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
krycek Offline
Junior Member
Posts: 32
Joined: Jan 2011
Reputation: 0
Post: #11
Oke cool thanks Margo,
No rush, just curious.
And the v13 is a yearly update ? Somewhere to see the roadmap ?
find quote
Birdincamera Offline
Junior Member
Posts: 39
Joined: Jan 2013
Reputation: 0
Post: #12
Great news for me margro, I too use MP TV service backend and XBMC on 3 HTPCs - wife is not impressed with the channel change times (5-7 seconds) so no go ahead to ditch my cable TV service and save a few £££s

Look forward very much to your mod, in meantime (noob alert) when you say

(2013-03-02 23:55)margro Wrote:  @DoubleM: not a setting. Requires building both XBMC and the development version of the MediaPortal pvr addon from my github repository.
The particular change that reduces the channel switch time for me is this commit.

What do you mean by 'build', would like to try this in meatime.
find quote
jdembski Offline
Fan
Posts: 502
Joined: Feb 2012
Reputation: 12
Post: #13
(2013-03-02 23:55)margro Wrote:  @DoubleM: not a setting. Requires building both XBMC and the development version of the MediaPortal pvr addon from my github repository.
The particular change that reduces the channel switch time for me is this commit.

Hmm - I just tried this change.

Good news: Channel switching is really fast now
Bad news: Sometimes there will be no picture, just the audio playing.

Guess I will go and play around a little bit with the max_analyze_duration...

VU+ / Enigma2 PVR Client: Documentation | Development | Discussion
find quote
FernetMenta Offline
Team-Kodi Developer
Posts: 3,276
Joined: Jul 2010
Reputation: 65
Location: Munich
Post: #14
Can you test this: https://github.com/FernetMenta/xbmc/tree/zappy
The 4 commits on top are relevant.
find quote
jacobjust Offline
Junior Member
Posts: 12
Joined: Dec 2008
Reputation: 0
Post: #15
(2013-03-21 13:13)FernetMenta Wrote:  Can you test this: https://github.com/FernetMenta/xbmc/tree/zappy
The 4 commits on top are relevant.

Build failed for me. Grapped today at 14:26. Other builds fine... (margro and master)...
(This post was last modified: 2013-03-21 16:39 by jacobjust.)
find quote
Post Reply