Neon (Frodo edition) [v2.5.9]

  Thread Rating:
  • 3 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #1
Neon for Frodo !
Most is working, although it is still a work in progress.
Notice: Skin versions 2.5.5 and earlier are incompatible with Frodo.

Installation
Zip file (direct installation, you will not get any automatic updates)
Get the latest version here.
Repos:
- You can find Neon in the Superrepo, but because of recent issues with other addons in this repository I am not actively promoting using this repository anymore.
- You can find Neon in the Passion repo but because they do not respond to my requests and keep hosting incorrect / non-working versions I no longer advise people to use this repo at all.

Reporting issues
First look in the FAQ list directly below.
If you can't find the problem there then please post your OS, XBMC version, skin version and issue description in this thread.
Bonus points (and quicker fixes) if you include screenshots !

-----------------------------------------------------------------

FAQ:
1) If you just started using XBMC Frodo
* Read the Frodo FAQ
* read the list of known issues in Frodo

2) If you can't find the skin settings
* Skin Settings have been moved to Appearance - Skin - Settings as is required for Frodo.

3) Known issues in Neon 2.5.9
* Priority issues:
[#16] Music "Now Playing screen" has misaligned items (possible fix is being checked)
[#12] Skin setting "Use a local landscape.jpg instead of regular thumb on TV level" not honored in every view.
[#01] Media flags show "HD READY" for 1080p videos
* Smaller issues:
[#17] PVR screens have not been checked for alignment issues yet
[#11] When using PseudoTV addon there are smaller alignment issues

4) Requests for new additions / features to the skin
Here is a list of requests that have already been made in this thread:
Adding new features to the skin has a lower priority than fixing known issues.
[#10] Modify the Panel view to have additional 4x6 and 6x9 views
[#14] Add Hi10P media tags
[#15] Add ' Media Info 3' view
[#06] Use transifex for skin translations

-----------------------------------------------------------------

Changelog
2.5.9
- prevent Artist Slideshow from showing up twice (#13)
- Add Sets button to Movies submenu
- Landpanel shows correct images at TVShow level
- Bottom RSS not shown when XBMC global setting disables all RSS
- Implemented skinsetting to change global weather
- Smaller CodecInfo font so VDPAU info fits correctly
- Fix restart XBMC option in shutdown menu
- [Slide] Fix Fullscreen trailer
- [Wall] Fix thumbnails
- Neon settings added to Settings submenu
2.5.8
- Pressing up-button from Homebar Settings does not navigate to empty view anymore. (#09)
- Fixed alignment of all recent and random items (#07)
- Added skin setting for 'songs rather than albums' (defaults to albums)
- 'Use large recent TV-Shows' now functional and selectable.
- Fixed an issue that prevented playing recent items when those items were on a smb-fileshare
- Progressbar centered in screen (Stoli #04)
- Norwegian language corrected (Stoli #03)
- Settings menu glued back together (never noticed it became disjointed)
- Removed the extra clearlogo that was right through the text in info screen
- Removed unused fonts
2.5.7
- Use Shutdown instead of Poweroff when choosing shutdown in main menu
- Fanart shown using database calls instead of fixed locations, to comply with Frodo (#08)
- Skin now correctly using DejaVu font
- Video watched overlay status added to Multiplex view
- Random items now functional, still need to be aligned properly (#02)
2.5.6
- Initial add for XBMC Frodo

Skin history:
Stoli initially wrote and designed this excellent skin in oktober 2010 for XBMC Dharma.
Stoli started porting it to XBMC Eden in April 2011 and continued maintaining it for XBMC Eden until August 2012.
I started porting it to XBMC Frodo begin January 2013.
(This post was last modified: 2013-12-11 16:56 by Kib.)
find quote
Japz Offline
Junior Member
Posts: 5
Joined: Jan 2012
Reputation: 0
Post: #2
Installed fine, just one error from the log (don't know how relevant):

Code:
16:44:56 T:3077486400    INFO:   msg: PICTURE::LoadImage: Unable to open image: /root/Frodo.zip/icon.png Error: (11)
16:44:56 T:3077486400   ERROR: Texture manager unable to load file: /root/Frodo.zip/icon.png
find quote
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #3
Thx for testing Japz!

That error is fine - it seems to happen when manually loading a skin from a zip file.
After installation the icon is shown as it should be (in the skin selection dialog)
find quote
stoli Offline
Skilled Skinner
Posts: 2,409
Joined: Nov 2008
Reputation: 31
Location: Florida
Post: #4
@Kibje - thanks for the work. I've merged your pull request so it will get updated in Passion Repo. I'm pretty much out of commission for the next month or so, but will watch for any pull requests.

Thanks again,
find quote
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #5
I have to see when I can work on it again - not much time either and still learning.
I plan to at least correct the aligning of the recent items and get the random items working in Frodo, that will probably be the next pull request.
(This post was last modified: 2013-01-23 21:48 by Kib.)
find quote
codepony Offline
Junior Member
Posts: 9
Joined: Dec 2012
Reputation: 1
Post: #6
I still have a problem with Neon not showing the correct artwork for TV show banners and movie posters. The show up fine in Confluence. For TV shows, half my banners are blank even though a banner is selected.
find quote
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #7
(2013-01-24 07:20)codepony Wrote:  I still have a problem with Neon not showing the correct artwork for TV show banners and movie posters. The show up fine in Confluence. For TV shows, half my banners are blank even though a banner is selected.
First of all, this is now on the known bugs list.
I'd like to look into this tonight, but it's hard to know where to start because you are not giving me much to work with.
The skin is quite complex and I am still finding my way in it.

What version of the skin are you running and what version of XBMC Frodo (RC1 / RC2 / RC3 ) ?
Which OS ?
What view have you got selected where you expect the banners - I do not use banners myself.
Can you make a screenshot showing what you see in Neon ?
Can you make a screenshot of the contents of one of your fileshares ( I am interested if you have local artwork files in the folders or not.)

I think I have a clue what causes the issue but it might take quite me some time to figure out how to fix it.
Providing this information will significantly shorten the amount of time.
(This post was last modified: 2013-01-24 10:35 by Kib.)
find quote
supergroovegear Offline
Junior Member
Posts: 17
Joined: Aug 2010
Reputation: 1
Post: #8
Hi and happy new year stoli and Kibje

Kibje, thanks for the updates. I'd like to see what the updates are. My barrier at the moment is that I have so many customisations at the moment that I'd have to start from scratch to recustomise and I am too lazy for that at the moment (that's my problem not yours Big Grin).

Which leads me to stoli, thanks for the git updates on the passion repo which I get through the passion addon. I had hoped that the git update would satsify my laziness so the skin would update automatically. However, the Neon still appears as 'broken' and I can't update it. Is there anything that can be done about that or is that a passion addon issue?

Thanks
(This post was last modified: 2013-01-24 10:53 by supergroovegear.)
find quote
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #9
@Stoli - Random items are working / functional. The skin is now using service.skin.widgets instead of script.randomitems.

I upped the version to 2.5.7 and sent a pull request.

Also, you can close your issues number 3 and number 4
find quote
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #10
(2013-01-24 10:51)supergroovegear Wrote:  Hi and happy new year stoli and Kibje
You as well =)
(2013-01-24 10:51)supergroovegear Wrote:  Kibje, thanks for the updates. I'd like to see what the updates are. My barrier at the moment is that I have so many customisations at the moment that I'd have to start from scratch to recustomise and I am too lazy for that at the moment (that's my problem not yours Big Grin).
Check out the changelog at the top, it links to the pull requests and proposed pull requests.
I think it might be easier to check out my changes and reapply them (or apply a diff if you know how to Tongue)
I am interested in your customisations as well. Any chance I could get a copy of your current version ? (Provided it works under Frodo!)
(2013-01-24 10:51)supergroovegear Wrote:  Which leads me to stoli, thanks for the git updates on the passion repo which I get through the passion addon. I had hoped that the git update would satsify my laziness so the skin would update automatically. However, the Neon still appears as 'broken' and I can't update it. Is there anything that can be done about that or is that a passion addon issue?

Thanks
What version is it showing in the addon browser ? I checked the repository just now and it is showing the correct version (2.5.6.1358955865) on the site.
If you are seeing that version as well, please let me know if it shows as broken - it shouldn't, because all skin requirements are correct for Frodo now - and I'll look into it.
(This post was last modified: 2013-01-24 11:25 by Kib.)
find quote
supergroovegear Offline
Junior Member
Posts: 17
Joined: Aug 2010
Reputation: 1
Post: #11
(2013-01-24 11:20)Kibje Wrote:  I am interested in your customisations as well. Any chance I could get a copy of your current version ? (Provided it works under Frodo!)
Oh miscommunication! My bad. My customisations are not structural to the skin but are mainly in respect to Home Customisations and backgrounds. I have changed a few xml file to use a particular font and to get use a different script in the home menu titles.

Quote:What version is it showing in the addon browser ? I checked the repository just now and it is showing the correct version (2.5.6.1358955865) on the site.
If you are seeing that version as well, please let me know if it shows as broken - it shouldn't, because all skin requirements are correct for Frodo now - and I'll look into it.
Yes that the version I have and it shows that it is enabled. I was confuised because I have set addons to NOT update automatically (ignore what I stated in my previous message). I was expecting an update notification but it seems it updated automatically.

I'll begin testing and keep you informed.
Thanks!
find quote
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #12
(2013-01-24 12:41)supergroovegear Wrote:  Yes that the version I have and it shows that it is enabled. I was confuised because I have set addons to NOT update automatically (ignore what I stated in my previous message). I was expecting an update notification but it seems it updated automatically.
It is weird that it autoupdated anyway, because it was never installable from the Frodo repository.
(This post was last modified: 2013-01-24 15:02 by Kib.)
find quote
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #13
Most likely fix for banner images added to new pull request. If stoli approves should be in repository one day later.
find quote
p750mmx Offline
Senior Member
Posts: 246
Joined: Feb 2012
Reputation: 4
Location: Netherlands
Post: #14
I've installed the Frode version by the link you shared on Tweakers and today I've installed the GIT version by the Passion-XBMC repository for Frodo. With the previous version there where no big issues but with the last GIT version, XBMC sometimes hangs when choosing XBMC exit while returning to Windows desktop. I must close XBMC by Windows task manager. I've configured both Frodo versions exactly the same by using the same addons and settings.

OS you run XBMC on: Windows 7 32b NL SP1
XBMC version: Frodo RC3
Neon skin version: 2.5.6.1358955865
Experience: as written above
Issues you have detected: as written above
Any other comments and remarks: not at this moment
find quote
Kib Offline
Team XBMC
Posts: 2,738
Joined: Jan 2010
Reputation: 50
Location: NL
Post: #15
(2013-01-24 21:38)p750mmx Wrote:  I've installed the Frode version by the link you shared on Tweakers and today I've installed the GIT version by the Passion-XBMC repository for Frodo.
I had the same thing when I had both installed. XBMC does not seem to like the fact you then have 2 skins which both have the same displayname.
Luckily it only happens if you install the zip from github which I previously linked to and another named zip which is basically the same (the passion-xbmc one)
Could you try removing one (or all) and then installing just the skin from the passion-xbmc repository ?

There is a huge update coming up that fixes most issues with randomitems and fanart displays in almost every view, should auto update in a day or so.

I will change the link on tweakers so people won't download that one anymore.
(This post was last modified: 2013-01-24 23:41 by Kib.)
find quote
Post Reply