Neon 2.5.9 for XBMC 12 (Frodo)

  Thread Rating:
  • 3 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
m-o-r-g Offline
Junior Member
Posts: 43
Joined: Oct 2012
Reputation: 0
Post: #31
(2013-01-28 22:21)Kibje Wrote:  Stoli pulled my changes into his code.
There will be a new version (2.5.7) in the Passion-XBMC repository tomorrow!


your reputation is getting a few more +1's from me for sure!
find quote
Kib Offline
Team XBMC
Posts: 3,205
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #32
It is now in the repository!
My mediacentre had auto-updated to 2.5.7 this morning.

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
find quote
m-o-r-g Offline
Junior Member
Posts: 43
Joined: Oct 2012
Reputation: 0
Post: #33
Good stuff Kibje . . . . keep the updates coming . . . you'll be an experienced 'skinner' in no time (you've certainly done a fine job so far!)

I'll update tonight and report back if all is well
find quote
p750mmx Offline
Senior Member
Posts: 250
Joined: Feb 2012
Reputation: 4
Location: Netherlands
Post: #34
Addon auto-update is disabled so I manually started the update from 2.5.6 > 2.5.7. when I saw that the update was there.

After starting the update TV-screen went blank and stayed blank, even after waiting a long time. XBMC did not hang but the screen just didn't came up, no reaction on whatever button I pressed.
I forced a XBMC close-down, restarted the system and restarted XBMC and the image came up with Neon 2.5.7. My screen-layout and background settings where the same as before so that was OK.

The first thing I've noticed was that the progress bar for scraping media was aligned to the left of the top-screen, that was in the top-center with my previous 2.5.6. Could be easy corrected I think.

Will test further with this version and keep posting my experiences.

OS you run XBMC on: Windows 7 32b NL SP1
XBMC version: Frodo Final
Neon skin version: skin.neon.svn-2.5.7.1359399692 (update from repo)
Experience: as written above
Issues you have detected: as written above
Any other comments and remarks: not at this moment
(This post was last modified: 2013-01-29 22:05 by p750mmx.)
find quote
Kib Offline
Team XBMC
Posts: 3,205
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #35
I am really mistified by your progress bar being aligned to the left of the top screen, which is an issue I can't reproduce with any of my systems.
It used to be incorrectly aligned but that was fixed several versions ago and I do not believe I have changed anything since then.

You could try reinstalling Neon:
switch to a different skin, remove Neon from the addons section and then install it again and switch to it.

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
find quote
p750mmx Offline
Senior Member
Posts: 250
Joined: Feb 2012
Reputation: 4
Location: Netherlands
Post: #36
Tested it on 2 different systems and on both systems I get the same image. On the second system I upgraded tot Frodo Final and selected this Neon version for the first time as skin. I use a 1920x1080 desktop on every system I have in my home (that is a total of 5), I will update every system to the latest Frodo and this skin. Will let you know if I experience the image on every system.

Edit: switched to other skin, un-installed Neon, closed XBMC, removed every zip file zip with Neon in the name from roaming. Started XBMC, selected Neon within the Passion-XBMC.org Add-ons (frodo-pre) and the view stays as seen below. Its not a big issue but it could look nicer.

[Image: ScreenShot102.jpg]
(This post was last modified: 2013-01-29 21:47 by p750mmx.)
find quote
godsfilth Offline
Junior Member
Posts: 1
Joined: Nov 2012
Reputation: 0
Post: #37
(2013-01-29 21:04)p750mmx Wrote:  Tested it on 2 different systems and on both systems I get the same image. On the second system I upgraded tot Frodo Final and selected this Neon version for the first time as skin. I use a 1920x1080 desktop on every system I have in my home (that is a total of 5), I will update every system to the latest Frodo and this skin. Will let you know if I experience the image on every system.

[Image: ScreenShot102.jpg]

i have this issue too i removed my weeks old github zip install and followed the directions in the first post to install the passion repo and install neon from there, not only do i have the progress bar on the left i have no skin settings menu to change settings. the really strange thing is that even if i remove the passion install and install straight from the latest github changes i still dont have the settings menu and the progress bar is on the left

im running frodo release (although i was having this issue with the nightly i had installed before upgrading as well)

the skin version is 2.5.7-1359399692
when i go under changelog it says last change says 23/1/13 16:44 stoli: Merge pull request #6 from kibje/Frodo

im making a quick backup then going to do aclean install of xbmc and see if that changes anything

EDIT: so full removal with clean install didn't change anything
(This post was last modified: 2013-01-29 22:23 by godsfilth.)
find quote
Kib Offline
Team XBMC
Posts: 3,205
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #38
I just managed to reproduce the progressbar issue.
I have not figured out yet why I don't have it on my test machine (that runs the latest github code) and on my own media centre (that uses the version from Passion XBMC).

I'll try to figure out what happened. Fixing it should be trivial indeed.


(2013-01-29 21:51)godsfilth Wrote:  i have this issue too i removed my weeks old github zip install and followed the directions in the first post to install the passion repo and install neon from there not only do i have the progress bar on the left i have no skin settings menu to change settings. the really strange thing is that even if i remove the passion install and install straight from the latest github changes i still dont have the settings menu and the progress bar is on the left
The skin settings menu has been removed from the main settings screen and moved to Appeareance - Skin - Settings (because it is a Frodo standard)
I have been thinking of putting the old menu location back so we will have both ways as it is bound to confuse people.

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
(This post was last modified: 2013-01-29 22:29 by Kib.)
find quote
Kib Offline
Team XBMC
Posts: 3,205
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #39
(2013-01-29 21:51)godsfilth Wrote:  when i go under changelog it says last change says 23/1/13 16:44 stoli: Merge pull request #6 from kibje/Frodo
The changelog is added automatically by Passion-XBMC but is not updated correctly. Please ignore it for now.

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
find quote
martix Offline
Junior Member
Posts: 30
Joined: Nov 2009
Reputation: 0
Post: #40
HI, i have installed the final version of xbmc v12 and have the latest neon version (2.5.7).
My problem is, that the favorite folder i added to the main menu as custom menu entry, is empty when i open it from the main menu.
When i open it from the favorite list, it works.
Any help?
find quote
m-o-r-g Offline
Junior Member
Posts: 43
Joined: Oct 2012
Reputation: 0
Post: #41
(2013-01-29 11:38)m-o-r-g Wrote:  Good stuff Kibje . . . . keep the updates coming . . . you'll be an experienced 'skinner' in no time (you've certainly done a fine job so far!)

I'll update tonight and report back if all is well

Yep updated, although I thought you would get some sort of notification? I had to check manually, obviously a repository thing?.

Anyway my progress bar is in the middle FYI.

Keep up the good work.

My AV Equipment

Virgin Media TiVo : Sony AV Receiver : Samsung LCD TV : PS3 : PC / HTPC (running xbmc) / Skin Neon / Aeon Nox
find quote
Kib Offline
Team XBMC
Posts: 3,205
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #42
m-o-r-g,

If you would like to test something: remove all references to the skin, reinstall it from the repository and check if the progress bar is still in the middle.
I still can't put my finger on that progressbar location.

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
(This post was last modified: 2013-01-30 14:46 by Kib.)
find quote
m-o-r-g Offline
Junior Member
Posts: 43
Joined: Oct 2012
Reputation: 0
Post: #43
Will have a go tonight for you, (I'm at work right now. . . Not doing much work :-D)

My AV Equipment

Virgin Media TiVo : Sony AV Receiver : Samsung LCD TV : PS3 : PC / HTPC (running xbmc) / Skin Neon / Aeon Nox
find quote
Kib Offline
Team XBMC
Posts: 3,205
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #44
Yeha join the club, I should be really typing out 5 pages of notes on an proposed fallback scenario.
Making the notes was fun, typing them out - not so much.
(2013-01-30 01:36)martix Wrote:  HI, i have installed the final version of xbmc v12 and have the latest neon version (2.5.7).
My problem is, that the favorite folder i added to the main menu as custom menu entry, is empty when i open it from the main menu.
When i open it from the favorite list, it works.
Any help?
It's a bit hard to check this at the moment. What would help is some more information or a debug log on xbmclogs.com

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
(This post was last modified: 2013-01-30 15:31 by Kib.)
find quote
Kib Offline
Team XBMC
Posts: 3,205
Joined: Jan 2010
Reputation: 53
Location: NL
Post: #45
(2013-01-30 01:36)martix Wrote:  HI, i have installed the final version of xbmc v12 and have the latest neon version (2.5.7).
My problem is, that the favorite folder i added to the main menu as custom menu entry, is empty when i open it from the main menu.
When i open it from the favorite list, it works.
Any help?

I just tried this to a new share I made and it worked like a charm.
Could you tell me what OS you are using, where the favorite is pointing to and what it said in the skin settings after you created it ?
In my case it says ActivateWindow(10025,"/home/blabla/bla")

Neon skin - v3.0.7 now available for XBMC 13 (Gotham)
find quote
Post Reply