[Release] Picture Slideshow Screensaver

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
sparticle Offline
Member
Posts: 97
Joined: Jan 2010
Reputation: 0
Post: #301
Quote:thanx.

the next version of the screensaver will support .nef files.

That's great thanks. The Nikon cameras can save in either .RAW or .NEF I believe they are the same format.

Cheers
Spart

3 x Raspberry Pi Model B (RaspBMC + Miappa Kodi Nightly) - Zotac Mag Ubuntu 12.04.5 XBMC 13.2 - RocketNAS 8TB Raid 6 Ubuntu 12.04.5 Minimal
find quote
Raytestrak Offline
Donor
Posts: 334
Joined: Sep 2011
Reputation: 3
Post: #302
(2014-08-27 20:41)ronie Wrote:  disk is offline, for instance, I get a slideshow of my media (or is it just of my movies, don't know).
does it make a difference if you set the samba timeout to, let's say, 20 seconds?
http://wiki.xbmc.org/index.php?title=Adv...3Csamba.3E

I've added it, I'll check if it helps. It doesn't crash all the time, so I'll come back to you with a positive result (I hope).

Edit:

alas .. Doesn't seem to make a difference.

XBMCbuntu on an Intel NUC (DC3217IYE). Onkyo NR-717. Canton Movie CD-1000. LG 42LM760S

If it ain't broke: break it, fix it, repeat
(This post was last modified: 2014-08-30 12:40 by Raytestrak.)
find quote
eisbaer128 Offline
Junior Member
Posts: 6
Joined: Dec 2010
Reputation: 0
Post: #303
I'm trying to skin the screensaver for my favorite skin (Eminence). It's my very first trial and I was able to adapt the positions, fonts..., but I'm not able to adapt the italic and bold style for the EXIF data as they are coded inside the script. Wouldn't it make sense to put this into the skin instead ? In addition the tags have some animation which I really coudn't figure out where this is coded ?


Any help appriciated

Code:
<?xml version="1.0" encoding="UTF-8"?>
<window>
        <zorder>5</zorder>
        <controls>
                <control type="group">
                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Splash),hide)">
                                <effect type="fade" start="0" end="100" time="500"/>
                        </animation>
                        <control type="group">
                                <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Fade1),1)">
                                        <effect type="fade" start="100" end="0" time="1000"/>
                                </animation>
                                <control type="largeimage" id="1">
                                        <posx>0</posx>
                                        <posy>0</posy>
                                        <width>1920</width>
                                        <height>1080</height>
                                        <aspectratio>keep</aspectratio>
                                        <fadetime>0</fadetime>
                                        <colordiffuse>$INFO[Window.Property(SlideView.Dim)]</colordiffuse>
                                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Slide1),0)" reversible="false">
                                                <effect type="slide" tween="cubic" easing="inout" start="1920,0" end="0,0" time="500"/>
                                        </animation>
                                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Slide1),1)" reversible="false">
                                                <effect type="slide" tween="cubic" easing="inout" start="0,0" end="-1920,0" time="500"/>
                                        </animation>
                                </control>
                        </control>
                        <control type="group">
                                <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Fade2),1)">
                                        <effect type="fade" start="100" end="0" time="1000"/>
                                </animation>
                                <control type="largeimage" id="2">
                                        <posx>0</posx>
                                        <posy>0</posy>
                                        <width>1920</width>
                                        <height>1080</height>
                                        <aspectratio>keep</aspectratio>
                                        <fadetime>0</fadetime>
                                        <colordiffuse>$INFO[Window.Property(SlideView.Dim)]</colordiffuse>
                                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Slide2),0)" reversible="false">
                                                <effect type="slide" tween="cubic" easing="inout" start="1920,0" end="0,0" time="500"/>
                                        </animation>
                                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Slide2),1)" reversible="false">
                                                <effect type="slide" tween="cubic" easing="inout" start="0,0" end="-1920,0" time="500"/>
                                        </animation>
                                </control>
                        </control>
                        <control type="group">
                                <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Fade1),1)">
                                        <effect type="fade" start="100" end="0" time="1000"/>
                                </animation>
                                <control type="largeimage" id="3">
                                        <posx>0</posx>
                                        <posy>0</posy>
                                        <width>1920</width>
                                        <height>1080</height>
                                        <aspectratio>scale</aspectratio>
                                        <fadetime>0</fadetime>
                                        <colordiffuse>$INFO[Window.Property(SlideView.Dim)]</colordiffuse>
                                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Slide1),0)" reversible="false">
                                                <effect type="slide" tween="cubic" easing="inout" start="1920,0" end="0,0" time="500"/>
                                        </animation>
                                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Slide1),1)" reversible="false">
                                                <effect type="slide" tween="cubic" easing="inout" start="0,0" end="-1920,0" time="500"/>
                                        </animation>
                                </control>
                        </control>
                        <control type="group">
                                <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Fade2),1)">
                                        <effect type="fade" start="100" end="0" time="1000"/>
                                </animation>
                                <control type="largeimage" id="4">
                                        <posx>0</posx>
                                        <posy>0</posy>
                                        <width>1920</width>
                                        <height>1080</height>
                                        <aspectratio>scale</aspectratio>
                                       <fadetime>0</fadetime>
                                        <colordiffuse>$INFO[Window.Property(SlideView.Dim)]</colordiffuse>
                                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Slide2),0)" reversible="false">
                                                <effect type="slide" tween="cubic" easing="inout" start="1920,0" end="0,0" time="500"/>
                                        </animation>
                                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Slide2),1)" reversible="false">
                                                <effect type="slide" tween="cubic" easing="inout" start="0,0" end="-1920,0" time="500"/>
                                        </animation>
                                </control>
                        </control>
                        <control type="grouplist">
                                <posx>1000</posx>
                                <posy>920</posy>
                                <itemgap>0</itemgap>
                                <orientation>vertical</orientation>
                                <control type="textbox" id="101">
                                        <width>900</width>
                                        <height>70</height>
                                        <align>right</align>
                                        <aligny>top</aligny>
                                        <font>Font-Sublabel</font>
                                        <textcolor>SubLabel2</textcolor>
                                </control>
                                <control type="label" id="99">
                                        <width>900</width>
                                        <height>35</height>
                                        <aligny>top</aligny>
                                        <font>Font-Sublabel</font>
                                        <textcolor>SubLabel2</textcolor>
                                        <align>right</align>
                                </control>
                                <control type="label" id="100">
                                        <width>900</width>
                                        <height>35</height>
                                        <align>right</align>
                                        <aligny>top</aligny>
                                        <font>Font-Sublabel</font>
                                        <textcolor>SubLabel2</textcolor>
                                </control>

                        </control>
                        <control type="group">
                                <posx>20</posx>
                                <posy>920</posy>
                                <animation effect="fade" start="80" end="80" time="0" condition="true">Conditional</animation>
                                <visible>Player.HasAudio + StringCompare(Window.Property(SlideView.Music),show)</visible>
                                <control type="image">
                                        <posx>0</posx>
                                        <posy>0</posy>
                                        <width>140</width>
                                        <height>140</height>
                                        <texture fallback="DefaultAlbumCover.png">$INFO[MusicPlayer.Cover]</texture>
                                        <aspectratio>scale</aspectratio>
                                </control>
                                <control type="grouplist">
                                        <posx>160</posx>
                                        <posy>0</posy>
                                        <height>140</height>
                                        <orientation>vertical</orientation>
                                        <itemgap>0</itemgap>
                                        <control type="label">
                                                <width>900</width>
                                                <align>left</align>
                                                <aligny>top</aligny>
                                                <height>35</height>
                                                <font>Font-Sublabel</font>
                                                <label>$INFO[MusicPlayer.Title]</label>
                                                <textcolor>MainLabel2</textcolor>
                                        </control>                                      
                                        <control type="label">    
                                                  <width>900</width>
                                                  <align>left</align>
                                                  <font>Font-Sublabel</font>
                                                  <textcolor>Highlight</textcolor>
                                                  <height>35</height>
                                                  <label>$INFO[MusicPlayer.Artist]</label>
                                        </control>
                                        <control type="label">
                                                <width>900</width>
                                                  <align>left</align>
                                                  <aligny>top</aligny>
                                                  <font>Font-Sublabel</font>
                                                  <height>35</height>
                                                  <label>$INFO[MusicPlayer.Album]</label>
                                                  <textcolor>SubLabel2</textcolor>
                                        </control>
                                        <control type="label">
                                                      <width>900</width>
                                                      <height>35</height>
                                                      <font>Font-Sublabel</font>
                                                      <align>left</align>
                                                      <aligny>top</aligny>
                                                      <textcolor>SubLabel2</textcolor>
                                                      <label>$INFO[Player.Time(hh:mm:ss)]$INFO[Player.Duration(hh:mm:ss), / ,]</label>
                                        </control>      
                                 </control>
                        </control>
                </control>
                <control type="image">
                        <posx>409</posx>
                        <posy>129</posy>
                        <width>461</width>
                        <height>461</height>
                        <aspectratio>keep</aspectratio>
                        <fadetime>0</fadetime>
                        <texture>splash.png</texture>
                        <colordiffuse>$INFO[Window.Property(SlideView.Dim)]</colordiffuse>
                        <animation effect="rotate" end="-360" center="auto" time="7000" loop="true" reversible="false" condition="True">Conditional</animation>
                        <animation type="WindowOpen">
                                <effect type="fade" start="0" end="100" time="1000" delay="500"/>
                        </animation>
                        <animation type="Conditional" condition="StringCompare(Window.Property(SlideView.Splash),hide)">
                                <effect type="fade" start="100" end="0" time="500"/>
                        </animation>
                </control>
        </controls>
</window>
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #304
(2014-09-05 16:32)eisbaer128 Wrote:  I'm trying to skin the screensaver for my favorite skin (Eminence). It's my very first trial and I was able to adapt the positions, fonts..., but I'm not able to adapt the italic and bold style for the EXIF data as they are coded inside the script. Wouldn't it make sense to put this into the skin instead ? In addition the tags have some animation which I really coudn't figure out where this is coded ?


Any help appriciated

it's not possible to define bold/italic in the default skin (included with the addon).
addons don't have access to a Font.xml where where such things can be defined.

i'm not sure what animations you're referring to?

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
eisbaer128 Offline
Junior Member
Posts: 6
Joined: Dec 2010
Reputation: 0
Post: #305
The textbox id=101 (the photo tags). Scroll in from the bottom (in the Eminence skin). I couldn't figure out why as this is not specified in the definition of the textbox.
find quote
Rolfi Offline
Junior Member
Posts: 1
Joined: Mar 2011
Reputation: 0
Post: #306
Hi,

I just installed XBMC on a Raspberry PI couse I want to use it as a easy way to manage a slideshow. Everything works like expected, updates via network in one folder, startup and one minute screensaver is enough for me. So but one thing is bad, I don't get that crisp clear image I put in the folder.

Is there a way to display the picture in full quality?
find quote
richardb70 Offline
Junior Member
Posts: 14
Joined: Oct 2013
Reputation: 0
Post: #307
Hi,

Strange issue yesterday with my folks' Pi. I've installed OpenElec (latest stable version), all is well and I've got a working SMB link to their Windows 7 PC housing their photos. I can browse this link via the "Pictures" main menu, works a treat. Pi is wired to the router, the PC is wifi.

I installed the screensaver and pointed it to the same source. The only other thing I did was to disable the cache in the settings menu.

Whenever the screensaver kicks in, there is the large spinning circle which goes on forever. If you interrupt with a key, the spinning circle remains in the background, and eventually XBMC restarts.

Any suggestions?
find quote
Raytestrak Offline
Donor
Posts: 334
Joined: Sep 2011
Reputation: 3
Post: #308
(2014-09-08 17:40)richardb70 Wrote:  Hi,

Strange issue yesterday with my folks' Pi. I've installed OpenElec (latest stable version), all is well and I've got a working SMB link to their Windows 7 PC housing their photos. I can browse this link via the "Pictures" main menu, works a treat. Pi is wired to the router, the PC is wifi.

I installed the screensaver and pointed it to the same source. The only other thing I did was to disable the cache in the settings menu.

Whenever the screensaver kicks in, there is the large spinning circle which goes on forever. If you interrupt with a key, the spinning circle remains in the background, and eventually XBMC restarts.

Any suggestions?

That's what I have too. My guess is that for me it's the disks in the NAS that aren't ready yet. When I access my pictures from another client, it also takes quite some time to respond. Increasing the samba timeout didn't help. Accessing the pictures from xbmc directly works fine. Only weird thing in my setup is that the SMB share is mapped in my skin folder (otherwise xbmc will cache them). Cache in the screensaver is turned off as well. The network is fast enough and there are too many pictures to cache.

XBMCbuntu on an Intel NUC (DC3217IYE). Onkyo NR-717. Canton Movie CD-1000. LG 42LM760S

If it ain't broke: break it, fix it, repeat
find quote
Dark Hunter Offline
Junior Member
Posts: 2
Joined: Sep 2014
Reputation: 0
Post: #309
Hello. I am using this plugin for a while and I've got problem to do one thing :
I need to play both images and videos on TV screen in a shop and this plugin works perfectly for images, but now I need to mix videos with images. And it doesn't work. I searched the forum but didnt find a solution, could you help me? Is this even possible with this plugin or I need different solution?
I use remote folder to store files.
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #310
(2014-09-11 17:01)Dark Hunter Wrote:  Hello. I am using this plugin for a while and I've got problem to do one thing :
I need to play both images and videos on TV screen in a shop and this plugin works perfectly for images, but now I need to mix videos with images. And it doesn't work. I searched the forum but didnt find a solution, could you help me? Is this even possible with this plugin or I need different solution?
I use remote folder to store files.

nope, not possible with this addon.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Dark Hunter Offline
Junior Member
Posts: 2
Joined: Sep 2014
Reputation: 0
Post: #311
Ok, so any other solution you would suggest?
find quote
aktarus Offline
Junior Member
Posts: 2
Joined: Sep 2014
Reputation: 0
Post: #312
(2014-09-08 17:40)richardb70 Wrote:  Hi,

Strange issue yesterday with my folks' Pi. I've installed OpenElec (latest stable version), all is well and I've got a working SMB link to their Windows 7 PC housing their photos. I can browse this link via the "Pictures" main menu, works a treat. Pi is wired to the router, the PC is wifi.

I installed the screensaver and pointed it to the same source. The only other thing I did was to disable the cache in the settings menu.

Whenever the screensaver kicks in, there is the large spinning circle which goes on forever. If you interrupt with a key, the spinning circle remains in the background, and eventually XBMC restarts.

Any suggestions?

I running the same issues Sad
Can someone can help us with it ??

MERCI Smile
find quote
ronie Offline
Team-Kodi Member
Posts: 9,198
Joined: Jan 2009
Reputation: 158
Post: #313
i can't, for the sole reason that i can not reproduce it Sad

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Post Reply