[Windows][Frodo] Choppy Video Playback

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
dukpep Offline
Junior Member
Posts: 3
Joined: Feb 2013
Reputation: 0
Post: #1
I hate to copy the thread that is immediately below this one, especially as my first post, but I'm ready to pull my eyes out. Sad

I'm getting ready to cut my cable cord and am looking to use XBMC as the media manager but need to make sure everything is going good. I was given a old slimline with a pentium 4 in it but had constant video lag that I gave up on because I thought it was the computer being so old. I decided to pull out my beastly computer and use it full time as I knew that it would be adequately powered however I'm getting the same issue in that 720p video files have an extremely unbearably lag. I'm going to say I've spent close to 10 hours researching the issue and so far I've not been able to solve it. Any advice would be much appreciated.

Firstly, I've followed http://forum.xbmc.org/showthread.php?tid=146911. to see if possibly it's an audio issue. I have a nvidia card that got through those steps pretty quickly, so I don't believe that is the problem.

1: Currently on public released Frodo
2: Windows 7 Pro Service pack 1 ( fully updated )
3: intel core 2 duo e8400 ( 64 bit processor. )
4: 8 gigs of ram
5: Nvidia GT 610 Version 310.90
6: Sound comes from mother board to video card
7: LG hd plasma TV.
8: Current public release of Frodo
9: Open a 720p movie ( I don't use 1080p so I'm not sure if it's there as well )
10: http://pastebin.com/Mc1F6Si7
find quote
DDDamian Offline
Team-XBMC Developer
Posts: 3,030
Joined: Sep 2011
Reputation: 254
Location: Canada
Post: #2
If you are going straight to the TV change your speaker settings from 7.1 > 2.0

System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
find quote
dukpep Offline
Junior Member
Posts: 3
Joined: Feb 2013
Reputation: 0
Post: #3
I have tried 2.0 as well.

Also, I wanted to add that I have a very basic set up as far as the hard ware goes. Listed above is it. No extra receiver or any fancy NAS set up. (multiple hard drives in the computer. XBMC on C drive and media on external hard drive )

Thanks again for the response. I'm sure that this forum gets tons of these every day.
(This post was last modified: 2013-02-01 05:38 by dukpep.)
find quote
jjd-uk Offline
Team-XBMC Member
Posts: 2,410
Joined: Oct 2011
Reputation: 51
Post: #4
Set Audio Output to Analog so XBMC decodes all audio before sending to the TV if you haven't done so already
find quote
bluray Offline
Posting Freak
Posts: 8,271
Joined: May 2011
Reputation: 144
Post: #5
(2013-02-01 05:35)dukpep Wrote:  I have tried 2.0 as well.

Also, I wanted to add that I have a very basic set up as far as the hard ware goes. Listed above is it. No extra receiver or any fancy NAS set up. (multiple hard drives in the computer. XBMC on C drive and media on external hard drive )

Thanks again for the response. I'm sure that this forum gets tons of these every day.
Since you are using Nvidia discret GPU, you might want to enable DXVA2 and select Auto Detect as render method. Make sure to go through audio output settings again, and you can find other tips in here- Simplify XBMC configurations......

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
dukpep Offline
Junior Member
Posts: 3
Joined: Feb 2013
Reputation: 0
Post: #6
I have tried that link again, bluray and same thing.

Two questions, is there away to completely disable audio so that I can verify that the video is no longer lagging with it off? To verify it's the audio that's giving me issues?

One thing that is different than most screen shots I've seen is encoded formats for my audio settings. Below is a screenshot for my (it shows it's using the nvidia drivers) It seems strange to have no supported formats, but I can't find anything on google about this.

http://i45.tinypic.com/2md5ce9.jpg

Thanks again.
find quote
jjd-uk Offline
Team-XBMC Member
Posts: 2,410
Joined: Oct 2011
Reputation: 51
Post: #7
That's because you're connected directly to a TV that only accepts LPCM 2.0 so you must set Audio Output to Analog and Speaker Configuration to 2.0
find quote
aleex Offline
Junior Member
Posts: 1
Joined: Feb 2013
Reputation: 0
Post: #8
Not sure if it will help any, but i had choppy playback as well.. i disabled the "Output all stereo to all speakers" setting, and all video plays back fine for me now
find quote
bluray Offline
Posting Freak
Posts: 8,271
Joined: May 2011
Reputation: 144
Post: #9
(2013-02-03 04:40)dukpep Wrote:  One thing that is different than most screen shots I've seen is encoded formats for my audio settings. Below is a screenshot for my (it shows it's using the nvidia drivers) It seems strange to have no supported formats, but I can't find anything on google about this.

http://i45.tinypic.com/2md5ce9.jpg

Thanks again.
You're falling into this configuration- Intel/Nvidia/AMD to LEDTV via 3.5mm jack.....

>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
find quote
steve.rand Offline
Junior Member
Posts: 23
Joined: Sep 2012
Reputation: 0
Post: #10
Ah! This has fixed my problem i've been googling for since I updated. Only affected movs and some mkvs, which might have some audio track in common.

I use an amp to pass through sound via optical. When I updated it seemed to be set correctly (after a bunch of other stuff seemed to change on its own.).

When I read the analog suggestion I thought i'd double check the SPDIF setting. Turns out there are now FOUR options instead of two. SPDIF and HDMI in both directsound and WASAPI or whatever it was called. Changing it from WSAPI to directsound fixed the problem!
find quote