HOW-TO synchronize XBMC between every room in the house: Wiki Edition

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Ned Scott Offline
Team-XBMC Wiki Guy
Posts: 18,257
Joined: Jan 2011
Reputation: 220
Location: Arizona, USA
Post: #211
Quote:and created xbmc_video and xbmc_music databases

That's the problem. Go back and follow the wiki's instructions. Do not manually create any databases. Make sure to drop the existing MySQL DBs so that XBMC can create fresh DBs for you.

You can make easy links to the XBMC wiki using double brackets around words: [[debug log]] = debug log, [[Add-on:YouTube]] = Add-on:YouTube, [[Adding videos to the library]] = Adding videos to the library, [[userdata]] = userdata, etc
find quote
MilhouseVH Online
Posting Freak
Posts: 3,012
Joined: Jan 2011
Reputation: 71
Post: #212
Code:
CREATE USER 'xbmc' IDENTIFIED BY 'xbmc';
CREATE database xbmc_video;
CREATE database xbmc_music;
GRANT ALL ON *.* TO 'xbmc';

Why are you creating the databases - the Wiki doesn't say you should be doing this. Just leave the job of database creation to XBMC. Hardly surprising you've got a problem when you go off piste. Also naming the video (with the <name> tag in advancedsettings.xml) usually causes more problems - do you really need to use a custom name prefix? If not, don't.

Also turn on debug log and check xbmc.log for errors, or upload the log on pastebin.com or xbmclogs.com if you still can't spot the problem.

Edit: Ned beat me to it - that'll teach me to leave a post open for an hour before hitting reply... Smile

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2014-03-27 03:36 by MilhouseVH.)
find quote
duncang92 Offline
Junior Member
Posts: 8
Joined: Apr 2007
Reputation: 0
Post: #213
All sorted ...... as you say no need to create the databases AND especially don't use the name variable in advancedsettings.xml - the databases in mysql are redundant and I may delete them one day to keep things tidy.

One XBMC instance is now scanning my tv database ...... once it has finished then I can do the same for movies. The original databases were due for a good cleanup and so starting again will be good.

I know there will be tweaking to do afterwards but that can wait and since I've now read all of the posts in this forum I am sure that you have all run into any issues I may find.

Now I can go to the pub and enjoy a nice pint to celebrate.

Cheers, Duncan
find quote
salar521 Offline
Junior Member
Posts: 1
Joined: Apr 2014
Reputation: 0
Post: #214
Thank you so much for taking the time to do this, I'm sure it'll greatly benefit the community.
find quote
jonatan Offline
Member
Posts: 79
Joined: Jan 2013
Reputation: 0
Post: #215
I need help
I got mysql sever running on synology nas 3 clients (2 windows 7 and ouya) i got them all connected to database the all working well except my 2nd instance of windows 7 my 2nd client when i go into tv show it shows poster.jpg but when i go into seasons no poster and then when i go into each season i got no fanart or thumbnails my other 2 clients display all art just not one windows 7 machine
All features work
Update libary
Watched flag
Resume
Just no tv show art on 2nd instance w7

Update
I scraped my tv collection with emm and all is working thanks anyways

[Image: xbmcmediacenter.jpg][Image: xbmcmediacenter1.jpg]
intel G530/BIostar th67+/Cx430/2x4gb ripjaws x 1600/N mediapc 1000B case/N media lcd/Asus gt520/60gb adata ssd.os/2tb spinpoint 5400 rpm. Media/Hp dvd rw
(This post was last modified: 2014-04-02 14:04 by jonatan.)
find quote
Post Reply