BUG - [RPi] XBMC restarts when starting LiveTV or Radio

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
doveman2 Offline
Posting Freak
Posts: 834
Joined: Nov 2012
Reputation: 2
Post: #1
Testing on OpenElec Testbuild http://forum.xbmc.org/showthread.php?tid...pid1349277 whenever I select a TV or Radio channel, I see it start Timeshifting on my PC in TV Server config but after about 10s of saying "Working" XBMC just restarts. I can play a Recorded TV programme fine, so it doesn't appear to be a GPU/codec issue.

This is the log from trying to start Live Radio:

Code:
15:32:19 T:3043086336  NOTICE: COMXPlayer: Opening: pvr://channels/radio/All radio channels/1.pvr
15:32:19 T:3043086336   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.clock handle 0x04145260 dllopen : 1
15:32:19 T:3043086336   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.clock input port 80 output port 81
15:32:20 T:3043086336   DEBUG: CRenderManager::UpdateDisplayLatency - Latency set to 0 msec
15:32:20 T:3043086336   DEBUG: LinuxRendererGL: Cleaning up GL resources
15:32:20 T:3043086336   DEBUG: DllSwScale: Using libswscale system library
15:32:20 T:2823005280  NOTICE: Thread COMXPlayer start, auto delete: false
15:32:20 T:2823005280  NOTICE: Creating InputStream
15:32:20 T:2823005280   DEBUG: PVRManager - OpenLiveStream - opening live stream on channel 'BBC Radio 1'
15:32:20 T:2823005280   DEBUG: opening live stream for channel 'BBC Radio 1'
15:32:20 T:2823005280   DEBUG: AddOnLog: MediaPortal PVR Client: ->OpenLiveStream(uid=35)
15:32:20 T:3043086336   DEBUG: ------ Window Init (DialogBusy.xml) ------
15:32:20 T:3043086336   DEBUG: LIRC: Update - NEW at 622385:160 0 KEY_OK_UP devinput (KEY_OK_UP)
15:32:21 T:2823005280    INFO: AddOnLog: MediaPortal PVR Client: Channel stream URL: rtsp://192.168.2.1/stream6.0, timeshift buffer: R:\\live6-0.ts.tsbuffer
15:32:21 T:2823005280    INFO: AddOnLog: MediaPortal PVR Client: Creating a new TsReader...
15:32:21 T:2823005280  NOTICE: AddOnLog: MediaPortal PVR Client: CTsReader::Open(R:\\live6-0.ts.tsbuffer)
15:32:21 T:2823005280   DEBUG: AddOnLog: MediaPortal PVR Client: Multiseat mode; need to translate 'R:\\live6-0.ts.tsbuffer' to UNC filename.
15:32:21 T:2823005280    INFO: AddOnLog: MediaPortal PVR Client: CTsReader:TranslatePath R:\\live6-0.ts.tsbuffer -> smb://x:x@X4/R/live6-0.ts.tsbuffer
15:32:21 T:2823005280   DEBUG: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() Trying to open smb://x:x@X4/R/live6-0.ts.tsbuffer
15:32:21 T:2823005280    INFO: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() smb://x:x@X4/R/live6-0.ts.tsbuffer.
15:32:21 T:2823005280   DEBUG: CSmbFile::Open - opened R/live6-0.ts.tsbuffer, fd=10000
15:32:21 T:2823005280   DEBUG: AddOnLog: MediaPortal PVR Client: OpenFile: OpenFile(smb://x:x@X4/R/live6-0.ts.tsbuffer) succeeded.
15:32:21 T:2823005280   DEBUG: AddOnLog: MediaPortal PVR Client: MultiFileReader: buffer file opened return code 0.
15:32:21 T:2823005280   DEBUG: CSmbFile::Open - opened R/live6-0.ts.tsbuffer1.ts, fd=10001
15:32:21 T:2823005280   DEBUG: CSmbFile::Close closing fd 10001

and this is from watching a recording:

Code:
15:36:48 T:3042963456   DEBUG: ------ Window Init (MyPVR.xml) ------
15:36:48 T:3042963456    INFO: Loading skin file: MyPVR.xml, load type: LOAD_EVERY_TIME
15:36:48 T:3042963456   DEBUG: Using already stored xml root node for /usr/share/xbmc/addons/skin.confluence/720p/MyPVR.xml
15:36:49 T:3042963456   DEBUG: CGUIMediaWindow::GetDirectory (pvr://recordings/Channel 4 - Secret State/)
15:36:49 T:3042963456   DEBUG:   ParentPath = [pvr://recordings/Channel 4 - Secret State/]
15:36:49 T:3042963456   DEBUG: CPVRDirectory::GetDirectory(pvr://recordings/Channel 4 - Secret State)
15:36:49 T:3042963456   DEBUG: CGUIWindowPVRCommon - OnMessageFocus - focus set to window 'recordings'
15:36:49 T:3042963456   DEBUG: CGUIWindowPVRRecordings - UpdateData - update window 'recordings'. set view to 13
15:36:49 T:3042963456   DEBUG: CGUIMediaWindow::GetDirectory (pvr://recordings/Channel 4 - Secret State/)
15:36:49 T:3042963456   DEBUG:   ParentPath = [pvr://recordings/Channel 4 - Secret State/]
15:36:49 T:2977776736   DEBUG: CPVRDirectory::GetDirectory(pvr://recordings/Channel 4 - Secret State)
15:36:49 T:2847929440  NOTICE: Thread Background Loader start, auto delete: false
15:36:49 T:3042963456   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.image_decode handle 0x0299fbb0 dllopen : 1
15:36:49 T:3042963456   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.image_decode input port 320 output port 321
15:36:49 T:3042963456   DEBUG: COMXCoreComponent::Initialize : OMX.broadcom.resize handle 0x02a00748 dllopen : 1
15:36:49 T:3042963456   DEBUG: COMXCoreComponent::Initialize OMX.broadcom.resize input port 60 output port 61
15:36:49 T:3042963456   DEBUG: COMXCoreComponent::AllocInputBuffers component(OMX.broadcom.image_decode) - port(320), nBufferCountMin(2), nBufferCountActual(3), nBufferSize(81920), nBufferAlignmen(16)
15:36:49 T:3042963456   DEBUG: COMXCoreComponent::AllocOutputBuffers component(OMX.broadcom.resize) - port(61), nBufferCountMin(1), nBufferCountActual(1), nBufferSize(3686400) nBufferAlignmen(16)
15:36:49 T:2847929440   DEBUG: Thread Background Loader 2847929440 terminating
15:36:49 T:3042963456   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.resize handle 0x02a00748 dllopen : 1
15:36:49 T:3042963456   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.image_decode handle 0x0299fbb0 dllopen : 1
15:36:50 T:3042963456   DEBUG: COMXPlayer::CloseFile
15:36:50 T:3042963456   DEBUG: COMXPlayer: waiting for threads to exit
15:36:50 T:3042963456   DEBUG: COMXPlayer: finished waiting
15:36:50 T:3042963456   DEBUG: LinuxRendererGL: Cleaning up GL resources
15:36:50 T:3042963456   DEBUG: OMXClock::OMXStop
15:36:50 T:3042963456  NOTICE: OMXClock using video as reference
15:36:50 T:3042963456   DEBUG: OMXClock::OMXReset audio / video : 0 / 0 start audio / video : 0 / 0 wait mask 0
15:36:50 T:3042963456   DEBUG: OMXClock::OMXStop
15:36:50 T:3042963456  NOTICE: OMXClock using video as reference
15:36:50 T:3042963456   DEBUG: OMXClock::OMXReset audio / video : 0 / 0 start audio / video : 0 / 0 wait mask 0
15:36:50 T:3042963456   DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.clock handle 0x02a60aa8 dllopen : 1
15:36:50 T:2977776736   DEBUG: DoWork - Saving file state for video item pvr://recordings/Channel 4 - Secret State/Secret State, TV (69), 20121128_215800.pvr
15:36:50 T:3042963456   DEBUG: LIRC: Update - NEW at 267157:80 0 KEY_STOP_UP devinput (KEY_STOP_UP)
15:36:50 T:2977776736   DEBUG: Mysql execute: insert into path (idPath, strPath, strContent, strScraper) values (NULL,'pvr://recordings/Channel 4 - Secret State/','','')
15:36:50 T:2977776736   DEBUG: Mysql execute: insert into files (idFile, idPath, strFileName) values(NULL, 59, 'Secret State, TV (69), 20121128_215800.pvr')
15:36:50 T:2977776736   DEBUG: Mysql execute: update files set playCount=NULL,lastPlayed='2013-02-27 15:36:50' where idFile=140
15:36:50 T:3042963456   DEBUG: LIRC: Update - NEW at 267203:80 0 KEY_STOP devinput (KEY_STOP)
15:36:50 T:3042963456   DEBUG: OnKey: 224 (e0) pressed, action is Stop
15:36:50 T:3042963456   DEBUG: LIRC: Update - NEW at 267231:80 0 KEY_STOP_UP devinput (KEY_STOP_UP)

This is my current advancedsettings.xml:

<advancedsettings>
<cputempcommand>cputemp</cputempcommand>
<gputempcommand>cputemp</gputempcommand>
<showexitbutton>false</showexitbutton>
<destroywindowcontrols>false</destroywindowcontrols>
<useddsfanart>false</useddsfanart>
<fanartheight>540</fanartheight>
<thumbsize>256</thumbsize>
<network>
<alwaysforcebuffer>false</alwaysforcebuffer>
<freememorycachepercent>5</freememorycachepercent>
</network>
<gui>
<algorithmdirtyregions>3</algorithmdirtyregions>
<nofliptimeout>0</nofliptimeout>
<guires>720</guires>
</gui>
<video>
<defaultplayer>omxplayer</defaultplayer>
<defaultdvdplayer>omxplayer</defaultdvdplayer>
</video>
<audio>
<defaultplayer>omxplayer</defaultplayer>
<streamsilence>false</streamsilence>
</audio>
<lookandfeel>
<enablerssfeeds>false</enablerssfeeds>
</lookandfeel>
<bginfoloadermaxthreads>2</bginfoloadermaxthreads>
<videodatabase>
<type>mysql</type>
<host>192.168.1.64</host>
<port>3306</port>
<user>root</user>
<pass>MediaPortal</pass>
</videodatabase>
<musicdatabase>
<type>mysql</type>
<host>192.168.1.64</host>
<port>3306</port>
<user>root</user>
<pass>MediaPortal</pass>
</musicdatabase>
<videolibrary>
<importwatchedstate>true</importwatchedstate>
</videolibrary>
</advancedsettings>
find quote
doveman2 Offline
Posting Freak
Posts: 834
Joined: Nov 2012
Reputation: 2
Post: #2
I've just tested with Raspbmc and LiveTV is working OK on that, so I guess it's something about OpenElec that's wrong.
find quote
doveman2 Offline
Posting Freak
Posts: 834
Joined: Nov 2012
Reputation: 2
Post: #3
Well it was working on Raspbmc and then it started causing the RPi to reboot, so any ideas anyone?
find quote
jeffbrown1966 Offline
Junior Member
Posts: 3
Joined: Aug 2013
Reputation: 0
Post: #4
Did you ever fix this, I just installed openelec and it does the same thing .
find quote
doveman2 Offline
Posting Freak
Posts: 834
Joined: Nov 2012
Reputation: 2
Post: #5
I gave up on using the tuner with XBMC I'm afraid.
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #6
No idea what is happening without log files (which will be difficult to obtain due to the reboot).
I'm using the Milhouse OpenElec builds on my RPi and it is working just fine.
Note that a possible cause for a reboot on an overclocked RPi could be a voltage drop on the 5V (that is what I had before with a cheap an too thin micro-USB cable.

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote