Solved Issue - [Debug log included] XBMCbuntu 12.10 Can't Play Movies

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
somidscr21 Offline
Junior Member
Posts: 23
Joined: Feb 2013
Reputation: 0
Post: #1
I am having a very strange issue. I have just installed XBMCbuntu on a Foxconn NTA350-0H0W-B-A-NA, and from there I have added tv shows from my NFS file server as well as movies. I can play the tv shows just fine (I am connecting over wireless using an Alfa AWUS036H), but the movies give me strange problems. Some of them won't even play, while some of them start playing, however, the audio doesn't work. There's sound but it's horribly stuttered to the point of being indecipherable (not quite static, but not quite actual audio).

Here is my xbmc.log with debugging turned on. It shows me first playing a tv episode (IT Crowd), then trying a movie that fails with the bad audio (Wreck It Ralph), then a movie (Zero Dark Thirty) that just won't even play.

http://xbmclogs.com/show.php?id=15029
(This post was last modified: 2013-05-02 03:29 by somidscr21.)
find quote
wsnipex Online
Team-XBMC packaging monkey
Posts: 3,481
Joined: Jun 2011
Reputation: 84
Post: #2
http://forum.xbmc.org/showthread.php?t=116996
find quote
somidscr21 Offline
Junior Member
Posts: 23
Joined: Feb 2013
Reputation: 0
Post: #3
(2013-04-30 09:39)wsnipex Wrote:  http://forum.xbmc.org/showthread.php?t=116996

I'm sorry I've seen that page, but my understanding of it is that the drrivers from amd won't work for me. Am I incorrect? Or was that what you were pointing out to me? If so, does anyone know where I can get XBMCbuntu 12.04? I tried to find it and couldn't.
find quote
somidscr21 Offline
Junior Member
Posts: 23
Joined: Feb 2013
Reputation: 0
Post: #4
wsnipex

I basically restarted and walked through that thread of yours. After doing that, things seemed to work as I was able to start watching a movie. I had to reboot though, as my overscan needed fixing. After that, things stopped working again.

I'm running from your xvba git
Code:
root@livingroom:~# apt-cache policy xbmc
xbmc:
  Installed: 2:12.1~git20130319.1943-frodo-0quantal
  Candidate: 2:12.1~git20130319.1943-frodo-0quantal
  Version table:
*** 2:12.1~git20130319.1943-frodo-0quantal 0
        500 http://ppa.launchpad.net/wsnipex/xbmc-xvba-frodo/ubuntu/ quantal/main i386 Packages
        100 /var/lib/dpkg/status
     2:11.0~git20120510.82388d5-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ quantal/universe i386 Packages

My fglrx driver:
Code:
root@livingroom:~# apt-cache policy fglrx
fglrx:
  Installed: 2:9.000-0ubuntu3
  Candidate: 2:9.000-0ubuntu3
  Version table:
*** 2:9.000-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ quantal/restricted i386 Packages
        100 /var/lib/dpkg/status

Vsync is set to always on.
AMD Tearfree is off.
DTS-HD is off as is True-HD, with LPCM on for audio over HDMI.

Video Ram:
Code:
root@livingroom:~# grep -i fglrx /var/log/Xorg.0.log | grep -i kb
[   127.203] (II) fglrx(0): VESA VBE Total Mem: 16384 kB
[   127.203] (--) fglrx(0): Video RAM: 393216 kByte, Type: DDR3

System->Settings->System->Video Settings:
Vertical blank sync: Always enabled

System ->Video->Playback:
XVBA: On (the only of the hardware accelerations on)
Adjust Refreshrate to match video: Always
Sync playback to display: on
A/V sync method: Video Clock (Drop/Dupe)

Movie file info:
Code:
root@livingroom:~# mediainfo /movies/Zero\ Dark\ Thirty\ \(2012\).m4v
General
Complete name                            : /movies/Zero Dark Thirty (2012).m4v
Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42
File size                                : 1.51 GiB
Duration                                 : 2h 36mn
Overall bit rate mode                    : Variable
Overall bit rate                         : 1 375 Kbps
Encoded date                             : UTC 2013-04-17 21:27:27
Tagged date                              : UTC 2013-04-17 21:57:16
Writing application                      : HandBrake 0.9.8 2012071700

Debug.log: http://xbmclogs.com/show.php?id=15177

One thought I had was that maybe it is my network being too slow? Not sure if that would actually cause this, but I noticed that my bandwidth on the xbmc machine is:
Code:
[  5] local 192.168.1.7 port 5001 connected with 192.168.1.16 port 48399
[  5]  0.0-11.1 sec  2.25 MBytes  1.70 Mbits/sec

While my laptop sitting a foot away showed this from iperf:
Code:
[  4] local 192.168.1.7 port 5001 connected with 192.168.1.28 port 50707
[  4]  0.0-10.0 sec  59.5 MBytes  49.8 Mbits/sec

Any help would be great. Thanks.
find quote
nickr Online
Donor
Posts: 7,409
Joined: May 2009
Reputation: 126
Location: Christchurch NZ
Post: #5
(2013-05-01 01:27)somidscr21 Wrote:  One thought I had was that maybe it is my network being too slow? Not sure if that would actually cause this, but I noticed that my bandwidth on the xbmc machine is:
Code:
[  5] local 192.168.1.7 port 5001 connected with 192.168.1.16 port 48399
[  5]  0.0-11.1 sec  2.25 MBytes  1.70 Mbits/sec

While my laptop sitting a foot away showed this from iperf:
Code:
[  4] local 192.168.1.7 port 5001 connected with 192.168.1.28 port 50707
[  4]  0.0-10.0 sec  59.5 MBytes  49.8 Mbits/sec

Any help would be great. Thanks.

That could very well be the problem. Run a wire to test. Or transfer a file to the client and try playing it locally?

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,444
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #6
Quote:DTS-HD is off as is True-HD, with LPCM on for audio over HDMI.

Also disable LPCM, if you have set more than 2.0 speakers. In short: fglrx on linux can only do 5.1 when played pseudo formats. Therefore only enable DTS (if your receiver can do it), AC3 (if your receiver can do it) and Boost Volume on downmix. If you AVR cannot do AC3, set the speaker numbers to 2.0.
find quote
wsnipex Online
Team-XBMC packaging monkey
Posts: 3,481
Joined: Jun 2011
Reputation: 84
Post: #7
and the file you are trying to play cannot be hardware decoded. Only h264 and VC-1 are currently supported
find quote
somidscr21 Offline
Junior Member
Posts: 23
Joined: Feb 2013
Reputation: 0
Post: #8
nirckr: When I was setting up the machine I had it in the same room as the AP and I was seeing speeds of about 40-50 Mbits/sec. Unfortunately, I can't run wires otherwise I definitely would have done so already. Maybe I'll try some powerline adapters. I hear they are pretty hit or miss, but they really can't be all that much worse right?

fritsch: I will disable LPCM and enable DTS/AC3 (mine is capable of both) and Boost volume on downmix. Thanks.

wsnipex: Are you saying based on the info I gave that this file will not be able to be hardware decoded or are you just reminding me in general? Sorry for my ignorance, I don't know how to tell that.

What I do know though is that I have about a 75% success rate playing movies now after doing all of this. Even with the same file. Makes it definitely sound like network issues to me, though I'm the one on here looking for help...

By the sound of it, they may be working intermittently, but not hardware decoded, is that right wsnipex?
find quote
wsnipex Online
Team-XBMC packaging monkey
Posts: 3,481
Joined: Jun 2011
Reputation: 84
Post: #9
this one cannot be hardware accelerated:

Complete name : /movies/Zero Dark Thirty (2012).m4v
Format : MPEG-4
Format profile : Base Media / Version 2

If you look at mediainfo of h264, it will either say h264, AVC or mpeg-4 Version 10. Those(+VC-1) can be hardware decoded on AMD.

So yes, it sounds like your problem is one of:
1.) wrong Audio setup
2.) network issues

copy one of the problematic files over to the local hard disk and play from there. If it still does not play pastebin another debug log.
find quote
nickr Online
Donor
Posts: 7,409
Joined: May 2009
Reputation: 126
Location: Christchurch NZ
Post: #10
powerline is way better than wireless unless your power wiring is incompatible.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
somidscr21 Offline
Junior Member
Posts: 23
Joined: Feb 2013
Reputation: 0
Post: #11
wsnipex: I sincerely thank you for taking the time to explain. I would always prefer to be taught to fish vs given a fish.

nickr: I got some powerline adapters in and while they don't quite make their rated speed, they are giving me 47Mbit/sec on a few attempts. Now movies all play perfectly fine (well from watching the first 5 minutes of a couple anyways...).

I appreciate the help everyone. I'll mark this as solved.
find quote
nickr Online
Donor
Posts: 7,409
Joined: May 2009
Reputation: 126
Location: Christchurch NZ
Post: #12
(2013-05-02 03:28)somidscr21 Wrote:  wsnipex: I sincerely thank you for taking the time to explain. I would always prefer to be taught to fish vs given a fish.
Light a man a fire and he is warm for a day. Set the man on fire and he is warm for the rest of his life Smile

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote