Linux - vaapi-sse4: Deinterlacing Testing

  Thread Rating:
  • 12 Votes - 4.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Morrtin Offline
Member
Posts: 67
Joined: Jul 2011
Reputation: 0
Location: Vienna
Post: #16
Finished installation.

Without (fake) De-interlace I see lines - Especially when the text moves from right to left.
With (fake) De-interlace I looks good - Moving text can be read. But when I move closer to TV I think I see the effects you mentioned.

Here is my log: http://paste.ubuntu.com/5703684/

BTW: I thought RC6 is disabled by default in Linux kernel 3.0+ (read it somewhere in the Internet)?

Edit: I think I know what you gonna tell me. :-)
Line: ERROR: VAAPI - unable to initialize display -1 - unknown libva error says it all, or?

Off Topic:
1) Is linux-firmware_1.108_all.deb not the actual one?
2) How can I check if I also could have a colorspace issues?
(This post was last modified: 2013-05-26 16:46 by Morrtin.)
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,477
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #17
@Morrtin: Can you join #xbmc-xvba?

Your error message tells, that you missed a package to install.

@Frank-NL:
See the very first post. I linked to the OE testing thread. This version includes Frodo.
find quote
wsnipex Offline
Team-XBMC packaging monkey
Posts: 3,505
Joined: Jun 2011
Reputation: 84
Post: #18
Morrtin, as you already assumed, your vaapi install is somehow broken. Maybe you need to upgrade libva-glx1 as well.
Can you run "sudo apt-get upgrade" and try again?

If it still fails:
dpkg -l libva* | pastebinit
apt-cache policy xbmc | pastebinit
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #19
After updating to 3.9.4 (downloaded the dvb headers for this kernel) it is working even better.

No dark picture so that's fixed.

It seems nVidia also had a 59.94 refresh rate, now I only have 50 and 60. Is that going to be a problem? Switching refresh rates is still slow (3-4 secs), it used to be instant. Any hints or tips?

Will the vaapi branch be separate or is it going to be included in the frodo stable branch?

It looks like I will have a GT610 for sale... For now I am quite satisfied with BOB :D
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #20
(2013-05-26 17:09)fritsch Wrote:  @Frank-NL:
See the very first post. I linked to the OE testing thread. This version includes Frodo.

-edit- Read the whole thread on OE forum, very nice that it's Frodo, now I can finally switch to OE Smile
(This post was last modified: 2013-05-26 18:11 by Frank-NL.)
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,477
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #21
@Frank-NL:
Switching refreshrates also depends on the TV, that is connected. If you watch 50i content all the time, just set your Refreshrate to 50hz (System -> Settings -> Video Hardware)

There are also xorg.conf files for intel (make sure HDMI1 matches yours, if not - change it), e.g.
Code:
Section "Device"
  Identifier  "Device0"
  Driver      "intel"
  VendorName  "INTEL Corporation"
  # a user reported, that this could cause high jumping fps in the menus when running on Ubuntu Raring
  # in that case set it to "uxa" instead
  Option "AccelMethod" "sna"
EndSection

Section "Screen"
  Identifier  "Screen0"
  Device      "Device0"
  Monitor     "HDMI1"
  DefaultDepth  24
  SubSection "Display"
    Depth       24
    Modes     "1920x1080@50p" "1920x1080@59.94p" "1920x1080@23.97" "1920x1080@24p" "1920x1080@60p"
  EndSubSection
EndSection

Section "Monitor"
  Identifier  "HDMI1"
  HorizSync   14.0 - 70.0
  VertRefresh 24.0 - 62.0
  Option      "DPMS" "true"
  # you might have to tune the 23.97 modeline it is a bit of trail and run
  ModeLine         "1920x1080@23.97" 74.175 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
  ModeLine         "1920x1080@24p" 74.400 1920 2558 2602 2758 1080 1084 1089 1124 +hsync +vsync #INTEL
  ModeLine          "1920x1080@50p"    148.500 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
  ModeLine          "1920x1080@59.94p" 148.352 1920 1960 2016 2200 1080 1082 1088 1125 +hsync +vsync
  ModeLine          "1920x1080@60p"    148.500 1920 2008 2056 2200 1080 1084 1089 1125 +hsync +vsync
EndSection

Section "Extensions"
  # fixes tearing
  Option      "Composite"           "Disable"
EndSection

The fractual modes won't work on 12.04.02, cause of xorg I think -> black screen.
(This post was last modified: 2013-08-11 19:09 by fritsch.)
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #22
Thanks. It's not the tv since the nVidia driver did it a lot faster and did not cause HDMI to appear on the TV. So it looks like intel does a more thorough reset of the HDMI connection which takes more time and causes the TV to init again.

I'm going to try if your OE build makes any difference when I have more spare time.

Currently watching 1080i and still working like a charm! Whoohoo.
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,477
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #23
I think your nvidia just did not switch ;-) cause you had "Adjust Refreshrate to match video" not enabled - if TV switches, it must appear.
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #24
No it switched before, I didn't touch the setting after enabling VAAPI. Anyway, minor issue.
find quote
Morrtin Offline
Member
Posts: 67
Joined: Jul 2011
Reputation: 0
Location: Vienna
Post: #25
After a nice session with fritsch and wsnipex I can report that vaapi is running on my system.

Good job guy's!

EDIT: Only the Setting System -> Settings -> System -> Video Hardware: Vertical Blank Sync: Always enabled. results in a little miss behaving.
DIM Screensaver is not dimming anymore. Solution / Workaround is to set it to "Enable on playback"
(This post was last modified: 2013-05-27 12:06 by Morrtin.)
find quote
Morrtin Offline
Member
Posts: 67
Joined: Jul 2011
Reputation: 0
Location: Vienna
Post: #26
Me again.

Today I did a complete new installation of Ubuntu Server 13.04. Upgraded to kernel 3.9.4 (including firmware 1.108) and applying RC6 fix. Before installing XBMC with my script I added packages " libva-intel-vaapi-driver libva1 vainfo libva-glx1 " and VAAPI PPA to it.

Installation script run smooth and I got my XBMC immediately. I checked my script log and saw that package libva-intel-vaapi-driver was installed but no info about "libva1 vainfo libva-glx1" (there are in a separate if statement). So I checked them manually. And saw that "libva1 libva-glx1" where up to date but vainfo was not installed.

My conclusion: "Something" (operation system 13.04, kernel, Intel driver) is already installing these packages to the newest version. Just for information because to be on the save side these packages should be installed or at least checked.

Testing De-interlace resulted in a perfect working video material.

The issue with not working screen saver (DIM) persists. I noticed that XBMC activates the screen saver because I need one keystroke to "wake it" up and then I can choose a menu point. Only the screen doesn't get dimmed. Workaround: System -> Settings -> System -> Video Output -> Vertical Blank Sync: Enabled during video playback still works.

Here are my pastebinit's:
dmesg: http://paste.ubuntu.com/5708202/
xbmc log: http://paste.ubuntu.com/5708204/
libva: http://paste.ubuntu.com/5708207/
vaapi: http://paste.ubuntu.com/5708209/
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,477
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #27
If you add the ppa prior to installing the packages, it is quite clear that these packages get installed uptodate. Btw. libva1 and libva-glx1 are dependencies of libva-intel-vaapi-driver. The should be installed when just specifiing the vaapi-driver. I only added them, cause someone told, that they would not be installed - just to be on the safe side. vainfo is no dependency of these packages - it is also not needed. But I need it, when I want to find bugs. So that i can easily check if vaapi is working.

The bug with the screensaver I noted. It is also a upstream bug.

Oki, thanks again for testing and now have a nice time with your setup :-)
find quote
Marx1 Offline
Fan
Posts: 303
Joined: Jan 2011
Reputation: 3
Post: #28
Is there any chance this feature will be part of official next frodo update?
find quote
wsnipex Offline
Team-XBMC packaging monkey
Posts: 3,505
Joined: Jun 2011
Reputation: 84
Post: #29
no, new features never get into bugfix releases.
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #30
Yesterday I updated from Quantal to Raring. Still working, except the frame rate in the GUI goes crazy with v-sync always on. It stutters a lot, going from 50 to 150 fps (the RSS ticker looks funny).

If I disable it (or set it to only during playback) the GUI frame rate is still way too high (100 - 150 fps) but there is no stutter in the GUI and video plays fine, exactly the matching frame rate.

What logs do I need to provide so you can have a look? (assuming you want that Smile)
find quote
Post Reply