Linux - vaapi-sse4: Deinterlacing Testing

  Thread Rating:
  • 12 Votes - 4.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
fritsch Offline
Team-XBMC Developer
Posts: 5,460
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #31
Start with a normal logfile and debugging turned on. That should be a Raring bug with the intel driver - i doubt I can do something about it.
find quote
George Offline
Senior Member
Posts: 128
Joined: Feb 2010
Reputation: 2
Location: The Netherlands
Post: #32
Very nice work!

Just updated my Ubuntu Raring installation after removing the installed Frodo packages. I don't like watching tennis but I just watched some livetv and it looked amazing. Running on a i3-3225 processor by the way, no problems in the mainmenu with strange FPS.
(This post was last modified: 2013-05-30 17:21 by George.)
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #33
Ok some logs.

Loaded XBMC, switched to debug, opened Live TV 1080i @ 50 hz and after that switched to Game of Thrones @ 24p, forcing my display to 60hz (it doesn't do 24hz.)

http://xbmclogs.com/show.php?id=23319

Xrandr verbose output: http://pastebin.com/qrkizrDe

I don't use a xorg.conf.

I hope there's something interesting Smile
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,460
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #34
No - nothing.

That you don't need anymore I think.
Quote:<gputempcommand>echo &quot;$(nvidia-smi -q -d TEMPERATURE | grep Gpu | cut -c35-36) C&quot;</gputempcommand>

Try to set Vertical Blank Sync to "On Playback". Not sure what happens there, that log does not tell anything. Retry with Confluence Skin.
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #35
I noticed the nvidia-smi command too while reading the log Smile

Same with confluence: http://xbmclogs.com/show.php?id=23327
V-sync is set to on playback.

The interface reports 99.10 to 99.70 fps, jumping every second. Videos run with a stable 50 or 60 fps. Weird.

-edit- wrong log, fixed
(This post was last modified: 2013-05-30 20:09 by Frank-NL.)
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,460
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #36
When vsync is set to "on Playback" the normal interface is not bound to glxSwapBuffers, so I don't wonder that much - it is limited via the "great main loop" to do even more.

So basically you are saying: It does not matter if vsync is turned on / video playback - your fps jump to heaven? Do you use a special desktop environment?
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #37
Vsync only on playback: fps in the GUI way too high, during video stable as it should
Vsync always on: fps in the GUI way too high and stuttering heavily, during video stable
Vsync always off: fps in the GUI still too high, video is ok.

So it's rendering the GUI too high whatever setting I choose. Video is ok with vsync on or off.

I use xinit to start xbmc, so no I don't use a DE.
And the same Frodo install was OK on Quantal.
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,460
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #38
Nice :-) I have heard, that Raring makes bugs and is not what one could expect, but that sounds funny :-)
One last question, die you reenable the wsnipex ppa after the upgrade? and did apt-get update && apt-get upgrade? So that the packages got also tranfered to the raring packages?
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #39
Yes.

deb http://ppa.launchpad.net/wsnipex/vaapi/ubuntu raring main # disabled on upgrade to raring

I don't have the Frodo-stable ppa activated. Should be disabled, right?
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,460
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #40
All fine as is. perhaps you can contact @George, that has it working really nicely on Raring to see if there are obvious differences.

I cannot switch my machines to raring yet. I always have to witch the whole themepark to get the binaries running on those machines. I am still on Quantal.
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #41
George, did you do a clean install of Raring? I did an upgrade from Quantal. Maybe I'm going to try a fresh install, it's not that much work.

I use an i3-3220 which has 2500 graphics instead of 4000. Maybe that makes a difference, although again, it worked fine under Quantal.
find quote
soulchar Offline
Junior Member
Posts: 22
Joined: Jan 2011
Reputation: 1
Post: #42
Hi,
a while ago I found out that enabling Option "AccelMethod" "sna" in xorg.conf results in very high jumping framerates in the gui.
I'm on an Ivy HD4000.
Maybe you use a custom xorg.conf(from this thread) with this option enabled - so try again with disabling it.
find quote
fritsch Offline
Team-XBMC Developer
Posts: 5,460
Joined: Aug 2011
Reputation: 129
Location: Karlsruhe
Post: #43
@soulchar: Thanks for this feedback, I did not see this problem yet - but I added a comment into the xorg.conf I posted some posts back.
@Frank-NL: Can you post your Xorg.0.log? That should reveal if you are using SNA
find quote
Frank-NL Offline
Donor
Posts: 142
Joined: Sep 2012
Reputation: 1
Post: #44
I will post it when I'm home. I did enable SNA yesterday as an experiment, but don't know if it really worked... From what I've read SNA is not enabled by default so before I enabled it I had the same issue. Anyway, let's wait for the log.
find quote
George Offline
Senior Member
Posts: 128
Joined: Feb 2010
Reputation: 2
Location: The Netherlands
Post: #45
(2013-05-31 10:17)Frank-NL Wrote:  George, did you do a clean install of Raring? I did an upgrade from Quantal. Maybe I'm going to try a fresh install, it's not that much work.

I use an i3-3220 which has 2500 graphics instead of 4000. Maybe that makes a difference, although again, it worked fine under Quantal.

No, I did an upgrade from Quantal. I don't think the 2500 graphics makes a difference. Let me know if I can help you, I have SNA enabled.
(This post was last modified: 2013-05-31 12:14 by George.)
find quote
Post Reply