Fanart Grabber - script for skinners

  Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
kidhazy Offline
Junior Member
Posts: 25
Joined: Nov 2009
Reputation: 0
Location: Melbourne, Australia
Post: #91
(2014-07-31 23:41)kidhazy Wrote:  
(2014-07-31 15:43)robweber Wrote:  Hi,

I just committed 13.2 yesterday - staying on the latest and greatest!

The error you're seeing is an XBMC file error. The XFILE::CDirectoryFactory is an internal XBMC C++ class. My guess is that it doesn't like something about the picture you are trying to load. Could be characters in the filename or something about the image itself. I don't know alot about Aeon Nox but does it have views in the Movie area where you can see the fanart as a background or something? I'd be curious if you found the movie in your movie list if the background would show up there - it should be loading the same image name.

I also tried to search for that error in both the forum and on trac - couldn't find anything. Might be worth a ticket on trac.xbmc.org
Yes, the fanarts that have the 'protocol error' show as backgrounds OK in Aeon Nox if I select the movie.

I'll keep digging and might wipe out the library on a test system and rescan. I thought I noticed one fanart with the protocol error that I'd previously seen appear as one of the random fanart backgrounds - so I'm now not sure if it's a file specific error.

More testing I think.

EDIT: I just noticed Aeon Nox can still display some random fanart backgrounds correctly - even when I'm not connected to the network where the fanarts (and movies) are stored. So it must be getting it from the library image cache. But I still get the 'unsupported protocol(image)' error pointing to the SMB share location for the blank fanarts. I'll drop a post on the Aeon Nox 5 thread as well.

This turned out to be a cache issue. I ran the Texture Cache utility over my library which cached all the missing movie fanarts and now no more Unsupported Protocol errors in the log and the random fanarts all work.
find quote
robweber Offline
Posting Freak
Posts: 889
Joined: Sep 2009
Reputation: 27
Post: #92
Great. Glad you found a fix. From your description it definitely sounded like something with the cache system. Seemed like if it was already present in the cache you were fine but if it wasn't there was an issue. Maybe XBMC had issues pulling it from the SMB share?
find quote
Post Reply