[RELEASE] Chrome Launcher

  Thread Rating:
  • 4 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
$tocK Offline
Junior Member
Posts: 10
Joined: Sep 2014
Reputation: 0
Post: #211
Hi All,

I know this may be a Noob Question but I have searched this thread and the chrome launcher thread and have not found an answer Sad

I have managed to install this on my XBMCbuntu machine,

I have Google Chrome installed #38, I have the chrome launcher and the netflixbmc add-ons installed.

I also have the xdotool installed for Linux users.

Now the first problem is, When I open Netflixbmc it opens a chrome browser in kiosk mode, but the username and password does not come through? do I have to do anything to make it automatically log in?

The Main problem that I am having is when Google Chrome launches Keyboard control is not passed from XBMC to Google ChromeConfused Confused When I click the arrow buttons I can hear XBMC menu sounds?

Can someone please give me a hand?

Thanks,
(This post was last modified: 2014-10-15 08:52 by $tocK.)
find quote
$tocK Offline
Junior Member
Posts: 10
Joined: Sep 2014
Reputation: 0
Post: #212
Hi Guys,

I am finally getting somewhere,

i have managed to get the mouse and keyboard to go through to Google chrome,

I am hoping to do a how to once i'm finished as i haven't found one yet.

My last problems are:

Problem 1: I have set up my MCE remote to work with XBMC, however when i go to Netflix in Google chrome, the remote controls don't go through only the mouse and keyboard. Does anyone know how to pass the remote control to Google Chrome?

Problem 2: I have no sound. I have sound in XBMC when using the remote, but as soon as i go to Netflix, i have no sound. Does anyone know how to fix this?

Thanks,

$tocK
find quote
nickr Online
Donor
Posts: 9,041
Joined: May 2009
Reputation: 163
Location: Christchurch NZ
Post: #213
By default chrome will use the default audio device, which is probably not your XBMC output device. You may need to redefine your default device in /etc/asound.conf.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
Larske Offline
Junior Member
Posts: 9
Joined: Jan 2012
Reputation: 0
Post: #214
I am having the same problem. Everything is working fine, when i choose Youtube or NetfliXBMC from the Chrome Launcher they are both launching in fullscreen and play video. I am also able to control them with my remote control, but no sound.

As mentioned above i have edited my asound.conf but that didn't solve the problem. My config now looks like this:
Code:
pcm.!default {
      type plug
      slave.pcm {
              type hw
              card 1
              device 3
      }
}

pcm.!hdmi {
      type plug
      slave.pcm {
              type hw
              card 1
              device 3
      }
}

Card 1 and device 3 are the right ones, i have checked them with aplay and hear sound. I have also rebooted after applying the above config. .asoundrc is empty, so that is not overriding asound.conf.

I am running XBMCbuntu and have sound everywhere except from everything i launch from the Chrome Launcher. I have tested to boot into desktop mode and open the Netflix website, when i do that my sound is working. But as soon as i go through the Chrome Launcher there is no sound,

Because the sound is working on the desktop i have tried to use unity instead of openbox in my Chrome Launcher script but that doesnt solve anything.
(This post was last modified: 2014-10-18 16:41 by Larske.)
find quote
ikkeenjij36 Offline
Junior Member
Posts: 26
Joined: Jan 2014
Reputation: 0
Post: #215
Hi there i almost got the netflixbmc addon working but in the other thread over the addon they told me to get an window manager caus netflix opens in a smaal window with no sound and xbmc is still showing on the background.
Is anybody willing to help me to get this solved?
Really desperate by now cause after 2 weekends trying to get it to work i am almost there.
Thanks in advance!!!!
find quote
nickr Online
Donor
Posts: 9,041
Joined: May 2009
Reputation: 163
Location: Christchurch NZ
Post: #216
(2014-10-18 16:40)Larske Wrote:  I am having the same problem. Everything is working fine, when i choose Youtube or NetfliXBMC from the Chrome Launcher they are both launching in fullscreen and play video. I am also able to control them with my remote control, but no sound.

As mentioned above i have edited my asound.conf but that didn't solve the problem. My config now looks like this:
Code:
pcm.!default {
      type plug
      slave.pcm {
              type hw
              card 1
              device 3
      }
}

pcm.!hdmi {
      type plug
      slave.pcm {
              type hw
              card 1
              device 3
      }
}

Card 1 and device 3 are the right ones, i have checked them with aplay and hear sound. I have also rebooted after applying the above config. .asoundrc is empty, so that is not overriding asound.conf.

I am running XBMCbuntu and have sound everywhere except from everything i launch from the Chrome Launcher. I have tested to boot into desktop mode and open the Netflix website, when i do that my sound is working. But as soon as i go through the Chrome Launcher there is no sound,

Because the sound is working on the desktop i have tried to use unity instead of openbox in my Chrome Launcher script but that doesnt solve anything.

I am not sure where you got your asound settings. Try

pcm.!default {
type hw
card 1
device 3
}

ctl.!default {
type hw
card 1
device 3
}

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
Larske Offline
Junior Member
Posts: 9
Joined: Jan 2012
Reputation: 0
Post: #217
Same story with that config. Everything is working great but no sound when opening a webpage through Chrome Launcher.
find quote
Michael84 Offline
Junior Member
Posts: 1
Joined: Oct 2014
Reputation: 0
Post: #218
(2014-10-19 11:51)Larske Wrote:  Same story with that config. Everything is working great but no sound when opening a webpage through Chrome Launcher.

Hi,
I had the same Problem using chrome Launcher on Gentoo within xmbc 13.2. After deactivating GUI Sounds the sound works fine for me.
I think xbmc is blocking the audio device. Changing the Setting "keep audio device active" does only word sometimes in my case.

regards
Michael
find quote
ikkeenjij36 Offline
Junior Member
Posts: 26
Joined: Jan 2014
Reputation: 0
Post: #219
I also have the sam problem in chrome with the sam config running xbmcbuntu.
xbmc is no problem sound works with everything.
It looks like i can't select the hdmi output on my nuc.
Working without a problem on mint 17 with xbmc standalone.
Any advice is welcome.
find quote
$tocK Offline
Junior Member
Posts: 10
Joined: Sep 2014
Reputation: 0
Post: #220
It would be really helpful if someone did a How To on configuring the alsa sound issues. it looks like some people have done it and have it working.

Or even point us in the direction of a How To.

thanks,
find quote
teeedubb Offline
Donor
Posts: 2,644
Joined: Mar 2010
Reputation: 62
Location: Down Under
Post: #221
In the steam launcher signature there is a link to setting up steam and xbmcbuntu and in that there is a section for setting up either pulse audio or alsa with dmix. Each has their pros and con's, but honestly the best method would be to quit XBMC before running chrome (which isn't possible within the XBMC session in xbmcbuntu, but the guide has some info on how to achieve this, albeit with steam but the general principal applies.)

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
find quote
jawilljr Offline
Senior Member
Posts: 187
Joined: Jan 2010
Reputation: 5
Post: #222
(2014-10-20 03:46)$tocK Wrote:  It would be really helpful if someone did a How To on configuring the alsa sound issues. it looks like some people have done it and have it working.

Or even point us in the direction of a How To.

thanks,

Her is how I got audio working for Chrome.

1. In XBMC go to System->System->Audio Output and make sure "keep audio device alive" is set to Off.

2. Below is my script.sh:

Code:
#!/bin/bash
#openbox &
/usr/bin/google-chrome --alsa-output-device=plughw:1,9 "$@"
kill %1

Change the 'plughw:1,9' to whatever your alsa device is.

I Don't need openbox so I commented it out.
find quote
Larske Offline
Junior Member
Posts: 9
Joined: Jan 2012
Reputation: 0
Post: #223
(2014-10-20 17:56)jawilljr Wrote:  
(2014-10-20 03:46)$tocK Wrote:  It would be really helpful if someone did a How To on configuring the alsa sound issues. it looks like some people have done it and have it working.

Or even point us in the direction of a How To.

thanks,

Her is how I got audio working for Chrome.

1. In XBMC go to System->System->Audio Output and make sure "keep audio device alive" is set to Off.

2. Below is my script.sh:

Code:
#!/bin/bash
#openbox &
/usr/bin/google-chrome --alsa-output-device=plughw:1,9 "$@"
kill %1

Change the 'plughw:1,9' to whatever your alsa device is.

I Don't need openbox so I commented it out.

You are the hero of the day! This solved my problem! Many thanks!
find quote
Post Reply