Work in Progress - Ember Media Manager 1.4.x BETA - Discussion Thread

  Thread Rating:
  • 5 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
ZacGates Offline
Junior Member
Posts: 21
Joined: May 2013
Reputation: 0
Post: #31
I just found another bug.

When downloading trailers from youtube. If the trailer is marked with an age consent then the scrapper just hangs. You can hit cancel to get out of it, however it will not download the trailer. To view it online you have to log into youtube and verify your age. Not sure if there is anything that can be done to link your youtube account into the settings so that it downloads under your account?

here is one that you can see what happens.

Private lessons (1981)
youtube trailer http://www.youtube.com/watch?v=cJ5rqXCk0wY
find quote
T-bird_se Offline
Senior Member
Posts: 128
Joined: Mar 2013
Reputation: 3
Location: Sweden
Post: #32
(2013-09-01 15:42)m.savazzi Wrote:  
(2013-09-01 13:33)T-bird_se Wrote:  One more issue

Movies with part 1 in the title
Example:
Folder --The Twilight Saga - Breaking Dawn - Part 1 (2011)
Files------------The Twilight Saga - Breaking Dawn - Part 1 cd1.avi
Files------------The Twilight Saga - Breaking Dawn - Part 1 cd2.avi

result of scraping is that both Part 1 and cd# is removed
The Twilight Saga - Breaking Dawn -.nfo
The Twilight Saga - Breaking Dawn --fanart.jpg
The Twilight Saga - Breaking Dawn --poster.jpg

Was working in 1.3.x

Nice catch Smile

Can you tell me which is the correct name for XBMC?

should it be:
The Twilight Saga - Breaking Dawn-fanart.jpg

or
The Twilight Saga - Breaking Dawn - Part 1 cd1-fanart.jpg
The Twilight Saga - Breaking Dawn - Part 1 cd2-fanart.jpg

from my understanding of the naming convention your naming is not fully correct as the folder name and file names are different. shouldn't it be like this?
Folder --The Twilight Saga - Breaking Dawn - Part 1 (2011)
Files------------The Twilight Saga - Breaking Dawn - Part 1 (2011) cd1.avi
Files------------The Twilight Saga - Breaking Dawn - Part 1 (2011) cd2.avi

In 1.3.x you always got both xxxxxx.cd1-fanart.jpg and one without cd1 none for cd2 and that's the same for all stacked movies
I read somewherethat it's a OK naming in FRODO but I have always manually removed those .nfo and .jpg and XBMC picks them up ok (shall make some digging and see if I can find it again)
find quote
ZacGates Offline
Junior Member
Posts: 21
Joined: May 2013
Reputation: 0
Post: #33
Another bug I just found


The trailers seems to be downloading into the Ember root folder and not into the movie folder.

[Image: 4f8i.jpg]
[Image: s8li.jpg]

This scrapping was done by using the trailer only scraping. Also I still can not get the add trailer under the edit movie by clicking the plus sign. The plus sign looks normal now and not shaded. But clicking on it still does not work.

Frame extraction is not loading the movie.
(This post was last modified: 2013-09-01 21:20 by ZacGates.)
find quote
Axodious Offline
Member
Posts: 97
Joined: Sep 2010
Reputation: 0
Post: #34
(2013-09-01 03:26)steve1977 Wrote:  
(2013-08-31 23:03)m.savazzi Wrote:  the trailers should download just the URL as the previous version

Does it mean that trailer no longer download? This would be a huge loss as trailer URLs may change and downloading them will give me certainty that the trailers stay there. I am running a 1.3 version, which downloads them. Do I have to stay with the "old" version?

Yeah, it use to do one or the other. That's what I'm trying to figure out.
(This post was last modified: 2013-09-01 21:55 by Axodious.)
find quote
m.savazzi Offline
Moderator
Posts: 887
Joined: Mar 2008
Reputation: 26
Post: #35
(2013-09-01 17:34)ZacGates Wrote:  I just downloaded the 9-1 version that you uploaded today with the fixes for the other stuff and when I did the same steps I did last time and now magically all the posters are there.

So what ever was changed in this new version corrected the posters not showing up,

This is real magic!

I've not changed anything there but happy to know is solved!

If you think I'm useful please use the +/- button to raise my reputation
find quote
ohreo Offline
Junior Member
Posts: 3
Joined: Sep 2013
Reputation: 0
Post: #36
Been testing the 1.4 beta yesterday and today..

I found that the filter function is a bit off..

If i check filter "missing Items" in general, and choose a specific source.
the list still shows all items with missing items. even those from a different source than selected.
find quote
T-bird_se Offline
Senior Member
Posts: 128
Joined: Mar 2013
Reputation: 3
Location: Sweden
Post: #37
Todays testing has been data scraping and the possibility to use more than one scraper but I not been very successful

The individual scraper doesn't respect there local settings
an example of what I want to do

Scrap all data but votes and ratings from TMDB and votes, ratings from IMDB
What ever order the scrapers is setup in, all info scraping is from the last one

Another thing, when scrap i movie for the first time and come back to the edit window, it doesn't matter if you hit OK or cancel because the nfo and artwork is already saved in movie folder and thats bad
(This post was last modified: 2013-09-02 23:09 by T-bird_se.)
find quote
m.savazzi Offline
Moderator
Posts: 887
Joined: Mar 2008
Reputation: 26
Post: #38
(2013-09-02 23:07)T-bird_se Wrote:  Todays testing has been data scraping and the possibility to use more than one scraper but I not been very successful

The individual scraper doesn't respect there local settings
an example of what I want to do

Scrap all data but votes and ratings from TMDB and votes, ratings from IMDB
What ever order the scrapers is setup in, all info scraping is from the last one

Another thing, when scrap i movie for the first time and come back to the edit window, it doesn't matter if you hit OK or cancel because the nfo and artwork is already saved in movie folder and thats bad

those sound like bugs Smile

Will try to check them when I have time.

If you think I'm useful please use the +/- button to raise my reputation
find quote
DanCooper Offline
Moderator
Posts: 1,413
Joined: Apr 2012
Reputation: 72
Location: Switzerland
Post: #39
(2013-09-01 20:22)T-bird_se Wrote:  
(2013-09-01 15:42)m.savazzi Wrote:  
(2013-09-01 13:33)T-bird_se Wrote:  One more issue

Movies with part 1 in the title
Example:
Folder --The Twilight Saga - Breaking Dawn - Part 1 (2011)
Files------------The Twilight Saga - Breaking Dawn - Part 1 cd1.avi
Files------------The Twilight Saga - Breaking Dawn - Part 1 cd2.avi

result of scraping is that both Part 1 and cd# is removed
The Twilight Saga - Breaking Dawn -.nfo
The Twilight Saga - Breaking Dawn --fanart.jpg
The Twilight Saga - Breaking Dawn --poster.jpg

Was working in 1.3.x

Nice catch Smile

Can you tell me which is the correct name for XBMC?

should it be:
The Twilight Saga - Breaking Dawn-fanart.jpg

or
The Twilight Saga - Breaking Dawn - Part 1 cd1-fanart.jpg
The Twilight Saga - Breaking Dawn - Part 1 cd2-fanart.jpg

from my understanding of the naming convention your naming is not fully correct as the folder name and file names are different. shouldn't it be like this?
Folder --The Twilight Saga - Breaking Dawn - Part 1 (2011)
Files------------The Twilight Saga - Breaking Dawn - Part 1 (2011) cd1.avi
Files------------The Twilight Saga - Breaking Dawn - Part 1 (2011) cd2.avi

In 1.3.x you always got both xxxxxx.cd1-fanart.jpg and one without cd1 none for cd2 and that's the same for all stacked movies
I read somewherethat it's a OK naming in FRODO but I have always manually removed those .nfo and .jpg and XBMC picks them up ok (shall make some digging and see if I can find it again)

This is a known bug of my stacking regex Big Grin
Ember think "Part 1" is the same like CD1 or DVD1 and remove that.

In the future, only stacks at the end of the file name and without spaces are recognized. In addition, the regex can be adjusted in the settings.

Latest Ember-MM version - [Release] Ember Media Manager 1.3.x
German XBMCNerds
find quote
m.savazzi Offline
Moderator
Posts: 887
Joined: Mar 2008
Reputation: 26
Post: #40
HAHAHA

Fix on you!


I'll work on an issue on the trailer download that saves the trailers in the application folder and NOT in the movie folder Big Grin


Also I will check the issue of the info saved before OK is pressed.

If you think I'm useful please use the +/- button to raise my reputation
find quote
m.savazzi Offline
Moderator
Posts: 887
Joined: Mar 2008
Reputation: 26
Post: #41
Fixed trailers now they should save in the right folder. Please confirm.

Do not understand why info are saved before the OK, not trivial.... will continue to investigate.
Same goes for the "individual scraper doesn't respect there local settings"

In any case new beta release on my skydrive.

If you think I'm useful please use the +/- button to raise my reputation
find quote
steve1977 Offline
Posting Freak
Posts: 1,893
Joined: Dec 2006
Reputation: 0
Post: #42
(2013-09-01 10:33)Cocotus Wrote:  There haven't been any new changes to trakt.tv in current 1.4 build yet - so no changes in that area there - I'm looking into personal list feature at the moment...

Great to hear, thanks!!!

Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 12 GB DDR3 | 256 GB SSD, 40 TB (1 x 4 TB, 6 x 3TB, 9 x 2 TB)
HTPC 1: Apple Mac Mini (mid-2011) | Intel Core i5 2.5 GHz | 4GB DDR3 | 500 GB
HTPC 2: Apple Mac Mini (mid-2007) | Intel Core 2 Duo 2.0 GHz | 4 GB DDR2 | 16 GB SSD
find quote
dirtydesaster Offline
Junior Member
Posts: 33
Joined: Dec 2010
Reputation: 0
Location: Erfurt/Germany
Post: #43
hey, savazzi

can you post the date, when you upload a new version, in the first post?
find quote
T-bird_se Offline
Senior Member
Posts: 128
Joined: Mar 2013
Reputation: 3
Location: Sweden
Post: #44
Test to use bulk scraper or right click and select to scrap selected movies and all items
Posters and data is picked up OK but fanart is always empty, try to run again and now select to only scrape for fanart, once again nothing is found.
Never used this function in the past so can be me doing something wrong or it's a bug
find quote
m.savazzi Offline
Moderator
Posts: 887
Joined: Mar 2008
Reputation: 26
Post: #45
(2013-09-07 07:51)dirtydesaster Wrote:  hey, savazzi

can you post the date, when you upload a new version, in the first post?

ok

If you think I'm useful please use the +/- button to raise my reputation
find quote
Post Reply