PVR margo speed fix build

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
soulshadow Offline
Junior Member
Posts: 14
Joined: Aug 2013
Reputation: 0
Post: #1
HI, Not sure if this the correct place for my problem. So here it is,

I was having slow channel changing speeds on PVR using NEXTPVR under XBMC 12.2 windows 7 64bit os.

So i started using Margo build 12.2 this one (Prebuild Windows setup of XBMC Frodo 12.2 with channel switching speed improvements (github/margro/Frodo build).)

from this website : - http://www.scintilla.utwente.nl/~marcelg...build.html

The build is very good and the channel changing speeds was alot faster,

However the problem is i kept getting script error on two addons the two that i use and like are ITV player and Vevo. At first i thought it was a problem with my system so i reinstalled and tested again they just will not work. Though they work fine on stable 12.2 frodo.

Any help would be grateful if there is a fix for this or if there is a reason why on the margo build with channel fix it doesn't work.


Regards

Ian
(This post was last modified: 2013-09-18 17:00 by soulshadow.)
find quote
soulshadow Offline
Junior Member
Posts: 14
Joined: Aug 2013
Reputation: 0
Post: #2
Hi Again, I have had no replys to this post so, is this problem just affecting me !!
(This post was last modified: 2013-09-08 15:57 by soulshadow.)
find quote
soulshadow Offline
Junior Member
Posts: 14
Joined: Aug 2013
Reputation: 0
Post: #3
Hi this is the error log that i get for ITV player addon :-

16:57:39 T:1544 NOTICE: Produciton ID is 2/2340/0003#001
16:57:39 T:1544 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.ImportError'>
Error Contents: No module named message
Traceback (most recent call last):
File "C:\Users\Ian\AppData\Roaming\XBMC\addons\plugin.video.itv\default.py", line 942, in <module>
VIDEO(url)
File "C:\Users\Ian\AppData\Roaming\XBMC\addons\plugin.video.itv\default.py", line 538, in VIDEO
response, res = http.request("http://mercury.itv.com/PlaylistService.svc", 'POST', headers=headers, body=SoapMessage)
File "C:\Users\Ian\AppData\Roaming\XBMC\addons\plugin.video.itv\lib\httplib2.py", line 968, in request
info = email.Message.Message()
File "C:\Program Files (x86)\XBMC\system\python\Lib\email\__init__.py", line 79, in __getattr__
__import__(self.__name__)
ImportError: No module named message
-->End of Python script error report<--

If more information is need i can add more of the log.

Any reply would be grateful

Ian
(This post was last modified: 2013-09-08 17:46 by soulshadow.)
find quote
negge Offline
Team-Kodi Member
Posts: 2,350
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #4
Well, the addon is crashing, so you should contact its developer to see if he can fix it.
find quote
soulshadow Offline
Junior Member
Posts: 14
Joined: Aug 2013
Reputation: 0
Post: #5
Hi again, Thank you for your reply, but i don't think the problem is with the add-on, as the both work fine with the stable build. Also i have found that iPlayer also doesn't work on the magro fix build.

I think it must have some thing to do with the channel fix.

Any reply would be grateful

Ian
find quote
zbyna Offline
Junior Member
Posts: 21
Joined: Sep 2010
Reputation: 0
Post: #6
Amazing speed and stability. Switching channels has never been so fast !
THANKS Big Grin
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #7
@soulshadow: I've yesterday posted a Gotham alpha build with the channel switch speed improvements (same webpage). Could you try if these two addons are still broken?
I've no idea why they fail on my Frodo 12.2 build, but I can't access iPlayer in the Netherlands ;-)

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
negge Offline
Team-Kodi Member
Posts: 2,350
Joined: Dec 2010
Reputation: 25
Location: Finland
Post: #8
@margro: I haven't tried your builds but have you considered trying to push your changes upstream?
find quote
soulshadow Offline
Junior Member
Posts: 14
Joined: Aug 2013
Reputation: 0
Post: #9
Hi, Thank you for your reply Margro, Sorry about late getting back to you. Just haven't had time to get on-line etc with xbmc. I will try the new build and let you know if it works. Also i not sure if it has something to do with a location check Iplay and itv do ?!?!

Thank you for help

Regards

Ian
(This post was last modified: 2013-10-19 03:01 by soulshadow.)
find quote
margro Offline
Fan
Posts: 654
Joined: Oct 2009
Reputation: 21
Location: The Netherlands
Post: #10
(2013-10-14 22:25)negge Wrote:  @margro: I haven't tried your builds but have you considered trying to push your changes upstream?
Well according to @whaupt, this was discussed during the recent XBMC devcon as "needs more work/not yet ready for inclusion".
I will contact the @FernetMenta for more info, since he is the original author of these changes. He asked me to test it, because he couldn't test it.
The main reason for posting my test builds is to get feedback from others about things that are broken after the change (compared to the official Gotham alpha's).

I've heard that people experienced problems with some video addons and with screen refresh rate changes, so the current path is probably indeed "not yet ready".

Developer of the MediaPortal PVR addon and the Argus-TV PVR-addon. Unofficial XBMC Windows builds with PVR.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
krustyreturns Offline
Moderator
Posts: 1,598
Joined: Aug 2012
Reputation: 48
Location: Springfield Heights, CA
Post: #11
Could the speed changes be an option? say a setting in the live-tv area? It could say something like 'improved channel switching speed' with some warning about possible adverse effects.

Windows Media Center PVR addon (pvr.wmc) and server backend (ServerWMC)
http://bit.ly/ServerWMC
find quote
onlinespending Offline
Member
Posts: 60
Joined: Jan 2012
Reputation: 0
Post: #12
(2013-10-27 14:47)margro Wrote:  I've heard that people experienced problems with some video addons and with screen refresh rate changes, so the current path is probably indeed "not yet ready".

Not sure how much the above comment applies to your latest builds, but couldn't the changes be limited to just Live TV and insulated from other video rendering so as not to cause issues with other areas of Xbmc/Kodi?
find quote