cmyth client for MythTV .27

  Thread Rating:
  • 1 Votes - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
billyx Offline
Junior Member
Posts: 14
Joined: Dec 2012
Reputation: 0
Post: #16
Got it (Myth 0.27) working with Gotham alpha 7:

Code:
sudo apt-get install autoconf libtool g++
sudo apt-get install libboost-all-dev libmysqlclient-dev

wget https://github.com/fetzerch/xbmc-pvr-addons/archive/master.zip

unzip master.zip

cd xbmc-pvr-addons-master

nano addons/pvr.mythtv.cmyth/addon/addon.xml
-> Change line 9 from 1.8.0 to 1.8.1
Code:
./bootstrap
./configure --enable-addons-with-dependencies

make zip

cp addons/pvr.mythtv.cmyth-linux-x86_64.zip /tmp

Install zip file from /tmp
find quote
nerddtvg Offline
Junior Member
Posts: 4
Joined: Sep 2013
Reputation: 0
Post: #17
(2013-09-26 01:19)billyx Wrote:  -> Change line 9 from 1.8.0 to 1.8.1

I thought I had tried that in one of my iterations, but I could be wrong. I will re-test later tonight or tomorrow and report back.
find quote
nerddtvg Offline
Junior Member
Posts: 4
Joined: Sep 2013
Reputation: 0
Post: #18
(2013-09-26 01:24)nerddtvg Wrote:  
(2013-09-26 01:19)billyx Wrote:  -> Change line 9 from 1.8.0 to 1.8.1

I thought I had tried that in one of my iterations, but I could be wrong. I will re-test later tonight or tomorrow and report back.

This did work. I thought I had done that before but I guess I didn't do a full make clean as I had previous builds still sitting there.
find quote
bcrosby333 Offline
Junior Member
Posts: 7
Joined: Sep 2013
Reputation: 0
Post: #19
I tried to do a fresh build (b/c i am running it on a Raspberry Pi) with the dev xbmc-pvr-addons. Build seemed to work, but then when i go to try and enable the addon, it errors out.

I think i may have been missing a lib, so i am rebuilding now.

Anyone know how to build just the xbmc-pvr-addons-master for a pi? W/o having to do a whole Openelec build with the new addon?
find quote
teeedubb Offline
Donor
Posts: 2,024
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #20
(2013-09-27 01:01)bcrosby333 Wrote:  I tried to do a fresh build (b/c i am running it on a Raspberry Pi) with the dev xbmc-pvr-addons. Build seemed to work, but then when i go to try and enable the addon, it errors out.

I think i may have been missing a lib, so i am rebuilding now.

Anyone know how to build just the xbmc-pvr-addons-master for a pi? W/o having to do a whole Openelec build with the new addon?

Youre not building the master addonfor a frodo rpi build? The instruction on the wiki page are for building master, which is only compatible with gotham. I havent had any luck modifying those instructions to build the frodo addon with OE, I manually update the source files in the OE build directory. You can try building only the addon using instructions found here
http://wiki.openelec.tv/index.php?title=...DVB_sample
although from experience it takes just as long as a full OE compile

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
find quote
bcrosby333 Offline
Junior Member
Posts: 7
Joined: Sep 2013
Reputation: 0
Post: #21
Good to know, i wasn't aware that the mythtv addon for 0.27 wasn't compatiable with Frodo. I will try a build with Gotham instead. Thanks!
find quote
nickr Online
Donor
Posts: 6,183
Joined: May 2009
Reputation: 101
Location: Christchurch NZ
Post: #22
It IS compatible with frodo. Read the thread.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
txcas Offline
Junior Member
Posts: 20
Joined: Aug 2013
Reputation: 0
Post: #23
(2013-09-25 01:30)teeedubb Wrote:  
(2013-09-25 01:03)bcrosby333 Wrote:  Has anyone gotten this to work on a openelec system?

Yes. You need to use the OE instructions in the wiki page

http://wiki.xbmc.org/index.php?title=PVR...o_OpenELEC

Are you sure that works? I tried the instructions from the WIKI and they do not work. First we need cmyth from the Frodo branch, not the Master branch, second the script fails on the mv command.
find quote
bcrosby333 Offline
Junior Member
Posts: 7
Joined: Sep 2013
Reputation: 0
Post: #24
The script on that site doesn't work you have to change the following:

source ./packages/mediacenter/xbmc-pvr-addons/meta

with the following

source ./packages/mediacenter/xbmc-pvr-addons/package.mk

I am able to get it to build correctly after that. But i still get errors when using the addon.

Has only gotten the following to work.

- MythTV 0.27 Backend
Running on a pi-->
- OpenELEC 3.2
- XBMC Lastest based on http://wiki.xbmc.org/index.php?title=PVR...o_OpenELEC
find quote
nickr Online
Donor
Posts: 6,183
Joined: May 2009
Reputation: 101
Location: Christchurch NZ
Post: #25
Try the builds at http://www.openelec.tv/forum/20-developm...=225#87507 - you need to join and log in to the forum to access the development subforum where they are posted.

This is the ION build I compiled a couple of days ago

https://www.dropbox.com/s/nqq5yzwsud0e6n...r16019.tar

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
(This post was last modified: 2013-10-01 00:58 by nickr.)
find quote
teeedubb Offline
Donor
Posts: 2,024
Joined: Mar 2010
Reputation: 42
Location: Down Under
Post: #26
(2013-09-30 21:30)txcas Wrote:  
(2013-09-25 01:30)teeedubb Wrote:  
(2013-09-25 01:03)bcrosby333 Wrote:  Has anyone gotten this to work on a openelec system?

Yes. You need to use the OE instructions in the wiki page

http://wiki.xbmc.org/index.php?title=PVR...o_OpenELEC

Are you sure that works? I tried the instructions from the WIKI and they do not work. First we need cmyth from the Frodo branch, not the Master branch, second the script fails on the mv command.

I havent used those instructions in a while and instead rerplace the mythtv-addon source in the OE build directory manually with the contentsof the appropriate zip file downloaded from git hub, in the root of the build dir run
Code:
rm -rf ./build.OpenELEC*/.stamps/xbmc-pvr-addons ./build.OpenELEC*/xbmc-pvr-addons-* ./build.OpenELEC*/image/.stamps/xbmc-pvr-addons
and rebuild OE.

My Add-ons, only available for XBMC:
Steam Launcher|Music Party Mode|Reboot2oOS|Triple J Radio
(This post was last modified: 2013-10-01 01:41 by teeedubb.)
find quote
bcrosby333 Offline
Junior Member
Posts: 7
Joined: Sep 2013
Reputation: 0
Post: #27
Rbej's builds work.

You can find them here -> http://netlir.dk/rbej/builds/index.php?dir=Gotham/

I am running the one from 9/11. Plex + MythTV + Raspberry Pi all are working.

Amazing!
find quote
nickr Online
Donor
Posts: 6,183
Joined: May 2009
Reputation: 101
Location: Christchurch NZ
Post: #28
Rbej's builds may work, but only if you have pi!

Here is a generic OE build which works with 0.27 and is Gotham based.

https://www.dropbox.com/s/pehdgiizam1oge...r16019.tar

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
txcas Offline
Junior Member
Posts: 20
Joined: Aug 2013
Reputation: 0
Post: #29
(2013-09-30 22:48)bcrosby333 Wrote:  The script on that site doesn't work you have to change the following:

source ./packages/mediacenter/xbmc-pvr-addons/meta

with the following

source ./packages/mediacenter/xbmc-pvr-addons/package.mk

I am able to get it to build correctly after that. But i still get errors when using the addon.

Has only gotten the following to work.

- MythTV 0.27 Backend
Running on a pi-->
- OpenELEC 3.2
- XBMC Lastest based on http://wiki.xbmc.org/index.php?title=PVR...o_OpenELEC
This was very helpful. I think the other thing that needs to be changed in the script is to replace everywhere the word "master" with "frodo". If you use the master branch it will get the Gotham version of cmyth instead of the Frodo version. That might explain the errors you are getting. I just ran the script with these changes and I am now compiling an Intel build to see if it works...
find quote
txcas Offline
Junior Member
Posts: 20
Joined: Aug 2013
Reputation: 0
Post: #30
Just wanted to confirm that the following script will get cmyth 1.6.11 on OE, and then you just have to compile your own build:

Code:
#!/bin/bash

source ./packages/mediacenter/xbmc-pvr-addons/package.mk

if [ ! -d ./sources/$PKG_NAME/ ]; then
    mkdir -p ./sources/$PKG_NAME/
fi
wget --no-check-certificate https://github.com/fetzerch/xbmc-pvr-addons/archive/frodo.zip
unzip frodo.zip
mv xbmc-pvr-addons-frodo $PKG_NAME-$PKG_VERSION
tar -cJf $PKG_NAME-$PKG_VERSION.tar.xz $PKG_NAME-$PKG_VERSION
rm -r $PKG_NAME-$PKG_VERSION frodo.zip

mv $PKG_NAME-$PKG_VERSION.tar.xz ./sources/$PKG_NAME/
md5sum sources/$PKG_NAME/$PKG_NAME-$PKG_VERSION.tar.xz > sources/$PKG_NAME/$PKG_NAME-$PKG_VERSION.tar.xz.md5
echo "http://sources.openelec.tv/devel/$PKG_NAME-$PKG_VERSION.tar.xz" > ./sources/$PKG_NAME/$PKG_NAME-$PKG_VERSION.tar.xz.url

rm -rf ./build.OpenELEC*/.stamps/xbmc-pvr-addons ./build.OpenELEC*/xbmc-pvr-addons-* ./build.OpenELEC*/image/.stamps/xbmc-pvr-addons

I can now get Live TV, and see my recordings on OE. For some reason the channel icons are not coming over from the backend and I seem to have a weird issue changing channels. Besides that, everything else is working.
find quote
Post Reply