cmyth client for MythTV .27

  Thread Rating:
  • 2 Votes - 1.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
kristianhk Offline
Junior Member
Posts: 2
Joined: Oct 2013
Reputation: 0
Location: Oslo, Norway
Post: #31
Does anyone other than me have problems with XBMC (12.2) freezing a bit after stopping a recording? I can't start another program (or do much else in XBMC) until after a minute or so, when an error message pops up (will update the post with this error, can't recall it right now).

This usually happens when there is only a few minutes left of the recording, and I think it's related to saving the bookmark in the recording, as I get entries like this in the mythbackend log:

Code:
Sep 23 18:57:43 mediabox mythbackend: mythbackend[22234]: E ProcessRequest mainserver.cpp:784 (ProcessRequestWork) Bad SET_BOOKMARK


I also found this in the MythTV 0.27 release notes (http://www.mythtv.org/wiki/Release_Notes_-_0.27):

[a8722fa] Correct sanity check on SET_BOOKMARK protocol command Fixes #11104

EDIT:
Forgot to mention: using the 1.6.11 version of xbmc-pvr-addons (from https://github.com/fetzerch/xbmc-pvr-addons.git), frodo branch.
Is the frodo branch being updated, or am I out of luck?
(This post was last modified: 2013-10-03 13:52 by kristianhk.)
find quote
jorara Offline
Junior Member
Posts: 3
Joined: May 2013
Reputation: 0
Post: #32
Thanks to the guide from txcas I have finally succeeded in building a version of OpenELEC that supports MythTV 0.27.

My problem now is that my custom build doesn't recognize my PulseEight USB-CEC Adapter.

Can anyone tell me how to get support for the before mentioned adapter in my custom build?
find quote
txcas Offline
Junior Member
Posts: 20
Joined: Aug 2013
Reputation: 0
Post: #33
(2013-10-03 13:49)kristianhk Wrote:  Does anyone other than me have problems with XBMC (12.2) freezing a bit after stopping a recording? I can't start another program (or do much else in XBMC) until after a minute or so, when an error message pops up (will update the post with this error, can't recall it right now).

This usually happens when there is only a few minutes left of the recording, and I think it's related to saving the bookmark in the recording, as I get entries like this in the mythbackend log:

Code:
Sep 23 18:57:43 mediabox mythbackend: mythbackend[22234]: E ProcessRequest mainserver.cpp:784 (ProcessRequestWork) Bad SET_BOOKMARK


I also found this in the MythTV 0.27 release notes (http://www.mythtv.org/wiki/Release_Notes_-_0.27):

[a8722fa] Correct sanity check on SET_BOOKMARK protocol command Fixes #11104

EDIT:
Forgot to mention: using the 1.6.11 version of xbmc-pvr-addons (from https://github.com/fetzerch/xbmc-pvr-addons.git), frodo branch.
Is the frodo branch being updated, or am I out of luck?

I am having the same problem.
find quote
cfetzer Offline
Fan
Posts: 307
Joined: Jul 2011
Reputation: 16
Post: #34
This issue is now fixed in the development repository.

The frodo branch has been updated as well with some recent fixes.

MythTV PVR addon - Wiki - Development
find quote
txcas Offline
Junior Member
Posts: 20
Joined: Aug 2013
Reputation: 0
Post: #35
(2013-10-06 13:59)cfetzer Wrote:  This issue is now fixed in the development repository.

The frodo branch has been updated as well with some recent fixes.

Thanks. I was able to get cmyth 1.6.12 on OpenElec, now trying to compile it on Ubuntu. So far so good on OE.
find quote
glenb77 Offline
Junior Member
Posts: 3
Joined: Nov 2012
Reputation: 0
Post: #36
which is the file to use for the 'developemnt repository'. using master.zip i continue to get a 'bad set_bookmark' error in my backend log after building the addon. Thanks for any help with this.
find quote
kristianhk Offline
Junior Member
Posts: 2
Joined: Oct 2013
Reputation: 0
Location: Oslo, Norway
Post: #37
(2013-10-09 10:56)glenb77 Wrote:  which is the file to use for the 'developemnt repository'. using master.zip i continue to get a 'bad set_bookmark' error in my backend log after building the addon. Thanks for any help with this.

Checkout the latest code with git:

git clone https://github.com/fetzerch/xbmc-pvr-addons.git
cd xbmc-pvr-addons
git checkout frodo

Or if you prefer a zip: https://github.com/fetzerch/xbmc-pvr-add.../frodo.zip should give you the latest.

EDIT:
Didn't see you said 'Development repository' - guess that means the master development version of XBMC?
In that case, it should be fixed now if you download the latest from https://github.com/fetzerch/xbmc-pvr-add...master.zip

Thanks for the fix, btw. Works great for me.
(This post was last modified: 2013-10-11 23:48 by kristianhk.)
find quote
glenb77 Offline
Junior Member
Posts: 3
Joined: Nov 2012
Reputation: 0
Post: #38
I am using the nightly build on linux, which is the gotham; using the git from above (not frodo.zip). I get bad SET_BOOKMARK in the backend log and an error message in xbmc.
find quote
simora Offline
Member
Posts: 83
Joined: Nov 2012
Reputation: 0
Post: #39
Mythtv 0.27, XBMC 12.2 ARM Amlogic (J1nx build), PVR Addon 1.6.12 (ab0639ca394d9757eb312d93e704d8f9b990e0c6)

If i watch a recording and am watching the recording when a recording on the backend begins XBMC segfaults. Thats it. It also happens during LiveTV playback. I believe it happens during video library items playback such as a file off a cifs share. cfetzer wanted the full gdb log and debug log from xbmc. i pruned the xbmc log because the myth addon is very very chatty and pastebin doesn't like such huge logs.

GDB log:
http://pastebin.com/d5wVZfeB

XBMC log (only the last five minutes to get it under the pastebin limit):
(And removed all "MythTV cmyth PVR Client: ReadRecordedStream" lines and "PVRTimers - UpdateEntries"
http://pastebin.com/ddXpw1pn
(This post was last modified: 2013-10-16 17:15 by simora.)
find quote
cfetzer Offline
Fan
Posts: 307
Joined: Jul 2011
Reputation: 16
Post: #40
(2013-10-16 17:10)simora Wrote:  Mythtv 0.27, XBMC 12.2 ARM Amlogic (J1nx build), PVR Addon 1.6.12 (ab0639ca394d9757eb312d93e704d8f9b990e0c6)

If i watch a recording and am watching the recording when a recording on the backend begins XBMC segfaults. Thats it. It also happens during LiveTV playback. I believe it happens during video library items playback such as a file off a cifs share. cfetzer wanted the full gdb log and debug log from xbmc. i pruned the xbmc log because the myth addon is very very chatty and pastebin doesn't like such huge logs.

GDB log:
http://pastebin.com/d5wVZfeB

XBMC log (only the last five minutes to get it under the pastebin limit):
(And removed all "MythTV cmyth PVR Client: ReadRecordedStream" lines and "PVRTimers - UpdateEntries"
http://pastebin.com/ddXpw1pn

I saw this issue once before, but I'm unable to reproduce it. However I do think that I found the issue in the code.
Could you apply the following patch on top of your fetzerch/xbmc-pvr-addons branch and try it?
https://github.com/fetzerch/xbmc-pvr-add...beaa.patch

If it resolves the issue, we can merge it in.

Cheers, Christian

MythTV PVR addon - Wiki - Development
find quote
allen00se Offline
Member
Posts: 85
Joined: Apr 2011
Reputation: 0
Post: #41
(2013-10-06 13:59)cfetzer Wrote:  This issue is now fixed in the development repository.

The frodo branch has been updated as well with some recent fixes.

So just to clarify, you are saying that the frodo branch is now compatible with MythTV .27?
find quote
cfetzer Offline
Fan
Posts: 307
Joined: Jul 2011
Reputation: 16
Post: #42
(2013-10-18 20:32)allen00se Wrote:  
(2013-10-06 13:59)cfetzer Wrote:  This issue is now fixed in the development repository.

The frodo branch has been updated as well with some recent fixes.

So just to clarify, you are saying that the frodo branch is now compatible with MythTV .27?

Yes exactly. The frodo dev branch (github.com/fetzerch/xbmc-pvr-addons).

MythTV PVR addon - Wiki - Development
find quote
nickr Offline
Donor
Posts: 8,029
Joined: May 2009
Reputation: 141
Location: Christchurch NZ
Post: #43
And working well.

If I have helped you or increased your knowledge, click the plus button and increase my reputation :)
find quote
allen00se Offline
Member
Posts: 85
Joined: Apr 2011
Reputation: 0
Post: #44
great so i guess my next question is, has anyone used the combination of Infinitv 6 eth > mythtv .27 > cmyth > xbmc yet? I am thinking about making the switch but my infinitv 4 usb has been so solid lately im not sure if I want to be a pioneer of the infinitv 6 eth.

thanks,
Krys
find quote
simora Offline
Member
Posts: 83
Joined: Nov 2012
Reputation: 0
Post: #45
(2013-10-17 23:35)cfetzer Wrote:  
(2013-10-16 17:10)simora Wrote:  Mythtv 0.27, XBMC 12.2 ARM Amlogic (J1nx build), PVR Addon 1.6.12 (ab0639ca394d9757eb312d93e704d8f9b990e0c6)

If i watch a recording and am watching the recording when a recording on the backend begins XBMC segfaults. Thats it. It also happens during LiveTV playback. I believe it happens during video library items playback such as a file off a cifs share. cfetzer wanted the full gdb log and debug log from xbmc. i pruned the xbmc log because the myth addon is very very chatty and pastebin doesn't like such huge logs.

GDB log:
http://pastebin.com/d5wVZfeB

XBMC log (only the last five minutes to get it under the pastebin limit):
(And removed all "MythTV cmyth PVR Client: ReadRecordedStream" lines and "PVRTimers - UpdateEntries"
http://pastebin.com/ddXpw1pn

I saw this issue once before, but I'm unable to reproduce it. However I do think that I found the issue in the code.
Could you apply the following patch on top of your fetzerch/xbmc-pvr-addons branch and try it?
https://github.com/fetzerch/xbmc-pvr-add...beaa.patch

If it resolves the issue, we can merge it in.

Cheers, Christian

It is no longer segfaulting but it is causing the video to buffer. Still trying to track down what that is. I have found that if clients terminate without notifying the server, is my guess, the server begins spitting out ThreadedFileWriter took too long errors. That causes a lot of video buffering. Have to restart the myth backend to clear it all up.
find quote
Post Reply